Welcome! Log In Create A New Profile

Advanced

Skeinforge 44 first layer

Posted by DeltaFlight 
Skeinforge 44 first layer
November 01, 2011 12:21PM
I notice a strange behaviour with Object First Layer settings in Raft.
With these vaules:
Object First Layer Feed Rate Infill Multiplier (ratio): 1.0
Object First Layer Feed Rate Perimeter Multiplier (ratio): 1.0
Object First Layer Flow Rate Infill Multiplier (ratio): 1.0
Object First Layer Flow Rate Perimeter Multiplier (ratio): 1.0

I get following G-code (first extruding lines, retraction is set to 8):

G1 X59.64 Y30.36 Z0.4 F1200.0 E8.9853
G1 X59.64 Y49.64 E9.9743

But when I set first layer to half speed, not changing anything else:

Object First Layer Feed Rate Infill Multiplier (ratio): 0.5
Object First Layer Feed Rate Perimeter Multiplier (ratio): 0.5
Object First Layer Flow Rate Infill Multiplier (ratio): 0.5
Object First Layer Flow Rate Perimeter Multiplier (ratio): 0.5

I get this:

G1 X59.64 Y30.36 Z0.4 F600.0 E9.9706
G1 X59.64 Y49.64 E11.9486

So the speed is lower, extruded amount is bigger. Prints get definitely too much plastic. Why is it so?
Re: Skeinforge 44 first layer
November 04, 2011 10:23AM
Have you fixed it?
If not: can you create a penultimate gcode file and post here?
So we can have a look at it and help..


IRC: #reprap on freenode.net (Action68)
[github.com]
Re: Skeinforge 44 first layer
November 07, 2011 05:41AM
For a while I'd rolled back to skeinforge 43. I've reported this bug to Enrique.
Just in case, I'm attaching here file I'd sent to Enrique.
I think penultimate.gcode diff says for itself:

(< setting> raft Interface_Nozzle_Lift_over_Interface_Layer_Thickness_(ratio): 0.45 )
(< setting> raft Name_of_Support_End_File: support_end.gcode )
(< setting> raft Name_of_Support_Start_File: support_start.gcode )
-(< setting> raft Object_First_Layer_Feed_Rate_Infill_Multiplier_(ratio): 1.0 )
-(< setting> raft Object_First_Layer_Feed_Rate_Perimeter_Multiplier_(ratio): 1.0 )
-(< setting> raft Object_First_Layer_Flow_Rate_Infill_Multiplier_(ratio): 1.0 )
-(< setting> raft Object_First_Layer_Flow_Rate_Perimeter_Multiplier_(ratio): 1.0 )
+(< setting> raft Object_First_Layer_Feed_Rate_Infill_Multiplier_(ratio): 0.4 )
+(< setting> raft Object_First_Layer_Feed_Rate_Perimeter_Multiplier_(ratio): 0.3 )
+(< setting> raft Object_First_Layer_Flow_Rate_Infill_Multiplier_(ratio): 0.4 )
+(< setting> raft Object_First_Layer_Flow_Rate_Perimeter_Multiplier_(ratio): 0.4 )
(< setting> raft Operating_Nozzle_Lift_over_Layer_Thickness_(ratio): 0.5 )
(< setting> raft Raft_Additional_Margin_over_Length_(%): 1.0 )
(< setting> raft Raft_Margin_(mm): 3.0 )
@@ -216,7 +216,6 @@
M113 S1.0
M104 S245.0
(< layer> 0.4 )
-M104 S244.317
(< rotation> (0.707106781187+0.707106781187j) )
(< nestedRing>)
(< boundaryPerimeter>)
@@ -231,14 +230,14 @@
G1 F1800.0
M101
G1 X40.6399 Y30.3252 Z0.4 F240.0 E8.228
-M108 S19.55
-G1 X59.68 Y30.32 Z0.4 F1055.6923 E9.1926
-G1 X59.68 Y49.68 Z0.4 F1055.6923 E10.1735
-G1 X40.32 Y49.68 Z0.4 F1055.6923 E11.1543
-G1 X40.32 Y30.6452 Z0.4 F1055.6923 E12.1187
+M108 S30.0
+G1 X59.68 Y30.32 Z0.4 F486.0 E11.4434
+G1 X59.68 Y49.68 Z0.4 F486.0 E14.7129
+G1 X40.32 Y49.68 Z0.4 F486.0 E17.9824
+G1 X40.32 Y30.6452 Z0.4 F486.0 E21.1969
G1 F798.0
-G1 E11.6157
-G1 F1055.6923
+G1 E20.694
+G1 F486.0
M103
(< /perimeter>)
(< /boundaryPerimeter>)

Edited 1 time(s). Last edit at 11/07/2011 05:44AM by DeltaFlight.
Attachments:
open | download - 44raft.zip (49.1 KB)
Re: Skeinforge 44 first layer
November 08, 2011 07:33AM
Update: Enrique resolved this bug in latest build.
Sorry, only registered users may post in this forum.

Click here to login