Welcome! Log In Create A New Profile

Advanced

Newbie Here - Manual Extrude works great, Auto Extrude Inop

Posted by BrnRubbr 
Newbie Here - Manual Extrude works great, Auto Extrude Inop
December 17, 2011 03:20PM
So I just entered the RepRap community and of course I have a few errors while setting up the new machine. It figures, I am hoping you all can point me in the right direction for a hopeful and easy fix.

Setup....
Prusa Mendal
Arduino Mega 2560
RAMPS 1.4
Prontorface (setup step-by-step using [github.com])
Skeinforge for STL's

I muddled through all of the software and then got everything in the correct directories with Skeinforge downloaded for STL's. After I get everything turned on, heated up and ready to go, I delved into ensuring the XYZ axis are all aligned correctly and the Opto Stops are good to go. All is well, then I check manual extrusion, that is good to go also (I may need to par back on this in the future because a 5mm seems MUCH longer, but that a different beast).

So I load a simple Mendal gear part file into Pronterface, no errors and it seemed to load the layers fine. I press print and the XYZ servos are working great...... but the extruder is not working at all (not a little, not a lot, just nothing). Weird, I go back to manual mode and the extruder works fine. I am just scrubbing G-Code and Pronterface settings right and I cannot find anything. I suspect the problem is something simple and overlooked by me in Skeinforge.

Oh wise ones, please point me in the right direction. I would not be surprised if I did not check one single box or setting. Feel free to yell at me ifI should upload any files or settings. I am hoping you all could easily help me.

Thanks for any help,
Sean
Re: Newbie Here - Manual Extrude works great, Auto Extrude Inop
December 17, 2011 04:43PM
Ok, found one problem. To use the Extruder, the "Activate Dimension" box must be checked. So extruder is extruding..... ish.

Next problem, after I press print, but before the extruder begins printing, the extruder has been executing a retract command. Any thoughts on how to eliminate this extraction command?

I really cannot afford to retract since this really screws up the plastic filament and the plastic filament no longer fits inside the extruder afterwords.
Re: Newbie Here - Manual Extrude works great, Auto Extrude Inop
December 19, 2011 02:55AM
In your start.gcode you need to set extruder position to zero: G92 E0.


Bob Morrison
W├Ârth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Newbie Here - Manual Extrude works great, Auto Extrude Inop
December 19, 2011 09:10PM
Sorry Mr. or Ms. Skeinforge...... I am in love with Slic3r. It is frickin' unbelievable!!!!!! Up and running in 10 minutes.

Cheers,
Sean
Sorry, only registered users may post in this forum.

Click here to login