Welcome! Log In Create A New Profile

Advanced

Skeinforge 50 no extruder temps

Posted by aka47 
Skeinforge 50 no extruder temps
November 06, 2012 01:58PM
Guys

Something I just noticed.

Skeinforge 50 is not putting gcode instructions into the gcode file to set the extruder temperature.

It used to do this OK a while ago but now there is none.

I am guessing this was intentional. How do we make Skeinforge50 do like it used to and put them in the gcode ??

Cheers

aka47


Necessity hopefully becomes the absentee parent of successfully invented children.
Re: Skeinforge 50 no extruder temps
November 06, 2012 03:04PM
For me Skeinforge 50 does indicate extruder temperatures into gcode … … …

(but as I don't want different temperatures according to layers during prints, I let Temperature plugin deactivated and set extruder temperature into start.gcode)


François
Re: Skeinforge 50 no extruder temps
November 06, 2012 04:39PM
It could be somethign silly I am doing, been banging my head against this one all afternoon.

First thing I checked was Activate Temperature was ticked. Even unchecked the box that removes reundant mcodes just in case it was being a touch over zealous.

I only noticed the problem when I stopped preheating the extruder in pronterface.

Look mum no temperatures...... It goes straight into the G1 printing statements. It also seems to be dead keen on settings for motor extruders rather than stepper extruders as well.

G90
G21
G28
M105
M106
M113 S1.0
M108 S8.0
G1 X66.984 Y106.971 Z0.2 F600.0
G1 F798.0
G1 E2.0
G1 F600.0
M101
G1 X67.488 Y108.468 Z0.2 F480.0 E2.1891
G1 X76.752 Y124.705 Z0.2 F480.0 E4.4274
G1 X82.125 Y128.161 Z0.2 F480.0 E5.1923
G1 X101.368 Y126.475 Z0.2 F480.0 E7.5053
G1 X103.583 Y123.183 Z0.2 F480.0 E7.9805

Edited 1 time(s). Last edit at 11/06/2012 04:39PM by aka47.


Necessity hopefully becomes the absentee parent of successfully invented children.
Re: Skeinforge 50 no extruder temps
November 06, 2012 11:13PM
Make Plugin "Chamber" ON

Hardwarekiller
Re: Skeinforge 50 no extruder temps
November 07, 2012 04:15AM
Hardwarekiller: arent You confusing SFACt with SF?
SFACT has a Temperature setting in Chamber that is put into gcode at the start, not skeinforge AFAIK..


www.reprapfordummies.net
IRC: #reprap on freenode.net (Action68)
[github.com]
Re: Skeinforge 50 no extruder temps
November 07, 2012 04:40AM
Here is a profile which gives extruder temp lines into gcode: you can compare with the profile you are using…


François
Attachments:
open | download - PLA Bleu 4043D.zip (21.9 KB)
Re: Skeinforge 50 no extruder temps
November 07, 2012 05:53AM
Umm already tried chamber, it does put in some temps but looks like it is only for the chamber not the extruder.

I would'nt mind but the printer I am sorting for a friend doesnt have a chamber or a controlled heated bed. But thanks for the thought though.

I am slowly coming round to the idea that there might be a bug in skeinforge 50 that was'nt in the last version I was using (45).

Thanks Francois I will try that over the next couple of nights.

Funnily enough the PLA I am trying to print with is indeed blue.

What a star...

Thanks

aka47


Necessity hopefully becomes the absentee parent of successfully invented children.
Re: Skeinforge 50 no extruder temps
November 07, 2012 06:35AM
In the meantime as a workaround you can place the temperature in your start.gcode.

Far from perfect as it is not changing with profiles, but could help for some time until you find what happens.

Did you check your replace.csv is not misconfigured to remove those gcodes ?


Most of my technical comments should be correct, but is THIS one ?
Anyway, as a rule of thumb, always double check what people write.
Re: Skeinforge 50 no extruder temps
November 07, 2012 07:10AM
Yup I have no replace.csv, already hacked the start Gcode.

It is a bodge indeed, and misses out on the interlayer temperature changes.

If it turns out to be a bug/feature, and no one says anything though it is'nt likely to get fixed.


Necessity hopefully becomes the absentee parent of successfully invented children.
Re: Skeinforge 50 no extruder temps
November 07, 2012 07:11AM
aka47 when did you download it? and is it the stable or the beanshell version?


www.reprapfordummies.net
IRC: #reprap on freenode.net (Action68)
[github.com]
Re: Skeinforge 50 no extruder temps
November 07, 2012 07:18AM
Hullo

I downloaded :-

2012-03-15 20:07:28 CET (Click to Download)

from :-

[fabmetheus.crsndoo.com]

On Monday 5 /11/2012

It is currently being used on my laptop in place of the 45 version I was using (Same build of laptop etc)

[email protected]:~$ uname -a
Linux quicksilver 3.2.0-33-generic #52-Ubuntu SMP Thu Oct 18 16:29:15 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

64Bit Ubuntu, think it is 12.04

I can have a look for the python vers etc if you need it.


Necessity hopefully becomes the absentee parent of successfully invented children.
Re: Skeinforge 50 no extruder temps
November 07, 2012 07:34AM
I just re downloaded and run it..
No problems...
G90
G21
M103
M105
M106
M140 S60.0
M141 S30.0
M142 S0.0
M113 S1.0
M108 S210.0
M104 S200.0
my first lines..
can you please enable the penultimate gcode option in export and then copy paste the top part of the gcode or upload the gcode file. (the penultimate one...)


www.reprapfordummies.net
IRC: #reprap on freenode.net (Action68)
[github.com]
Re: Skeinforge 50 no extruder temps
November 08, 2012 04:49AM
Ok Here's the penultimate.

Ignore the start.gcode as i put a set temp in here as a temporary workaround.

You can see it see the temperatures though but not set any.

Just about to try the PLA Blue profile next.


Necessity hopefully becomes the absentee parent of successfully invented children.
Attachments:
open | download - androidfm_penultimate.gcode.zip (224.5 KB)
Re: Skeinforge 50 no extruder temps
November 08, 2012 05:42AM
And heres the gcode and penultimate for running the PLA Blue profile on the same stl file.

The penultimate file has temp settings in and the final gcode one doesnt.

Rather strange.


Necessity hopefully becomes the absentee parent of successfully invented children.
Attachments:
open | download - PLAB.zip (380.9 KB)
Re: Skeinforge 50 no extruder temps
November 08, 2012 05:52AM
OK double checking for replace.csv I only fine the one I have created just this time to be sure that there was one there....

As you can see there are only start stop extruder commands (irrelevant on marlin and on a stepper driven mendel)

[email protected]:~$ find ./ -name replace.csv
./.skeinforge/alterations/replace.csv
[email protected]:~$ cat ./.skeinforge/alterations/replace.csv
M101
M103

My copy of skeinforge is in

[email protected]:~$ find ./ -name skeinforge.py
./applications/skeinforge50/skeinforge_application/skeinforge.py

So falls within the search path.


Necessity hopefully becomes the absentee parent of successfully invented children.
Re: Skeinforge 50 no extruder temps
November 08, 2012 07:36AM
have you tried to disable the alteration function?


www.reprapfordummies.net
IRC: #reprap on freenode.net (Action68)
[github.com]
Re: Skeinforge 50 no extruder temps
November 08, 2012 11:00AM
Have you tried totally redoing your settings from scratch ?
I remember that sometimes when upgrading skeinforge - that was when it was still regularly maintained - settings used to get corrupted, the only solution being to remove the whole .skeinforge directory - keep a backup for reference ofc - and start from scratch.


Most of my technical comments should be correct, but is THIS one ?
Anyway, as a rule of thumb, always double check what people write.
Re: Skeinforge 50 no extruder temps
November 08, 2012 12:12PM
DeuxVis, are you sure Skeinforge is'nt regularly maintained? of course Skeinforge 50 came eight months ago, but if you download the last version the date into fabmetheus_utilities/version.txt is today's date… I am asking myself about this difference, perhaps Enrique makes "official releases"… from time to time now…?

Andy, going from scratch as DeuxVis says is the best idea from now…


François
Re: Skeinforge 50 no extruder temps
November 08, 2012 12:27PM
Thanks for staying with me on this guys.

Yes I had done a from scratch setup before I posted here.

The only thing I can think is that there is some python or library issue that skeinforge is bumping into and producing the odd results.

To sort out the machine that I was working on for one of the RUG, I hacked out some start and end gcode scripts for now that should see him straight for a while.

Is there a git repo or some such for skeinforge. Everythign else seems to have gone this way but not skeinforge.

I tend to mirror such things and my update scripts keep them up to date. The 50 version must be getting a little old now.

For working copies I copy the current state of play to my applications area.

Other than that it looks like waiting for the next release to see if it makes any difference.

Wget'ing the file and then uncompressing etc only realy works easily if the file name stays the same. Which you would'nt want for continual updates.


Necessity hopefully becomes the absentee parent of successfully invented children.
Re: Skeinforge 50 no extruder temps
November 09, 2012 02:26AM
I am keeping sort of an unofficial Repo of the SF releases..

You can find it on Github..
Just follow the Sfact link...


www.reprapfordummies.net
IRC: #reprap on freenode.net (Action68)
[github.com]
Re: Skeinforge 50 no extruder temps
November 09, 2012 05:58AM
aka, there's no public version control access to skeinforge that I know, you could probably keep up to date with the last version zip that François posted a link for - note that this is probably not stable, for instance I see there are two different temperatures modules in the last one, probably some work in progress there.


So you're right François, didn't check that latest version, this might be a good idea to still submit patches to enrique then.

As a side note, the date I see in version.txt is 31/10/2012.


Most of my technical comments should be correct, but is THIS one ?
Anyway, as a rule of thumb, always double check what people write.
Re: Skeinforge 50 no extruder temps
November 09, 2012 06:20AM
DeuxVis Wrote:
-------------------------------------------------------

> As a side note, the date I see in version.txt is
> 31/10/2012.

yes, not yesterday's date!…


François
Re: Skeinforge 50 no extruder temps
November 09, 2012 07:24AM
The temperature tool after raft is called QQTemperature, to distinguish it from the before temperature tool. Currently it does not have circling, it only adds temperatures.

This is for cleaning up the workflow in SF, it is not tested yet...


www.reprapfordummies.net
IRC: #reprap on freenode.net (Action68)
[github.com]
Re: Skeinforge 50 no extruder temps
November 09, 2012 08:45AM
The funny thing is that the most up to date version (That I downloaded and am struggling with) is the 15th of march.

[fabmetheus.crsndoo.com]

I guess this is one of the benefits of git or perhaps nay version control system.

It is always clear which bit is older/newer.

Should I perhaps be using a differents source ?? This is the one thrown up top of the list in Google.


Necessity hopefully becomes the absentee parent of successfully invented children.
Re: Skeinforge 50 no extruder temps
November 09, 2012 09:17AM
The march one is the stable release one, The filename is preceded by the versiıon number.
The one from October is the development version and might contain bugs..

[github.com]


www.reprapfordummies.net
IRC: #reprap on freenode.net (Action68)
[github.com]
Sorry, only registered users may post in this forum.

Click here to login