Welcome! Log In Create A New Profile

Advanced

Skeinforge: Starting Z off, First F Layer off

Posted by amyrlam 
Skeinforge: Starting Z off, First F Layer off
October 18, 2013 07:28PM
I attached my custom Skeinforge settings, along with the .stl file and corresponding gcode from Skeinforge.

(1) Why does Z start at 0.01 instead of 0? (Line 6)
(2) Why does F start at 2400 (Line 11) for what seems to be Layer 0, but be F 6000 (Line 187) elsewhere? I'd like F to be at 6000 throughout.

Would appreciate any help on how to tweak these settings, thank you!
Attachments:
open | download - ML.zip (19.7 KB)
open | download - Cubeuntitled_mm.20131018_153407.gcode.zip (340.7 KB)
open | download - Cubeuntitled_mm.stl.zip (869 bytes)
Re: Skeinforge: Starting Z off, First F Layer off
October 19, 2013 04:39AM
(2) Why does F start at 2400 (Line 11) for what seems to be Layer 0, but be F 6000 (Line 187) elsewhere? I'd like F to be at 6000 throughout.
Disable Limit Plugin


www.reprapfordummies.net
IRC: #reprap on freenode.net (Action68)
[github.com]
Re: Skeinforge: Starting Z off, First F Layer off
October 20, 2013 05:34AM
> (1) Why does Z start at 0.01 instead of 0? (Line 6)

You probably have value(s) in Bottom plugin, or in Raft/Operating Nozzle Lift over Layer Thickness.

(Bottom must be activated, even with 0 values, for Raft/Operating Nozzle Lift over Layer Thickness value to be taken in acount.)

I suppose you are sure of your Z values, not 1/10 mm but 1/100 mm scale? Z value at the beginning of a print should be more or less half of layer height, not 0…

Edited 2 time(s). Last edit at 10/20/2013 05:40AM by François Delègue.


François
Re: Skeinforge: Starting Z off, First F Layer off
October 21, 2013 05:33PM
@ahmetcemturan Thanks for your response! I unchecked Activate limit but that did not change anything - F was still at 2400 until Line 187. (I then tried changing the Maximum Initial Feed Rate to match my Speed > Feed Rate of 100 mm/s to see if it would change F, even though Activate Limit was unchecked, but it did not.)

Edited 1 time(s). Last edit at 10/21/2013 05:59PM by amyrlam.
Re: Skeinforge: Starting Z off, First F Layer off
October 21, 2013 06:10PM
@François Delègue Thank you so much, I was able to get my Z to start at 0! Did not realize from the code that I needed to tweak Bottom and Raft!

I'm tweaking/hacking Skeinforge to get the gcode output we want for a custom application, so ok for Z to start at 0.
Re: Skeinforge: Starting Z off, First F Layer off
October 22, 2013 03:16AM
Are You using SFACT or Skeinforge?


www.reprapfordummies.net
IRC: #reprap on freenode.net (Action68)
[github.com]
Re: Skeinforge: Starting Z off, First F Layer off
October 22, 2013 03:45AM
@ahmetcemturan Skeinforge
Re: Skeinforge: Starting Z off, First F Layer off
October 22, 2013 04:38AM
Can You Post the Gcode file and Your settings with:
Limit Disabled
Penultimate Gcode enabled...
I suspect that You are not really disabling the Limit Plugin.. (It could be finding a discrepant csv file elsewhere..)


www.reprapfordummies.net
IRC: #reprap on freenode.net (Action68)
[github.com]
Re: Skeinforge: Starting Z off, First F Layer off
October 24, 2013 05:51PM
@ahmetcemturan Sorry for the delay! See attached files. In my Gcode, F = 2400 at Layer 0 (Z = 0) and jumps to F = 6000 at Layer 1. Would like F to be 6000 throughout!
Attachments:
open | download - ML_FINDER.zip (17.3 KB)
open | download - Cubeuntitled_mm.20131024_144005.gcode.zip (114.4 KB)
Re: Skeinforge: Starting Z off, First F Layer off
October 25, 2013 04:45AM
There should be a file created like.... filename_penultimate.gcode I need that one..(because it includes settings and commnets created by the program.


www.reprapfordummies.net
IRC: #reprap on freenode.net (Action68)
[github.com]
Re: Skeinforge: Starting Z off, First F Layer off
October 25, 2013 04:52AM
amyrlam Wrote:
-------------------------------------------------------
> @ahmetcemturan Sorry for the delay! See attached
> files. In my Gcode, F = 2400 at Layer 0 (Z = 0)
> and jumps to F = 6000 at Layer 1. Would like F to
> be 6000 throughout!

Because you have in Speed plugin:

Object First Layer Feed Rate Infill Multiplier (ratio): 0.4
Object First Layer Feed Rate Perimeter Multiplier (ratio): 0.4
Object First Layer Flow Rate Infill Multiplier (ratio): 0.4
Object First Layer Flow Rate Perimeter Multiplier (ratio): 0.4

6000*0.4 = 2400 for the 1st layer… you should set those parameters to 1…

Edited 1 time(s). Last edit at 10/25/2013 04:53AM by François Delègue.


François
Re: Skeinforge: Starting Z off, First F Layer off
October 25, 2013 05:24AM
Then its SFACT ???


www.reprapfordummies.net
IRC: #reprap on freenode.net (Action68)
[github.com]
Re: Skeinforge: Starting Z off, First F Layer off
October 28, 2013 06:44PM
@François Delègue - That worked, sorry that was such an obvious fix that I missed.

@ahmetcemturan - Just looked up SFACT, I'm just using SF-50 from [github.com] so I don't think I'm on SFACT.

Your help has been much appreciated! Sorry for the slow responses just totally overwhelmed with work and I'm new to coding/Skeinforge. One last question:

I want to save these custom settings to the code so that someone else can pull the custom settings like they would if they selected extrusion > ABS from the dropdown. If I add a set of my profile .csv's to the code in skeinforge/skeinforge_application/profiles/extrusion will that work? Or should each new user just add those .csv files to their local ~/.skeinforge folder? Wasn't sure if the custom settings in the code would be overwritten by the local ~/.skeinforge folder. How are the initial settings saved for the extrusion > ABS profile and others? Only temperature.csv is in skeinforge/skeinforge_application/profiles/extrusion/ABS and others and I was confused by that.

P.S. @ahmetcemturan - Downloading your SFACT now to see how you modified the code.

Edited 1 time(s). Last edit at 10/28/2013 07:38PM by amyrlam.
Sorry, only registered users may post in this forum.

Click here to login