Welcome! Log In Create A New Profile


Extruder Stepper In and Out

Posted by jcabrer 
Extruder Stepper In and Out
May 02, 2011 04:51PM
Can anyone shed light on which setting might cause the extruder to move in and out during printing?

I'm getting acquainted with RepG and Skeinforge 39 with my RAMPS/Sprinter/Prusa, and I've almost got it, but when the print starts, the extruder seems to go back and forth in mostly equal distances, so the net effect is that there is nothing extruded. I'm sure this is part of what normally controls the cutoff of flow during moves where material should not be extruded, but it seems to be maladjusted. From the sound of it, Oozebane is the setting, but disabling it does not affect the problem.
Re: Extruder Stepper In and Out
May 02, 2011 05:11PM
Look in the 'Dimension' tab. See what you have 'Extruder Retraction Speed', 'Retraction Distance' and 'Restart Extra Distance' set to.

For the moment try setting 'Retraction Distance' and 'Restart Extra Distance' to zero to switch off retraction and see if that helps.

You'll probably want to configure these settings to something sensible at some point to avoid oozing problems.


Blog: AdventuresIn3-DPrinting
Re: Extruder Stepper In and Out
May 03, 2011 07:14AM
From what you tell it looks like the Retraction is working but your actual filament extrusion is not happening...
It could be that You have some Gigantic settings for the filament diameter (2.8) or the packing density ratio (try with 1)
!!Note that the decimal has to be POINT not comma!!
Re: Extruder Stepper In and Out
May 08, 2011 02:50PM
@jcabrer: Can you post an update so People who have similar problems can find a solution.

Re: Extruder Stepper In and Out
May 08, 2011 10:59PM
@jcabrer - Turn off oozebane. It's not meant for stepper motor controlled extruders. Also look at your g-codes and look at the E parameters. They might be too small and so all you're seeing is the retract/restart. Turning off retract/restart is a good suggestion as you will see if this is the case. I recommend using SF 41 instead and adjusting your firmware setting for E steps per mm accordingly. See the skeinforge forum for a discussion on setting this.
Re: Extruder Stepper In and Out
May 09, 2011 12:19AM
Well, fir me the solution has been to abandon the current approach, and try something else. I found a Portable Skeinforge on the wiki, both 40 and 41, and I disabled all of the functions that try and pull filament back in. Even with this, the extruded was turning backward when I started to print in RepSnapper.

I finally figured out the the SF generated gcode was trying to perform a HOME on the extruder. To fix this, I home all three axis, and extrude a little just before Print.
Re: Extruder Stepper In and Out
May 09, 2011 03:32AM
jcabrer: You seem to have found a solution for a problem thats different then waht you describe. You fix the Homing of E by homing all three axis??
The homing of E is done after the retract so we dont have to deal with 1000s of mm's. Nothing else...
So it is needed...
And when you moved to SF40/41 have you changed your E-steps in the Firmware?

Thank you for the update btw.
Re: Extruder Stepper In and Out
May 09, 2011 11:26AM
It's the manual extrude before printing that does the trick. Let's say that you start a print, and for whatever reason, you pause it in RepSnapper, and then you click restart. The counter on the extruder axis wants to go back to Zero for the restrat. The end result is that the extruder turns backwads.

Same scenario, you pause, but before hitting restart, you manually extrude. At the end of the extrude, the E axis counter resets to zero, so there is no backward move required. Voila!
Re: Extruder Stepper In and Out
May 09, 2011 03:37PM
If you are priming your extruder by extruding before you actually print then check out this thread for a solution.

But I must say your description of your problem does not sound like this is what is causing it.
Re: Extruder Stepper In and Out
May 09, 2011 11:59PM
@jcabrer - do you see a G92 E0 in your g-code? If so, please post your g-code file up to that line. That command resets the extruder to 0.0.
Sorry, only registered users may post in this forum.

Click here to login