Welcome! Log In Create A New Profile

Advanced

[solved] Approach to first printed path is wicked slow

Posted by imitation 
[solved] Approach to first printed path is wicked slow
September 23, 2011 06:06PM
Hi everyone,

as i'm getting my Sells and Skeinforge dialed in and solid, there's one more bug (?) that i haven't squashed. The gcode Skeinforge generates looks like this:

...start.gcode
G90
G21
M103
M105
M106
M140 S122.0
M141 S30.0
M142 S0.0
M113 S1.0
M108 S38.0
M104 S237.0
M108 S13.68
and then this:
G1 X36.33 Y85.1 Z0.2 F60.0

F60 is way too slow, it can take around two minutes for the head to travel to the start position. Normally i travel at F18000 and the print always rolls down just fine and with the right speed.

Ideas?

Thanks,
-imitation-

Edited 1 time(s). Last edit at 09/24/2011 04:39AM by imitation.
Re: Approach to first printed path is wicked slow
September 24, 2011 01:30AM
If your firmware supports a maximum z feedrate, set it to something your z axis can handle.
Then disable the limit plugin in skeinforge or sfact.


Manufacturer of low tolerance Filaments PLA, ABS, ASA, PETG, TPU, PA, PVA,
[www.miafilament.com]
[github.com]
Re: Approach to first printed path is wicked slow
September 24, 2011 03:43AM
In Carve - Limit Set your Maximum Initial Feed Rate to your normal speed.


Bob Morrison
W├Ârth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Approach to first printed path is wicked slow
September 24, 2011 04:39AM
Thank you all!
Disabling Limit did the trick:
G1 X69.62 Y92.45 Z0.2 F751100.3928
Sprinter is set up for my maximum X/Y/Z/E Speeds, so this should work.

Thanks again!
-imitation-
Re: [solved] Approach to first printed path is wicked slow
September 24, 2011 01:08PM
Nice, not sure that you will get good prints at 12000mm/s winking smiley
Anyway you shouldnt let fw handle all speed control. That will mess up duration based calcs in skeinforge..
Always use reasonable values.


Manufacturer of low tolerance Filaments PLA, ABS, ASA, PETG, TPU, PA, PVA,
[www.miafilament.com]
[github.com]
Re: [solved] Approach to first printed path is wicked slow
September 24, 2011 04:14PM
Of course, i'm setting the general traveling and printing speeds in "Speed" (70mm/s btw), the fw limits only kick in with manual G0 moves or that one approach move.
Limit only offers me two options - "Initial Feed" and "Z Feed". I don't think disabling initial feed will mess up anything, and z feed shouldn't make much of a difference time-wise either since z moves are always less than a fraction than a second.

Edited 1 time(s). Last edit at 09/25/2011 04:25AM by imitation.
Sorry, only registered users may post in this forum.

Click here to login