SD card printing
October 04, 2011 05:48PM
Is there a wiki or some sort of information on SD card printing anywhere? I have been looking all over. I have the Sanguinololu electronics (1.2). I saw the post above with the MicroSD card adapter (Gravitech). If I set that up how do I get it to print from the SD card? Does it have to be loaded on there a specific way? What file format does the SD card have to be? Any specific naming conventions?

Thanks all for your help. I just about have all the parts and I am hoping to put it together this weekend! smiling smiley
Re: SD card printing
October 05, 2011 07:00AM
I have no experience with SD card printing, but I've seen that pronterface has some buttons to do that :


Re: SD card printing
October 06, 2011 12:10AM
Pronterface SD card printing

1. Load file button for .stl Skeining or .gcode loading to Pronterface.
2. SD upload button to your SD micro card (slow). OR pull the card out of SL and copy the gcode (8.3 format) file to the microSD from PC to the card. Place the card back to SL.
3. SD print button to select file from SL microSD that you want to print.
SD card doesn't work
October 10, 2011 08:58AM
Hello,

I use Ramps 1.3 with SD-Ramps from RepRapWorld. Problem, SD-Ramps doesn't work. I installed Kliments firmware and enabled SDSUPPORT.
LED doesn't shine and Printrun says that SD int fails. We checked power with multimeter, but there is no power on the small board.
Has anyone an idea what I can do, or is some more information needed?

Thanks

Klaus

PS: I use a Shapercube 2.0 with Arduino Mega 2560 and Ramps 1.3 with Kliment-Sprinter-f832569 Firmware.

Edited 1 time(s). Last edit at 10/10/2011 09:01AM by kkberg.
Re: SD card doesn't work
March 01, 2013 06:48AM
Hi im tryin to use SD ramps, im enabled it in marlin. the software pronterface can pick up the sd card and read the file. when i click on the file it loads the file and starts printing. however when i press the disconnect or pull out the cable from the pc it stops printing. the led is on on the arduino when i plug out the usb and the D1 and D2 is installed on the ramps.

Does anyone know where im going wrong.
Im naming the files test.gco this is ok isnt it?
thanks
Re: SD card doesn't work
June 01, 2014 07:30PM
Quote
fredted1234
Hi im tryin to use SD ramps, im enabled it in marlin. the software pronterface can pick up the sd card and read the file. when i click on the file it loads the file and starts printing. however when i press the disconnect or pull out the cable from the pc it stops printing. the led is on on the arduino when i plug out the usb and the D1 and D2 is installed on the ramps.

Does anyone know where im going wrong.
Im naming the files test.gco this is ok isnt it?
thanks

Hi,

If you are still having this problem, I might be able to help. You need to pull out the little jumper between the 2 chips. This will enable your reprap to run without input from the pc.

You will see it in the pic inside the yellow box.

When you do this, the ramps gets power from your power supply also. So the red led will not come on and you cannot connect to your printer until you turn on your power.

Also if you send the gcode from pronterface it will take forever. Instead save it on the micro sd card in your computer and then plug that into your printer.

Let me know how you go.

Greg
Attachments:
open | download - ramps jumper.jpg (131.7 KB)
Sorry, only registered users may post in this forum.

Click here to login