Bought a presoldered kit, rewired a nema17. Now it just squeaks.
January 11, 2012 09:01AM
Ok, so I bought a second presoldered complete sanguinololu kit from a seller over at emakershop.
The first one I think was blown because a heating element resistorleg got lose and shorted things out...

This time around I hooked everything up, connected with pronterface to check if everything worked. Some axis moved in the wrong direction, temperature worked, did not have time to check if the element work as the x-axis did some strange sounds.

I powered off quick and rewired x-axis properly this time as cat5 cables/connectors seem to be mostly lies.
When everything was soldered and installed I tried connecting with pronterface, to no avail. With the PSU it just makes a squeaky sound.

Thanks a lot in advance for adequate answers.

  • I have only rewired X as it made a horrible sound.
  • The stepper pot is at the 1/4 open. (see sellers complete set)
  • I can not connect.
  • I use pronterface, sprinter and the arduino ide.
  • It shows up according to dmesg*.
  • Pronterface just says: "Connecting..."
  • Reconnecting the usb cable does not help.

* usb 4-1: new full speed USB device number 11 using uhci_hcd
ftdi_sio 4-1:1.0: FTDI USB Serial Device converter detected
usb 4-1: Detected FT232RL
usb 4-1: Number of endpoints 2
usb 4-1: Endpoint 1 MaxPacketSize 64
usb 4-1: Endpoint 2 MaxPacketSize 64
usb 4-1: Setting MaxPacketSize 64
usb 4-1: FTDI USB Serial Device converter now attached to ttyUSB1

Edited 2 time(s). Last edit at 01/11/2012 09:45AM by danielpublic.
Re: Bought a presoldered kit, rewired a nema17. Now it just squeaks.
January 17, 2012 06:38AM

I’ve Used Think 3d Print 3d several times, he’s a genuine guy and does great products in record time,

First things first

Unplug everything (inc your Pololu’s) (incorrectly wired end stops can cause disconnection problems)

Plug it into the USB port only and ensure the drivers have installed correctly (device manager, windows 7 needs to check online for the correct driver)

Only when this is complete will Pronterface pick it up

Open Pronterface and confirm the com pot is set correct (check in device manager)

Check your baud rate is set to 115200 (sprinters default)

Try connecting now

Should say connecting for a few seconds prior to connecting

When testing

Only plug in one Pololu when testing, blowing 4 is expensive!

Wiring them up is easy if you have the datasheet for you steppers, it should tell you which pair are in which phase and even a pos or negative if required (sometimes they mix up Phase 1&2 for Phase A&B and +/- can be either A/B or 1/2

Your Sanguino will denotes them as: Phase (1/2) +/- (A/cool smiley A being positive) (on the silk screen on the top)

If your stuck post your stepper motors back and we will solve it out for you

That way your motors will move in the correct way and won’t be cross wired.

Test with just PSU power, 1 Pololu and 1 Motor (no end stops or thermistors etc)

Power down completely and reposition the Pololu and motor between each axis.
When every axis has been tested add end stops one at a time
Check there wired right vs. []
(Although your may not be a Huxley its well written on the wiring front for Sanguino and worth referencing to check things)

Sorry, only registered users may post in this forum.

Click here to login