Welcome! Log In Create A New Profile


Help Diagnosing - Not all axis are working

Posted by drewsipher 
Help Diagnosing - Not all axis are working
May 08, 2012 12:23PM
Hey Guys,
I'm new to the forum and repraps, and wondering if anyone can help me to fix/diagnose what is going on.

I have built a Prusa Mendel with a Sanguinololu 1.3a board, atMega644P Chip running Sprinter , and when I connect to the board with Pronterface or ReplicatorG I can get some of the axis to move.

Mostly, The Z-axis works. I have had success with the E-axis and just recently the X-axis. But I cannot for the life of me, figure out why the Y-axis isn't working.

Originally, on my first try, only the Z-axis was working. The firmware was loaded to the chip when I bought it, so I did some digging and managed to correctly upload my own configuration of Sprinter to the chip. That helped and got the E-axis working. I changed some settings (_AXIS_STEP_PER_UNIT was set to {80, 80, 3200/1.25,700}, I changed to be {800,800,800,700}) and uploaded it again. This managed to get the X-Axis working for a short period of time.

I then tried Teacup firmware, and that didn't work at all. No success on any axis.

I don't know what to do from here. How can I find out what is wrong? Any help would be greatly appreciated!
Re: Help Diagnosing - Not all axis are working
May 09, 2012 10:13AM
Just an Update:

Last night I managed to borrow a friends Stepsticks (duplicates of what I am already using) and some new Pololu A4988 stepper drivers.

And that seemed to do it. The Pololu A4988's worked pretty well. I managed to get all 4 axis working with 3 polulu's and one stepstick

I found one axis that was working for sure (to make sure it wasn't the chip or the board or the firmware), and tested each stepper driver off of it. I ended finding 2 Stepsticks out of the 8 that worked. And 3 of the 4 Pololu A4988 were working. Perhaps I was sold a bad Pololu from Mix Shop, and perhaps I had fried the Stepsticks previously

I hope that my logic is correct and that it was truly the stepper drivers. Some axis seem to run a bit hot though. I will update if I find any other info.
Re: Help Diagnosing - Not all axis are working
May 09, 2012 11:49AM
These drivers are sensitive and easy to fry. There is a very hidden and small note that cautions you in regards to connecting and disconnecting the stepper motor from the board with power applied. I, like you, was testing my steppers using one axis and was plugging and unplugging the stepper motors with power applied to the board. The driver kind of survived, but died a week or so after the tests. I ended up replacing it. While waiting for the replacement I found the hidden caution, but I can not remember where. If you unplugged the steppers from the drivers with the power on, then most likely you fried the board. If the board is not fried, it may act strange (stepper making whining noises) and eventually die.

Just my 2 cents.
Re: Help Diagnosing - Not all axis are working
May 09, 2012 12:24PM
Thanks egenoup,
I figured that was the case and always disconnected, unpowered, and de-static-ed (is that a word) the board before changing the stepper drivers.
However, having them seated backwards on the first attempt to power up the board may have damaged one or two of them. Lesson learned.
Sorry, only registered users may post in this forum.

Click here to login