Welcome! Log In Create A New Profile


2nd hand Sanguniololu 1.3a - Setup / Connection troubles

Posted by LShearer 
2nd hand Sanguniololu 1.3a - Setup / Connection troubles
September 09, 2013 08:04AM
I would like some help on where to next, if you can.

I have a second hand sanguinololu 1.3a which I know has previously worked within the current setup, under yje care of an IT/Electronics professional.

Thus far I have
1) Connected external power
I have connected to the external power slot, 12V, from a 800W computer PSU. At the moment it has green-ground shorted on the 20/24 pin header.

2) Established physical connection to computer
Using USB-A to USB-B, 1m cable from a header which is directly mounted on the motherboard (No Hub).
I have installed the driver on he Windows PC to enable COM3 communications (Virtual Com Port USB drivers from [www.ftdichip.com])
Attaching makes the happy-USB sound
Attachng also seems to makeattached stepper-motors make a step - as does pressing the reset button when marlin firmware is on the device.

3) Installed additional software
Installed Arduino IDE (http://arduino.cc/en/Main/Software)
Downloaded Sanguino files for Arduino IDE and put into hardware directory
Downloader Pronterface / Printrun (https://github.com/kliment/Printrun)

4) Addressed error "avrdude: stk500_getsync() : not in sync: resp=0xed"
Baud rate changed in settings for Arduino IDE so it is set to 34800
Changed CM device in Device Manager to same.
Can now start uploading, by pops an error after getting some communication back from board (header sizes, memory locations)
Can get some "Invalid characters" and junk in Pronterface

5) Addressed error "invalid device id"
Added following to sanguinololu hardware settings (Actually, did it manually with AVRDUDE first, also tried to delay slightly with -B4 and -B6 without sucess)
After loading this with reset bitton held down until initialisation, I have been able to load several sketches including Blink and Marlin firmware - And AVRdude gets a good readback / validation. It no longer needs the -F flag or to hold down reset.

6) "Angry red light"
I'm still just getting a solid red light. Despite cold shutdown (all power disconnected) and pressing red light, able to switch out different sketches and get good verifications.

Pronterface cannot connect when marlin is on.

So, questions:
A) How do I tell if / what bootloader is on the device? Can I dump it over the USB or do I need another connection?
cool smiley Have I bought a brick?
C) Anything I have missed up to this point?
Re: 2nd hand Sanguniololu 1.3a - Setup / Connection troubles
February 25, 2014 03:14PM
does this help
Sorry, only registered users may post in this forum.

Click here to login