Welcome! Log In Create A New Profile


No Com Port

Posted by bgrieco 
No Com Port
November 05, 2013 11:31AM
I am hoping someone can help me. I just bought a 3D printer with a Sanguinolu board Rev 1.3a and sprinter firmware. I am using Windows 7 and its a 32 bit machine. The printer was connected and worked perfect for a day. The following day when I went to use it, the COM 3 port that showed under device manager disappeared. Now when I plug in the USB its says device malfunctioned and Windows error code 43. If I try to update the driver it says driver up to date, Ive tried using a different computer, deleting and reinstalling the driver, downloading new drivers, pressing the reset button on the board. I have no idea how to get this to show back under COM ports. Any information you can give me would be great and if you need any more info please let me know. Thanks so much.
Re: No Com Port
December 02, 2013 11:31AM
what kind of driver are you using? can you link it?
try to install this:

Edited 1 time(s). Last edit at 12/02/2013 11:47AM by massimiliano.
Re: No Com Port
October 22, 2014 12:21AM
I just hit this same problem with a brand new Win 7 (sp1) + (all windows update) box built just for managing 3D printer builds,...

I was just about to claim that the link above does not solve this particular problem (though i knew i needed that driver) when on a whim (or perhaps out of desperation) i downloaded the older v2.10.00 version,.. guess what, the old one includes one additional needed driver and now everything works as expected!,. SO,. if your having problems with the latest version of the ftdichip install and your on a Win7 build,. try the older v2.10.00 it squashed the error message (code 43) for me =)

you may still get the error message,. if you do, make sure to refresh your com ports in your slicing software, and select the new one that just popped up!
Sorry, only registered users may post in this forum.

Click here to login