Welcome! Log In Create A New Profile


sad smileyMotors not working - reprap Huxley Sanguinololu

Posted by fujisama 
sad smileyMotors not working - reprap Huxley Sanguinololu
March 18, 2014 06:29AM
Hi everyone,

I'm asking for help. I can't drive any stepper motors on my reprap sad smiley

I built my reprap Huxley from reprappro two years ago, and it was working well. Since THE day.
I don't now why, maybe the heabed regulation was defective... I think that a surintensity destroyed my atmega, then it was impossible de communicate with it.
So I bought a new sanguinololu 1.3a assembled and tested to provide any problem. But without stepper drivers (I thougt there was only a problem with atmega or ftdi).

My config is:
-Reprap Huxley
-Sanguinololu 1.3a
-Marlin 1.0.1

When I recieved sanguinololu I loaded marlin firmware, I only check these 3 lines before:
#define SERIAL_R 4700

Now when I launch pronterface, it's blocked on "connecting..." (com port and baudrate are ok), and I don't hear the motors initialisation like before...
If I click on "reset printer", all functionnalities are functionnals(...) (heatbed, extruder heat, captors...), exept motors.

I don't know what to do then...

I tried the montage below, to check each stepper motors an driver with an arduino mega (almost totally copied from Jose Perez de Lama).

With the code found here..
But none motors or drivers works, (maybe I missed something?).

Is it possible that I broke down all the 4 stepper motors in one time ? I think the lm7805 is overheated too (I can't touch it, without connecting USB, only 19V supply).

What can I do, I'm quite desperate now (I broke my arduino mega yesterday too, due to badluck...) ?


Edited 9 time(s). Last edit at 03/18/2014 06:58AM by fujisama.
Re: sad smileyMotors not working - reprap Huxley Sanguinololu
March 25, 2014 04:13AM
Does anyone know why my motors don't want to initialize (Pronterface blocks on "connecting" and there is no motor noise at this step) ?
Do you think, it'a a problem with atmega, or stepper drivers ? .

Re: sad smileyMotors not working - reprap Huxley Sanguinololu
March 30, 2014 05:18AM
Hi Fujisama,

Try measuring what your PSU gives out. It might give out 12V DC but not enough amps. This lead to a similar problem with my build, The chip will be powered from the USB, and seams to work but the motors require more amps.


Re: sad smileyMotors not working - reprap Huxley Sanguinololu
April 10, 2014 03:29PM
Hi Aris,

I tried to use my multimeter to measure amps like this, but the meter consumes too much energy (extruder's fan runs slowly).

I also try with another old computer PSU ATX (350W), but when I connect it to my board, PSU stops (it's very old, maybe it could not suplly so much amps, even with 350W)...

Pfiuu after buying a new sanguino + atmega and 4 stepper controllers (recieved today), I have to buy another PSU ?

Edited 1 time(s). Last edit at 04/10/2014 03:32PM by fujisama.
Re: sad smileyMotors not working - reprap Huxley Sanguinololu
May 26, 2014 09:54AM
Ok, I think I have a shortcut on my new sanguinololu board...

I would like to try my Huxley with RAMPS 1.4, but I am scared about marlin configuration.

Is it easy to change from sanguinololu to RAMPS 1.4 with a reprap Huxley ?
I'm scared about SD card reader, heatbed control and non convetionnal dimension of Huxley's bed.

What do you think ?
Re: sad smileyMotors not working - reprap Huxley Sanguinololu
May 27, 2014 06:14AM
It works !

The first problem was issue to a short which burn ftdi, atmega and one stepper stick...

With my new sanguinololu, the problem was from marlin firmware. To fix this I took it on reprappro github, and inverted X axis motor polarity and now it works ! (I don't really understand what was the problem)

PSU problems was a wrong approach, those I tried where undersized (300W ??), that's why it turned off when connected.

Thanks smiling smiley
Sorry, only registered users may post in this forum.

Click here to login