Welcome! Log In Create A New Profile


Printrun stuck "connecting" to Sanguinololu

Posted by cobrageek 
Printrun stuck "connecting" to Sanguinololu
June 02, 2014 11:55PM
I have a sanguinololu that I've been able to successfully upload firmware to at 57600 on Com4 from my windows 8 machine. I have wired it the rest of the way to the motors, heaters and switches and it still powers up fine (red light and all), but pintrun (set with same Com and baud settings) gets stuck saying "Connecting". It will do this forever until I turn off the printer and then it comes up with errors.

Any ideas on what I should try? I went back to arduino and was still able to build and upload the firmware even with everything plugged in.

I don't know if it matters, but I made sure to move the reset jumper "off" when trying to run and connect with printrun but "on" when uploading firmware.

Should I try unplugging everything and seeing if I can get connection? Anything else to try?
Re: Printrun stuck "connecting" to Sanguinololu
June 03, 2014 12:05AM
Something else interesting I noticed is that when I hit the reset button on the Sanguinololu, the X, Y and Extruder motors "freeze" and make a bit of a humming noise for a few seconds. After the reset they stop buzzing and are free to move by hand again.

I also tried unplugging the limit switches and heaters and it still wouldn't connect. I then unplugged all the stepper motors and it still made no difference. Now the only things plugged in are the power and USB (and the stepper motor drivers).

Any ideas?
Re: Printrun stuck "connecting" to Sanguinololu
June 03, 2014 06:27AM
Try a serial terminal, like PuTTY, GtkTerm, CoolTerm. Bootloader and firmware have each their own serial communications (with possibly different baud rates), so having a working bootloader for uploading doesn't neccessarily mean firmware serial communications works, too.

Generation 7 Electronics Teacup Firmware RepRap DIY
Re: Printrun stuck "connecting" to Sanguinololu
June 03, 2014 10:23AM
Thanks Traumflug. I'll download one of the serial terminals and try to get a connection. The printrun baud rate matches the windows com port setting and the same as the arduino settings in boards.txt (57600), but there must be something else going on.

Is there any page with help on how to communicate to the sanguinololu using a serial terminal? I know there are G-codes and M-codes, but I'm not really sure how to get a connection and get things going in general.
Thanks for the help.
Re: Printrun stuck "connecting" to Sanguinololu
June 03, 2014 11:48AM
I just thought of another possible problem. I have the panelolu2 LCD panel that I soldered together and the firmware is configured for this. But when I power up the unit with the panelolu2 connected the back linght comes on for a few seconds and after about 5 seconds it goes off and so does the LED on the sanguinololu - that seems like a bad sign to me. I haven't done much debug on this figuring that I'd get the base sanguinololu working first and do some more short testing on the panelolu2 board before trying again.

But I'm wondering if the firmware being configured for the panelolu2 is getting stuck somewhere in boot-up because I don't have that plugged in? Should I reconfigure the firmware to not have that board and see if that helps? (any tips on getting the panelolu2 debugged?).
Re: Printrun stuck "connecting" to Sanguinololu
June 03, 2014 11:36PM
OK, I've spent a bunch of time tonight and made some great progress. (Thanks for the tips on this thread and a few others).

I think my biggest problem was pointed out in the post by Traumflug but I didn't recognize it at first. I was using the bootloader baudrate assuming that it was the same for any communication. But Marlin has it's own baudrate setting which by default is much faster than the bootloader.

Second problem was that the default baudrate for marlin is 250000 which is great and supported by printrun, but not by windows (or at least the drivers I found). Once I switched everything to 115200 (which has a note in marlin that it's not as stable unfortunately) I finally got some communication going. BTW, does anyone know how to get windows driver to work at 250000?

Once I had that and hit the reset button on the sanguinololu it would display a bunch of information in the terminal (I was first using putty but it also worked in printrun terminal). This pile of text ended with an error and it was complaining about extruder temp. I had unplugged everything so it had no temp feedback for the extruder tip. After experimenting with a few things it turns out that plugging in the thermistor for the extruder tip resolved that error.

After this I was hoping to be able to get the motors to move from printrun, but it still didn't work. I had suggested doing a firmware build without the LCD panel seeing as how that wasn't working and I couldn't plug it in so I tried uploading that and sure enough that did the trick. I could now use the quick interface in printrun to move all the motors and even get the extruder tip to heat up. So I think the basic pieces of the printer are now functioning.

If anyone has help on getting 250000 baudrate to work in windows please let me know. Also any tips on debugging the panelolu2 would be great (but I'll probably just start with my ohm meter and start checking for shorts and look at everything with a magnifying glass. Thanks!
Re: Printrun stuck "connecting" to Sanguinololu
June 04, 2014 04:41AM
Never heard of windows having an issue with that baud, except old XP

But give 230400 a go. Its what a lot of linux users use (which can have issues with 250000)
Re: Printrun stuck "connecting" to Sanguinololu
June 05, 2014 11:31AM
Just a quick update for anyone following this saga... Last night I focused on the Panelolu2 issues and was able to pin down the problem to the 5V to 3.3 regulator. It looks like the kit came with the wrong part. It's supposed to be a LM340MP, but what I was sent in the kit and soldered down said "TJ" on one line and "3CMD2CE" on the next. Can't find anything on google to help identify this. It's the same package but it appears to be the wrong part and heats up instantly when I switch on the power (the +5V in must be shorting somehow when the power is switched on). The upstanding person who sold me the kit is standing behind their product and sending me the right part and I think it should be fine after a swap.

Dust, thanks for the idea on 230400. I'll give that a shot. it doesn't appear to be a standard option from the printrun pull-down menu, but it seemed to take it when I typed it in directly, so hopefully it will work. I'll try that out next and then start working on leveling the bed and calibration. Thanks for all the help from this forum. I couldn't have done it without this help!
Sorry, only registered users may post in this forum.

Click here to login