Welcome! Log In Create A New Profile


Problems With Sanguino

Posted by blcArmadillo 
Problems With Sanguino
April 09, 2010 03:48AM
I just soldered up my Sanguino and plugged it in. I tried testing it by just uploading the blink example that comes the arudino software. When I try to upload it to the board I get the following errors:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Any ideas what the problem might be? Also the red debug led is blinking... is it supposed to be? Thanks in advanced for any help.
Re: Problems With Sanguino
April 09, 2010 12:38PM
If its a steady blink then you probally do not have the bootloader firmware for the arudino IDE env installed.

The LED should blink rapidly after you press the reset button. About five blinks, a slight pause and then another blink.

If it does not have the bootloader then you have to use a ISP programmer to upload it. There is bunch of different options to do this.

I have a blog on how to make an adapter cable to use the TTY serial cable to accomplish this.

Re: Problems With Sanguino
May 06, 2010 07:02AM
Does the bootloader firmware for the arduino IDE come with arduino0018 ?
Re: Problems With Sanguino
May 07, 2010 02:46AM
Not an expert here, but have been popping in and out looking at the variations in different Arduino supported processors (in my humble opinion). It looks like the differences are handled in the libraries for each board type.

The biggest item is having a boot loader that matches the Arduino development environment. A significant factor in that is what the processor speed is and that is mainly controller by the oscillator type, internal at 8mhz verse external at 16mhz (for a 20mhz chip), etc.

With 16mhz being the winner since that was the default for the Arduino, though the wild card is the recently release of new chips (bleeding edge) that have 32mhz as a internal clock frequency, etc.

The outstanding question in my mind being, does the main chip used for the Sanguino have enough CPU cycles to do RepRap at 8mhz(just use a bare chip!)?

Anyway Makerbot is a typical startup, long on promises, short on attention to detail so probably at a quality level of 98.5% rather then 99.99999, so when someone has problem we ask how do your LEDS blink?

As a virgin chip blinks all data lines once per second as a default program, verses an operational loader that blinks the LED on pin 0, three or four times; pauses then blinks one more time.

Arduino 018 does come with a boot loader, though it is for an Arduino hardware configuration, not the Sanguino which you have to configure that separately since the Sanguino is not in their main development cycle.

Also you then come into the realm of how do you load the bootstrap onto the processor chip?

A number of users have found the following post helpful:

Re: Problems With Sanguino
June 04, 2010 02:16AM
I bought a reprap motherboard (Sanguino Master), and extruder board (Arduino Slave) from Makerbot, downloaded the firmware, arduino, sanguino software, installed, compiled the SanguinoMaster and received the following error message, tried lot of things but didn’t work.
---- Error: variable or field ‘send_tool_command’ declared void In function ‘void init_commands()’;
I tried in two computers one Window XP the other Window Vista, received same error message. The Arduino 18 environment compiled fine the code downloaded here in the RepRap Subversion repository.
The problem is this version doesn’t support the Master Slave configuration I purchased from Makerbot.
I emailed Makerbot for help but …
Re: Problems With Sanguino
June 04, 2010 03:27PM
Tony: Your issue seems to be rather different from the one blcArmadillo was having. So you will probably get better results posting as a new topic, rather than asking your question in the middle of this thread.

Tony Phan
The problem is this version doesn’t support the Master Slave configuration I purchased from Makerbot.

Are you sure about that? The Reprap 5D firmware in svn does support the Gen3 electronics board set, which has two Arduinos, one on the main board and one on the extruder controller board. Under the trunk/mendel/firmware/5D_GCode/ directory you should see two subdirectories, Extruder and FiveD_GCode_Interpreter. The first is for the "slave" extruder controller board, the second is for the mainboard.

What makes you think that this code does not support your electronics? How exactly did you configure the firmware when you edited configuration.h in each directory? How did you upload it into each Arduino?

Re: Problems With Sanguino
June 05, 2010 11:04AM
Hi Jonathan,
Thank you so much for your help!
I downloaded the firmware “reprap-gen3-firmware-1.2.zip” which includes two subdirectories: Arduino Slave Extruder and Sanguino Master so I assumed that was the naming convention. When I looked at the 5D firmware and didn’t see the Master Slave keywords I thought that firmware was for another version that only use one microcontroller.
The two subdirectories, Extruder and FiveD_GCode_Interpreter compiled.
How should I test the firmware with the boards and the host software, without having the hardware (motors, extruder…) assembled?
Thanks again,
Re: Problems With Sanguino
June 05, 2010 02:54PM
Glad to help.

Tony Phan
How should I test the firmware with the boards and the host software, without having the hardware (motors, extruder…) assembled?

That's a good question to be asking.

I'm not an expert on testing Gen3 electronics (I don't have a set of them myself!). Here are some ideas:

  • Talking to them 'manually' by typing GCode at them over the USB-to-TTL connection using a serial comms program would be one way to check that the firmware is running as expected
  • Seeing whether the reprap.org host software recognizes their presence and what it does if you enable comms debugging (so you can see the data going back and forth to the electronics from the host) would be another.
  • If you have even just one stepper motor (even a small cheap one not good enough for actual Reprap use), you could hook it to each stepper driver board in turn, and see if you can move the stepper back and forth under firmware control, either from the XYZ panel of the reprap host software, or by typing GCode G0 commands at it in a serial comms program (screen or minicom or even HyperTerminal).

I am fairly sure there is a wiki page somewhere on reprap.org about this kind of testing, but I don't know where it is.

Back in the days of Gen 1 electronics there was a "stepper simulator" board with a bunch of LEDs on it that you could hook up to a (Gen 1) stepper controller board to see if it was stepping the 'non-existent' stepper appropriately; I'm not sure if such a thing exists for the Gen 3 electronics, though. I rather doubt it. Stepper motor costs are now low enough that it's probably easier to just acquire and connect a real stepper.

Re: Problems With Sanguino
April 28, 2011 09:39AM
If anyone could help. I can not get my gen 3 to communicate at all with any software. Here is latest error with host software.

C:\Program Files\reprap>rem reprap-host -- runs Reprap Java host code with an ap
propriate classpath

C:\Program Files\reprap>rem Amount of RAM to allow Java VM to use

C:\Program Files\reprap>set REPRAP_RAM_SIZE=1024M

C:\Program Files\reprap>rem reprap.jar file and stl file

C:\Program Files\reprap>set REPRAP_DIR=C:\Program Files\Reprap

C:\Program Files\reprap>rem Java3D and j3d.org libraries

C:\Program Files\reprap>rem set JAVA_LIBRARY_DIR=C:\Program Files\Reprap

C:\Program Files\reprap>rem cd so we can find the reprap-wv.stl file. Can we av
oid this??

C:\Program Files\reprap>IF NOT EXIST reprap-wv.stl cd "C:\Program Files\Reprap"

C:\Program Files\reprap>java -cp ".\reprap.jar;.\RXTXcomm.jar;.\j3dcore.jar;.\j3
d-org-java3d-all.jar;.\j3dutils.jar;.\swing-layout-1.0.3.jar;.\vecmath.jar;." -X
mx1024M org/reprap/Main
DEBUG: The distribution preferences file and yours match. This is good. [0.010s
DEBUG: GCode opening port COM1 [0.178s/168ms]
WARNING: RXTX Version mismatch
Jar version = RXTX-2.2pre1
native lib Version = RXTX-2.2pre2
DEBUG: Attempting to initialize Arduino/Sanguino [1.623s/1445ms]
comms: G-code: N0 T0 *26 dequeued and sent [6.415s/4792ms]
Sorry, only registered users may post in this forum.

Click here to login