Welcome! Log In Create A New Profile


Help with Firmware upload

Posted by Mellin 
Help with Firmware upload
February 15, 2016 12:08PM

I have a problem with my Sanguinololu 1.3a

I recently wanted to upload to it Marlin firmware, because I had to install new ATMEGA1284P-PU microcontroller, but in Arduino 0023 I keep getting "avrdude: stk500_getsync(): not in sync: resp=0x00" error after trying to upload.

I tried ways described in [reprap.org] article:
I tried that 10 seconds reset holding.
I already had those 2-pin connected before.
I can see USB Serial Port (COM3) under Ports (COM and LPT).
I have RTS on close checked.

Anyone have any suggestion on what I am doing wrong?
Re: Help with Firmware upload
February 15, 2016 01:57PM
Are you sure that the new ATMEGA1284 has a bootloader installed?
Re: Help with Firmware upload
February 15, 2016 04:19PM
No, I'm not.

I have a usbasp programmer (or whatever that is called), because I had to burn bootloader to the previous too.
But I don't remember how to...

I know how to connect it to the board, bot I don't remember what I should select inside Arduino and I don't want to try and error this problem out.
Re: Help with Firmware upload
February 16, 2016 12:56AM
In the Arduino IDE just select the right board (Sanguino ATMega1284p 16MHz), the right programmer (USBasp if it's that what you have) and the port of you programmer, and then click "Burn Bootloader". Check also the wiki.

Regarding "...usbasp programmer (or whatever that is called)", just beware in case it is not an USBasp but a USBtinyISP, since this does not work with the 1284p.
Sorry, only registered users may post in this forum.

Click here to login