Welcome! Log In Create A New Profile


Problem uploading configure.h file

Posted by JnsMuovi 
Problem uploading configure.h file
April 06, 2011 06:19AM

I'm trying to change the e_steps_per_mm value to my gen6 electronics so i could move on using skeinforge, but all I get is:

avrdude: Yikes! Invalid device signature
double check connections and try again, or use -F to override this check.

I've tried to change the stk500 value from board.txt to arduino, but that doesn't help.
Tried to press the reset button while uploading, but it says:

avrdude: stk500_recv(): programmer is not responding

I'm running latest ubuntu and arduino installs avrdude 5.10 with it and I don't know how to get it to 5.4 (works for many), the force version button is gray inthe synaptic.

Any suggestions would be greatly appreciated.
Re: Problem uploading configure.h file
April 06, 2011 08:39PM
Doesn't it also report which signature is expected vs. which one was received? If the received one is 0x00, your communications is probably failing. Firmware upload doesn't neccessarily happen at the same baud rate as the firmware's communication to the host.

If the received one is not 0x00, your board's CPU doesn't match the one set in the Arduino IDE. ATmega644 and ATmega644P have different signatures.

Generation 7 Electronics Teacup Firmware RepRap DIY
Sorry, only registered users may post in this forum.

Click here to login