Power Supply Help
June 14, 2020 01:24PM
I hope that this is the right place for this. If not, apologies, and please tell me where to go. grinning smiley I'm collecting things to build ... a few other things... and I stumbled across a couple really nice power supplies. I think that they're good, but misconfigured. I have a possibly strange hope that someone here is familiar with these units and can offer some advice.I have contacted the manufacturer's tech support team, but I'm impatientand I believe in casting a wide net.

My intended uses are pretty mundane: a router and a printer. The power supplies, if they actually work, are pretty spiffy.

What I stumbled into is a pair of Excelsys UltiMod UX6 setups with 5v, 12v, & 24v PowerMods. More detail on them:
Each unit has these powermods installed:
- slot A: XgB
- slot B: XgH
- slot E: Xg3
- slot F: Xg3

The two XG3 units are set up in series, which the manufacturer says turns them into a 480 watt, 24v supply. Neat.

The dip switches on each PowerMod apear to be set in as factory default, and there is a close fitting rectangle of kapton tape on most of the switches. Switch 1 is on, and switch 2 is off.

The problem is that I'm not getting any DC power out.

When I have the units connected to mains power (AC 112-118V, hovering near 60 Hz), I observe:
The LED next to J2 with the AC symbol next to it is on and green.
None of the LEDs on the PowerMods come on.
I get ~10v at each of the connectors to the PowerMods.
The fans are on and kind of loud.
I don’t have any cabling connected to the unit except for the cord that I use to plug into mains.
There are no jumpers on any of the PowerMods that appear to have a spot for a jumper, and I haven’t attempted to short across those pins with a jumper…

I doubt that the Powermods are bad, but I don’t know how to test that. I've read the very short manuals and understand some of what I read. I think that I’m missing something that would be obvious to someone who knows the product.

Aside from "Your PowerMods are shot, does anyone have any insights as to why I might not be getting power out if the mods are getting power in?

Thanks
-A
Re: Power Supply Help
June 14, 2020 01:41PM
Watch this video may help you.
[www.youtube.com]


Computer Programmer / Electronics Technician
Sorry, only registered users may post in this forum.

Click here to login