Welcome! Log In Create A New Profile

Advanced

Trouble with stepper motors

Posted by sapna 
Trouble with stepper motors
April 15, 2013 06:30PM
I am having trouble getting my stepper motors to move, they simply hum when pots on driver is turned towards the minimum and click and lock when the current is turned up.

I am using ramps 1.4 (reprap discount) and standard 4 wire NEMA 17 stepper motors, I only have motors plugged into the ramps at the moment.
I have loaded Marlin but also tried sprinter
I have checked and double checked that wiring is correct (identified coil pair).
Pronterface seems to be working fine as I can connect, and get the motors to make some noise.

The only way the motors will show any sign of doing anything (locking, humming) is when i click the home button, the jog command does not seem to do anything.

Could it be an issue with power supply not providing enough current? I am using a ATX and have checked the voltage.

Or is it an issue with the configuration?

I also tried the mechanical switch in case this was causing the problem, but this did not seem to change anything.

I am a little lost as to what to try next, any help would be appreciated!!
VDX
Re: Trouble with stepper motors
April 16, 2013 02:09AM
... re-check correct pin assignment and clock speeds - 'humming' is either not enough current or too high stepping rates ...


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: Trouble with stepper motors
April 16, 2013 07:41PM
Problem solved!!

Seems like both the firmwares i tried were sending the motor a signal they didn't like, i tried the ramps14 test code and it worked so i tried the official version of marlin and they all seem to be working fine!
Sorry, only registered users may post in this forum.

Click here to login