Welcome! Log In Create A New Profile


Stepper Motors won't turn

Posted by ArthurHelsloot 
Stepper Motors won't turn
October 15, 2013 10:32AM
So I build this Prusa Mendel I2 printer using the full kit from Charlie's 3d Technologies.
After assembly I really wanted to upload the firmware and simply make the printer move. Unfortunately it wasn't that simple.
I uploaded the Repetier firmware and tried to control my printer using Repetier host, but it didn't work. I only got the fan to blow and the heated bed and hot end to head up, but I could not move the motors. I tried to get them turning by adjusting the pot on the stepper drivers, but without positive result. Later I tried using Sprinter or Marlin, but still the same result. I also tried using Pronterface in stead of Repetier host, but still nothing.
I know there are a lot of people with the same problem, who posted their problems on the internet. I found a lot of solutions, but non of them worked for me. I've been searching the web for days and I can't find a working solution for my problem. I really hope somebody could help me.
Here is some information about my printer:
I am using Ramps 1.4, Nema 17 stepper motors and Pololu A4988 Stepper Motor Drivers. The power supply didn't come with the kit, so I use a old pc power supply, rated 12V max 15A. I tested the power supply on a cd drive, so I know it works. I am using an MK2a heated bed, two 100 ohms thermistors and mechanical end stops. All is connected.
To solve this problem I have tried to follow instructions on how to install the firmware and what adjustments to make in the configuration.h file, but no positive results. Therefor I do not think software is the problem. I also tried disconnecting the endstops and switching the stepper motor's wires, but still no changes. My motors are wired as follows:
2B blue
2A red
1A green
1B black
There is a connection inside the motors between the blue and the red wires and between the green and black wires.
When I tell one of motors to move, the X motor just lightly vibrates (you only feel this when your hand touches the motor) and the Z, Y and E motors don't react at all. When I press extrude in pronterface, it says 'echo: cold extrusion prevented'

I hope I gave you enough information to find me a solution, because I'm really desperate for one.

I forgot to mention I also tried the ramps test firmware, but that gives the same result.
Furthermore, I am Dutch, so my apologies for my crapy English.

Edited 1 time(s). Last edit at 10/15/2013 03:54PM by ArthurHelsloot.
Re: Stepper Motors won't turn
October 23, 2013 07:00AM
It all sounds good.

I would check that you have 12v going into both the 11amp and the 5amp part of the ramps , and not 5v into the 5amp connector. This wont hurt it, but wont work.

Also check your pololu driver are in correct way! Find the 4 tracks going to the steppers, they are normally nice and thick, and make sure they are closest side to the motor plugs. eg here [www.pololu.com] on a real pololu you can see the thick tracks on the right,
Re: Stepper Motors won't turn
October 25, 2013 03:57AM
Thanks for your reaction!
I already checked the input amperage and voltage. Those are exactly as they are supposed to be.
In the mean time I found a solution.
It turns out the stepper drivers where the problem. I did put them in the correct way, but I somehow managed to solder all of them in such a way they did not connect as they are supposed to. I soldered all of them again and I got 3 of them working now. The other two are either burned or broken in some other way, so I ordered a new one.
Again thanks for your reaction.
Re: Stepper Motors won't turn
December 09, 2013 12:51AM
Looks like you have your wiring wrong
2B blue
2A red
1A green
1B black

Its suppose to be :

So you would have had the opposite polarity for one of your phases, which would explain why the motor was vibrating. This could have led to your motors dying.

Edited 1 time(s). Last edit at 12/09/2013 12:52AM by Spenc.
Sorry, only registered users may post in this forum.

Click here to login