Welcome! Log In Create A New Profile


Stepper Motor Hell

Posted by SJFirst 
Stepper Motor Hell
June 13, 2015 02:35PM
Hello everybody,

I am having a really hard time trying to make my stepper motors to work ...
What i am using:
- ramps 1.4
- A4988 stepper motor driver
- 200 steps motor (17HSR1006-25)
- marlin 1.0.2-1

I tried a lot of things ... Checking the motors wires, playing with the micro-stepping, the driver calibration, acceleration constant definition, the feedrate ... but I can't get a reliable and smooth movement.

Most of the time, all i am getting is this something like this type of "vibration" [vid.me] (slower or faster, depending of the feedrate I use with the 'move' command, stronger or weaker depending of the driver calibration).

Any idea, tips or link concerning this subject would be highly appreciated.
Re: Stepper Motor Hell
June 13, 2015 03:03PM
Have you set/checked/tweaked the driver reference voltage?

- Tim
Re: Stepper Motor Hell
June 13, 2015 03:29PM
Thanks you Tim for your answer.

Yes, I tried to adjust this parameter. I started at first with a 0.8 V potential, and tried to lower and increase it. The only effects I can see, are a stronger vibration (louder noise, more 'torque') and more heat from the motor and the driver.

If the driver reference voltage it too low, i get a light buzz, and no more movement from the motor.
Re: Stepper Motor Hell
June 14, 2015 04:02AM
If all the motors are doing the same thing and they vibrate instead of move, then the wiring of the motor cables may be wrong for the electronics. I had this problem with a new set of cables from Robotdigg a few weeks ago. The fix was to swap over the outer 2 wires where they go into the connector that plugs into the electronics. You need a very small screwdriver or fine tweezers to lift the plastic tabs on the connector shell so that you can pull the pins out.

Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Sorry, only registered users may post in this forum.

Click here to login