Welcome! Log In Create A New Profile

Advanced

DRV8825 "skipping" microsteps

Posted by peepsalot 
DRV8825 "skipping" microsteps
October 05, 2015 03:56AM
I've been troubleshooting a weird issue with some DRV8825 stepper drivers. I am using them to drive all my motors on a RAMPS setup.

My setup is this:
Marlin firmware on RAMPS, with bed autoleveling enabled
DRV8825 set to 1/32 microstepping, driving dual Z motors in parallel.

So during printing, as autoleveling is being used, the Z motors will move smoothly for partial step and then pop into a position, it is quite audible and annoying of a sound, and obviously not microstepping properly. During infills etc, this pop can be heard repeatably as the nozzle passes over specific areas of the bed, adjusting the the same Z step levels as it travels.

To troubleshoot this, I have a little test jig set up where i can measure the current inline going to one of the motor coils with a multimeter, and manually send a step signal one at a time by pressing a button. I set this up the same with my motors in parallel as they are on my printer, and recorded the current measurements. The stepper driver was set beforehand to roughly 1.2A max current.

Here is a link to a spreadsheet with measured values charted as current vs steps.
[docs.google.com]

I only measured part of the waveform before my multimeter decided to auto shutoff and I didn't feel like continuing, but you can see that it does a weird jump from around 0 to .66A, instead of properly microstepping the entire waveform, thus causing the hard pops I was hearing at certain points during autoleveling. Does anyone know the reason it does this?

I suspected it might have something to do with the decay mode, which I had read about, though I admit I don't fully understand the exact effect of changing these modes. I tried tying the DECAY pin to 5V and it didn't seem to have any effect on this behavior of "skipping" microsteps. Just to be clear it never actually loses track of steps, which is why i put "skipping" in quotes, but it is ignoring the microstepping for a portion of the waveform.

After more searching online for similar issues, I read that its best to wire motors in series rather than parallel. So I made a wiring harness to accomplish this, and tested again, measuring the current. This made a significant improvement, but I still saw a jump from 0 to 0.22A or so which was not as smooth as it should . I wish I knew how to eliminate it entirely.
Re: DRV8825 "skipping" microsteps
October 05, 2015 04:27AM
Hmm, just did some more searching and came across this: [cabristor.blogspot.com]

I guess that pretty much answers it.

I think I'd actually seen this post before but didn't quite get it the first time around. Maybe I'll try this diode fix now.
Re: DRV8825 "skipping" microsteps
October 05, 2015 04:27AM
It seems that the DRV8825 has particular problems with driving stepper motors at low currents. Connecting the decay mode pin to +5V should have solved the problem, at the cost of possibly introducing audible subharmonics, so I wonder if you didn't get it quite right. See [cabristor.blogspot.co.uk] if you haven't already.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: DRV8825 "skipping" microsteps
October 05, 2015 05:32AM
I´m running my delta with 1.8° steppers and DRV8825 in fast decay mode. The noise only appears when a stepper stands still, which is almost never the case.
Otherwise they run smooth and silent.
This week I´ll get 0.9° steppers and will test them with fast decay hacked A4988. ( 0.9° and 1/32 microsteps would be too much for 8bit controllers )

The article about 4 antiparallel diodes made me curious to try it out. Maybe If I find a silicium based rectifier, the solder job would be pretty easy. ( and cooling, too )
-Olaf
Re: DRV8825 "skipping" microsteps
October 06, 2015 10:27PM
OK I double checked my work and it turns out I had accidentally soldered the wrong pin. Setting to fast decay does fix the missed microsteps.
Re: DRV8825 "skipping" microsteps
April 21, 2016 09:51PM
Quote
peepsalot
OK I double checked my work and it turns out I had accidentally soldered the wrong pin. Setting to fast decay does fix the missed microsteps.

How is the noise afterward? Also, along with solving the missing microsteps, does it smooth out all of the microsteps better?

I'm trying to figure out whether I want to do the fast decay mode hack, or the diode hack. I'm not so sure I'm missing microsteps as I am getting 'pulsing' in my extruder motor when the stepper is running very slow - causing moire in my prints.

Edited 1 time(s). Last edit at 04/21/2016 09:52PM by MrBaz.
Re: DRV8825 "skipping" microsteps
April 22, 2016 07:58PM
Tried the diode hack with 1N5408 diodes and I think something is wrong. The extruder doesn't move at all. I made sure they were on different phases of the motor. confused smiley
Re: DRV8825 "skipping" microsteps
May 04, 2016 04:55PM
I hooked it up like a dumb dumb. When I got it working, it gave me inconsistent extrusion. My prints came out worse. I'm switching back.
Sorry, only registered users may post in this forum.

Click here to login