Welcome! Log In Create A New Profile


Issue with cncshield+arduino. Steppers stopped working.

Posted by jvales 
Issue with cncshield+arduino. Steppers stopped working.
September 13, 2016 06:24AM
Hi everybody,

I am new to this forum. I hope this is the right place to post about my problem.

My config has 3 NEMA 17 stepper motors, each attached to a pololu A4988. The steppers do not have yet any mechanical load, I was just testing basic interfacing via gbrl.

Everything was working pretty fine. I left it untouched for about 1 month and when I tested again NONE of the steppers worked, but they are blocked (I can't move by hand) when powered. I also notice that the heatsinks of the A4988 became hot. I have checked power supply (12V, same as before) and seems it is working good, I recheck wiring and was ok too. So I went further and disconnected all, attaching only a new pololu driver and a new stepper. STILL not working.

After this, I did some test with a multimeter. Fuse was ok and A4988 VMOT pins are receiving proper power. I did tests with gbrl sending G0 X5 and G0 X-5 alternatively and DIRECTION pin is correctly changing. Besides, once when I tested with the multimeter STEP pin the stepper started to spin (may this indicate arduino is not sending STEP signal correctly?)

I am a bit loss. Any idea will be highly appreciated.

Cheers and thank you for reading!
Sorry, only registered users may post in this forum.

Click here to login