Welcome! Log In Create A New Profile


All tested but steppers don't move + DRV8825 + Marlin

Posted by niccok 
All tested but steppers don't move + DRV8825 + Marlin
March 28, 2017 05:44AM
Hi all,

I'm writing this message because I am desperate.
I built a cartesian printer and have a serious problem with steppers. All is OK except that.

Here's my problem :
When I connect one stepper to my RAMPS 1.4 and clic "start Motors" in Simplify 3D, the stepper makes some noises but does'nt want moving.
Wiring is OK (I spotted the two pairs : red/blue, green/black). I even tested all possibilities to connect to the RAMPS.
Power is OK : 12V 50A.
On my driver DRV8825 Vref is OK (I tested to turn the potentiometer : stepper makes differents songs but does'nt move).
All 3 jumpers are connected on the board (I tested without the jumpers : same result).
I also tried to connect a 4.7K (and a 10K) resistor between sleep and fault pins on the driver but no more result.

I don't know what I could make...

Steppers are Nema 17 1.7A (17HS4401) : [fr.aliexpress.com]
DRV8825 (semms to be m20b) : [www.banggood.com]

Do you have any idea to help me ?
This problem appears on all axes. So I make theses tests with one stepper (but tried some steppers to eliminate the stepper problem) and disconnected all others modules to the RAMPS.

I specify that motor doesn't move but it is very hard to turn manualy when it is started. So current should be OK.

Thanks a lot for any help.
Re: All tested but steppers don't move + DRV8825 + Marlin
March 29, 2017 03:12AM

I found the problem smiling smiley
I don't know why but I had to invert all the endstop into Marlin.

Hope this can help some peoples.

Sorry, only registered users may post in this forum.

Click here to login