Welcome! Log In Create A New Profile


New Titan Slimline motor seizing

Posted by fullHundo 
New Titan Slimline motor seizing
July 04, 2017 04:49AM
I realize that there is another post regarding a vibrating motor on the same page of this board, but that poster's solution had to do with his wiring and I am fairly certain that my wiring is fine as the cable was provided by e3d with the motor and I have been able to control the motor through other stepper output connections on the board with this cable.

I am installing a new Titan extruder with the e3d Titan Slimline motor (link). When I attempt a manual extrude command, the motor seizes/vibrates but will not turn. This new motor does 0.9° as opposed to the 1.8° motor I was using with the stock extruder. I have adjusted my steps/mm value to 837 as recommended by e3d.

I tested the motor on the Y-stepper output on the controller and was able to manually control it through Repetier just fine through that connection, so it appears that the motor is functional. I also tried reconnecting the previous stock extruder motor to E0 on the controller to make sure I hadn't fried that connection on the board, and it worked just fine as well, so I don't think I have burnt anything out.

Any suggestions? Could it be that the potentiometer is set too low/high for the new motor?

Thank you for the help!
Re: New Titan Slimline motor seizing
July 04, 2017 06:12AM
When you had it working by connecting it to the Y motor output, were you using the same cable as when you couldn't extrude with it? If you are not using the cable that came with it when trying to extrude, then the cable you were using may be wrong for the new motor. Sadly, stepper motors with connectors on the motor don't all use the same pinouts.

Edited 1 time(s). Last edit at 07/04/2017 06:16AM by dc42.

Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet.
Re: New Titan Slimline motor seizing
July 04, 2017 07:39PM
Yes, the same cable that I was not able to use on E0 was the same one that did work when connected to the Y motor output. It is the cable that came with it, and you're right, that cable is wired slightly differently from the cables of my other, bigger stepper motors. I did try the motor with the differently-wired cable from my old extruder as well and it was not helpful either.
Re: New Titan Slimline motor seizing
July 05, 2017 02:01AM
In general those 0.9° steppers like to run on higher voltages. The description on E3d page state it's a 2.7V motor, so it should run on 12V too.

How did you try to extrude? Using the buttons of the control panel or sending gcode with a propper speed declaration?
I always send " G1 F100 E10" so I know it's fully under control.
I guess, the control buttons use the max. extrusion speed, which is often way to high ( works for retract/unretract but not for extrusion )

PS: It's funny they don't specify max. current?

Edited 1 time(s). Last edit at 07/05/2017 02:04AM by o_lampe.
Sorry, only registered users may post in this forum.

Click here to login