Welcome! Log In Create A New Profile


Help troubleshoot Extruder

Posted by jamesarm97b 
Help troubleshoot Extruder
August 03, 2012 08:01PM
I have a Rostock I built and am trying to test the extruder (cold). I just want to see if I can make it feed the filament up and down by issuing Extrude commands using Pronterface. I see the command saying it is extruding but nothing happens. If I swap the stepper motor connector to the X axis and do a Home command I see the motor turn so I know it is working. I swapped drivers and that did not change anything. I measure the E0_Enable pin and it is always high. The firmware acts like it does not want to extrude. I disabled the cold extrusion safety and even sent the M302 and it still wont extrude. I tried enabling E0 and E1 and that did not help. If I enable power to all steppers using M17 the extruder motor engages so I no the enable pin and driver board works. Is there no way to manually feed filament when cold (not connected to hotend yet.

Mega 2560 and RAMPS 1.4
Rostock firmware
Re: Help troubleshoot Extruder
August 03, 2012 08:26PM
I went ahead and tried to print a dummy file and it heated up the extruder then started and the extruder stepper was moving. The test piece of filament is now stuck in there because it ran out. That kind of leads to my original question. What is the procedure for manually feeding filament during changes like this? I can't manually reverse or run forward at this point.
Re: Help troubleshoot Extruder
August 03, 2012 09:10PM
My extruder is tearing up the pla and stopping. Anyone have a rostock extruder made with a MK7 gear and have the correct ratio / steps per E? I think it is going too fast.
Re: Help troubleshoot Extruder
August 03, 2012 11:46PM
There is a safety in the firmware that you can disable that prevents extrusion while the hot end is cold. Disable it, remove the hot end, and calibrate your e steps per mm. See: [reprap.org]

Help improve the RepRap wiki!
Just click "Edit" in the top-right corner of the page and start typing.
Anyone can edit the wiki!
Re: Help troubleshoot Extruder
August 04, 2012 11:36AM
There is also a bug in the firmware that prevents extrusion without some x/y/z movement, I believe. (The safety Cameron mentioned can be disabled with M302)
Re: Help troubleshoot Extruder
August 04, 2012 11:48AM
It must be the bug, because I have disabled the safety in the firmware and using the M302 command and I can't get any extrusion. I am trying to find a way to prime the extruder and also change filament without printing something. Does anyone have a bug fix for the extrude with no movement?
Re: Help troubleshoot Extruder
August 06, 2012 03:20AM
Remove the safety check in the Marlin.pde, line 1387 or there abouts:
if (cartesian <= 0.many_zeros_1) {
Re: Help troubleshoot Extruder
August 16, 2012 01:52PM
Sorry, I think I fixed this bug before but must have forgotten to push the fix to GitHub. So now I have fixed it again:

I'm still on vacation and can't test my change (return to Seattle now delayed by expired greencard) but James said it works for him.
Sorry, only registered users may post in this forum.

Click here to login