Calibrating Geared Extruder
May 13, 2013 08:45PM
Rostock is now doing the right things, thanks to all the help from this forum. Now trying to calibrate the geared extruder by measuring the filament.
Using 'Triffid Hunter's Calibration guide -
After a pronterface manual extrude of 100mm, I get 16mm through the extruder.
My 'E-Steps from my delta marlin 'configuration_adv.h' seems to be is 836 (see below)
======================
#ifdef ADVANCE
#define EXTRUDER_ADVANCE_K .0

#define D_FILAMENT 1.75
#define STEPS_MM_E 836
#define EXTRUTION_AREA (0.25 * D_FILAMENT * D_FILAMENT * 3.14159)
#define STEPS_PER_CUBIC_MM_E (axis_steps_per_unit[E_AXIS]/ EXTRUTION_AREA)
=========================
using this formula:
6) calculate new_e_steps = e_steps * 100mm / measured_distance
I get a new E-Step figure of 5225 . . which seems very high (and four digits)
have tried changing the E-Step number in 'config_adv.h', then recompiled and uploaded to printer . . with negligable change in extruded filament.
Was going to reflash firmware with an 'M92 Ennn' command but that needs a three digit number and I have 5225.
Can anyone tell me how to get the extruder to pass 100mm (instead of 16mm) when I ask for 100mm in pronterface?
Re: Calibrating Geared Extruder
May 14, 2013 02:17AM
What speed are you trying to extrude at?
Try something like 5mm/s to make sure you are not loosing steps.


Bob Morrison
Wörth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Calibrating Geared Extruder
May 15, 2013 06:48AM
Bob, Not tried to extrude at any speed yet as the extruder isnt calibrated. When I try to extrude 100mm, only 16mm is extruded; wanted to get somewhere close to correct before trying to lay down plastic.
Re: Calibrating Geared Extruder
May 15, 2013 07:11AM
Quote
johnpanter
...Not tried to extrude at any speed yet as the extruder isnt calibrated...

eye rolling smiley

Quote
johnpanter
Using 'Triffid Hunter's Calibration guide -
After a pronterface manual extrude of 100mm, I get 16mm through the extruder.

How do you know that only 16mm is extruded when you try to extrude 100mm if you don't extrude at any speed?

To extrude 100mm you had a speed set for the extrusion, if this speed is too high you could be losing steps meaning the the filament will be moved less than 100mm. The speed is set in pronterface. Use a maximum of 5mm/s as the extrude speed when calibrating.


Bob Morrison
Wörth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Calibrating Geared Extruder
May 15, 2013 11:46AM
OK. see your point. As pronterface uses mm/min, I estimate 5mm/s equals 300mm/min.
I was already set at 400mm/min, but with the rate set at 300mm/min (5mm/s) as you suggest, the extruder still only pushes 16mm of filament towards the hot end (through the tube) when I try to send 100mm.
Re: Calibrating Geared Extruder
May 15, 2013 12:48PM
johnpanter Wrote:
-------------------------------------------------------
> My 'E-Steps from my delta marlin
> 'configuration_adv.h' seems to be is 836 (see
> below)

The steps per mm is set in configuration.h. You should have something like this (except with values suitable for your machine):

// default settings 

#define DEFAULT_AXIS_STEPS_PER_UNIT   {2*200/1.5, 2*200/1.5, 4*200/1.5, 16*200/(6.69215015*3.14159264)*47/9}  // default steps per unit for RILstrap
#define DEFAULT_MAX_FEEDRATE          { 70, 70, 35, 25}    // (mm/sec)
#define DEFAULT_MAX_ACCELERATION      {200,200,100,150}    // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for skeinforge 40+, for older versions raise them a lot.

(I.e. the hobbed bolt has a diameter of nearly 6.70 mm in my case.)

> Was going to reflash firmware with an 'M92 Ennn'
> command but that needs a three digit number and I
> have 5225.

M92 takes a floating point number for the X, Y, Z and E parameters. Marlin allows you to read the values back with the M503 command (which takes no parameters).
Re: Calibrating Geared Extruder
May 15, 2013 12:51PM
Seemed to have sorted this by trial and error. Tried to calibrate extruder by sending different values using M92 Ennn. to firmware from pronterface.

Eventually settled on M92 E635 which gives 101mm through the extruder using 1.75 filament. Stored the new setting to Eprom with M500 on completionn.

Thanks again to everyone thats helped.
Re: Calibrating Geared Extruder
June 12, 2014 11:33PM
I am over a year late to the discussion and your solution...I want to understand.

I have a 5:1 geared nema17 and I too ( though yours is fixed) am getting little extrusion. In repetier I can adjust speed and amount manually but, when I run a program...slow.

I am using Marlin straight from download. I only added LCD. Can I fiddle E axis speed in Marlin?
Re: Calibrating Geared Extruder
June 17, 2014 12:23PM
OK so the fix I found was.....to just pull the 3 jumpers out from under the driver. 10mm now extrudes a bit over 10mm. Done.
Re: Calibrating Geared Extruder
June 18, 2014 02:28AM
Quote
frankenfrankenstuff
OK so the fix I found was.....to just pull the 3 jumpers out from under the driver. 10mm now extrudes a bit over 10mm. Done.

Or you could put the three jumpers back and, assuming your drivers max at 1/16 micro stepping, multiply your current E steps per millimetres in Marlin/EEPROM by 16. The extruder motor would run smoother that way but your fix is fine too. M92 E old value x 16 will fix it in EEPROM.
Re: Calibrating Geared Extruder
November 26, 2015 09:59PM
@frankenfrankenstuff
don't know if u r still watching this or figured it out yet but it sounded like u did not address these settings since u used it stock
// default settings

#define DEFAULT_AXIS_STEPS_PER_UNIT {2*200/1.5, 2*200/1.5, 4*200/1.5, 16*200/(6.69215015*3.14159264)*47/9} // default steps per unit for RILstrap
#define DEFAULT_MAX_FEEDRATE { 70, 70, 35, 25} // (mm/sec)
#define DEFAULT_MAX_ACCELERATION {200,200,100,150} // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for skeinforge 40+, for older versions raise them a lot.

u must take into consideration the microstepping and if u r using the high power driver it defaults to 32 instead of 16 with all jumpers. Actually, I don't think the jumpers matter.

UNIT = mm
for X&Y --- yours may be different #s
Motor is 1.8° step or 200steps/rev
micro stepping is 32 for hipwr driver == 6400 steps/rev
factor in ur belt & drive gears 16 teeth/rev for drive gear and 2mm/tooth on belt == 32mm/rev
6400 steps/rev / 32mm/rev === 200 steps/mm
for E, u can do the calculation as above, 16*200/(6.69215015*3.14159264)*47/9, or experiment by changing the # till it is right, which I did.
for Z the screw pitch is 2 and lead is 4 so it rises 8mm/rev, direct drive gives 6400steps/rev / 8mm/rev === 800steps/mm
Sorry, only registered users may post in this forum.

Click here to login