Extrusion speed
November 28, 2013 08:12AM
Hi guys,

Just finished the build of a first 3D printer. We've got a Megatronics V2 in it running Marlin firmware with delta mod. I've just switched to Repetier Host whereas before we were using Pronterface.

Moving the head goes well. Calibrating that went like a breeze. When I start a printer it first warms up the bed, it then lowers the nozzle to about 5mm above the surface, warms up the nozzle, drops it to a paperthickness above the bed and starts the print.

The problem we encounter is in the extrude speed. It extrudes too slow it seems. The material that does come out it collecting around the nozzle instead of laying on the bed. I suspect this is a feedrate problem rather than a temperature issue. I've tried tweaking variables in the firmware to learn what they do, but the results have been disapointing so far. I will include the config.h and hope that someone can help us soon.
open | download - Configuration.h (24.8 KB)
Re: Extrusion speed
November 28, 2013 08:13AM
The part I've been tweaking around in is this:

// default settings

#define DEFAULT_AXIS_STEPS_PER_UNIT {80, 80, 80, 93} // conversie van stappen naar metrische lengtes
#define DEFAULT_MAX_FEEDRATE {100, 100, 100, 10000} // (mm/sec) maximum reissnelheid E was 1000
#define DEFAULT_MAX_ACCELERATION {100,100,100,10000} // X, Y, Z, E startsnelheid

#define DEFAULT_ACCELERATION 3000 // X, Y, Z and E max acceleration in mm/s^2 for printing moves
#define DEFAULT_RETRACT_ACCELERATION 3000 // X, Y, Z and E max acceleration in mm/s^2 for retracts

// Offset of the extruders (uncomment if using more than one and relying on firmware to position when changing).
// The offset has to be X=0, Y=0 for the extruder 0 hotend (default extruder).
// For the other hotends it is their distance from the extruder 0 hotend.
// #define EXTRUDER_OFFSET_X {0.0, 20.00} // (in mm) for each extruder, offset of the hotend on the X axis
// #define EXTRUDER_OFFSET_Y {0.0, 5.00} // (in mm) for each extruder, offset of the hotend on the Y axis

// The speed change that does not require acceleration (i.e. the software might assume it can be done instantaneously)
#define DEFAULT_XYJERK 2.0 // (mm/sec)
#define DEFAULT_ZJERK 0.4 // (mm/sec)
#define DEFAULT_EJERK 5.0 // (mm/sec)
Re: Extrusion speed
November 28, 2013 02:26PM
First callibrate extruder as described e.g. here: [richrap.com]

If it does not help, then there can be more reasons for this:
* Your z-height is not correct (the nozzle is still too far from the bed when printing the first layer).
* You print the first layer too quickly (try speeds around 20 mm/s or even slower).
* You do not have suitable bed surface or temperature.
Re: Extrusion speed
November 28, 2013 02:29PM
Your jerk values seem to be low for a delta. Try 20 for x,y,z. But this is unrelated to the problem that filament does not stick to your heatbed.
Re: Extrusion speed
November 28, 2013 05:29PM
Thanks for your replies. The problem seems to shift itself. At first it wasn't extruding fast enough. I don't know how to change the extrude speed in the firmware or slic3r. When I gave manual commands to retract it did get up to speed. I suspected that the reason is that it can't build enough presure to push it through for some reason. I tightened the springs on my airtripper extruder which only had the motor skipping steps as a result. I then tried to turn the pot switch screw. This didn't resolve the problem either.
Re: Extrusion speed
November 28, 2013 05:45PM
Firmware specifies only the maximum speed. In your case it is set to 10000 (the 4th arument of DEFAULT_MAX_FEEDRATE). 1000 is probably more common. It depends on your extruder. But this value is not really important (it is only the top limit). The actual extruder speed is set by slic3r. The option name is retract_speed. Set it to something low for the tests (e.g. 200).
Re: Extrusion speed
November 29, 2013 04:38AM
You'd say retract_speed has something to say about the speed at which it retracts, not extrudes. In fact, the speed at which it retracts is high, it's the extruding speed that is the problem.
Re: Extrusion speed
November 29, 2013 07:11AM
OK, it is a bit more complicated:

Slic3r uses retract_speed from both retract and also for reversing of the retract (which was done before).
For normal printing moves:
* retract_speed is not used at all,
* the speed of filament feeding is determined by filament diameter, print move speed in XY plane and E-stepsPerMm.

If you have your extruder e-steps correctly calibrated as advised by richRap and filament diameter correctly set, then your extrusion speed must be just right for your printing speed, layer height, and extrusion width.
Well that is if you do not mess with extrusion_multiplier which is kind of an option to never use anyway (it should be always 1).
In case of a correctly calibrated extruder it either gives just the right amount of filament at the right speed or you can hear your stepper skipping or pulley is grinding the filament.
First make sure you have extruder correctly calibrated (E-steps). Only then try to print anything.

Edit: spelling.

Edited 2 time(s). Last edit at 11/29/2013 08:13AM by hercek.
Re: Extrusion speed
November 29, 2013 07:53AM
That's some very useful info. I did calibrate it but I'm beginning to wonder if I used the right technique. I put a line on the filament. I then retracted it 10mm. It then put another line on the filament and measured the distance. I extruded back and forth to make sure it was a consistent length, which it was.
I then used the reprap calculator to tweak it until it was right.

After heating the hotend and trying to extrude I found that it wasn't building enough pressure to push through. I tightened the spring on the airtripper and tried again. This time it started skipping steps. I tried turning the polulu pot switch to the right but that didn't help.
Re: Extrusion speed
November 29, 2013 08:25AM
Richrap tutorial recomeds to calibrate only slow forward extrusion and with hotend hot so that the extrusion actually pushes plastic through the nozzle. The calibration is specific for given extruder spring force. It should be also new filament (not a piece of filament which did already run around extruder pulley). The reason is that the filament will get deformed a bit in the extruder and this has impact on E-steps.

But it looks like you may have a problem with weak extruder stepper or steper driver thermal shutdown. Try to put heatsink on the pololu chip and use a fan to cool it. This should move thermal shutdowns to higher currents. Notice the thermal shutdowns may last only split second, so they maybe hard to notice.

You should also verify that the hotend has the right temperature for the material you use. Infrared thermometer whould help here. Maybe your hotend is too cold (because of incorectly selected temperature sensor) and that is the reason the stepper skips steps.
Re: Extrusion speed
December 02, 2013 07:12AM
As it turns out, the stepper driver for my extruder was broken. The pot switch maximum was broken so I had no way to tweak it right. When I put a stepper driver from one of my other channels on the extruder motor it worked, but still was skipping steps. I've ordered a more powerful one now and hope that will fix the problem.
Re: Extrusion speed
July 13, 2014 12:19AM
I have a Rostock that im trying to make print since january...I have the same problem than proton. Sometimes I released any complete print but not more than five. It always stops extrude plastic in the middle of the print work.
Im using the airtripper extruder v2 and MK8. I tried it with MK7 too and without the optional MR105ZZ bearing. I begin with ABS from reprapworld. Without any good result somebody gives me a little of another ABS because of the bubbles of mine. Now im trying also with PLA from bq company.
I tried all temperatures and of course i dont trust completely in my thermistors from ebay and without datasheet...but they really seems to give the correct temperature.
The Hot End is the J-Head V with 0.5mm nozzle.

I wanted to know if Proton resolved this issue and if he can give me some advice for this eternal problem that will make me to kill my printer!!

I dont know if change the extruder to a wade's or change the hot end...I really tried everything I could see or thought could be giving the problem.

Sorry, only registered users may post in this forum.

Click here to login