Welcome! Log In Create A New Profile

Advanced

Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level

Posted by Kasahabo 
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 03, 2016 03:00PM
Quote
guitarhammer
DC42, Thanks for the answer. I have tried the calculator about 6 times with different points and always get this: M665 RNaN L240.00 M666 XNaN YNaN ZNaN ; Set homed height NaNmm in config.h. (I do have 240mm rods) Not sure what is wrong. I have tried to manually enter a correction with M666 and nothing changes. I am trying to do it in Pronterface, I have read somewhere that does not work. When I try in Repetier the EPROM screen is blank and says it only works for Repetier firmware, the printer is Marlin yes? What am I doing wrong here? Thanks for any help one can give me.

If you get NaNs in this answer, this generally means that two or more of the XY coordinates you have entered in the calculator are the same. If that isn't the case, please post a screenshot showing the values you used.

If in doubt, choose 4, 7 or 10 points and ask the calculator to suggest the XY coordinates for you.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 03, 2016 03:33PM
Below is the last one I ran. Previously I entered the coordinates to stop in front of each upright and stop between each upright and then center, So no two spots were the same and it covered the whole bed. Same output of calculator.


Firmware type: RepRapFirmware Smoothieware Repetier Marlin (standard) Marlin (Rich Cattel)
Steps/mm (for Repetier only):
80.0
Initial endstop corrections: X:
0.0
Y:
0.0
Z:
0.0
Initial diagonal rod length:
240.0
Initial delta radius:
186.0
Initial homed height:
244.9
Initial tower angular position corrections: X:
0.0
Y:
0.0
Z:
0.0
Printable bed radius:
97.0
Number of probe points:
7
Number of factors to calibrate:
6
Normalise endstop corrections?
Suggest probe points
Point 0 X:
10.00
Y:
87.00
Nozzle height error:
2.0
Point 1 X:
74.00
Y:
48.50
Nozzle height error:
2.0
Point 2 X:
84.00
Y:
-38.50
Nozzle height error:
1.0
Point 3 X:
1.00
Y:
-77.00
Nozzle height error:
1.0
Point 4 X:
-72.00
Y:
-46.50
Nozzle height error:
3.0
Point 5 X:
-73.00
Y:
47.50
Nozzle height error:
2.5
Point 6 X:
0
Y:
0
Nozzle height error:
0.0
Calculate
Calibrated 6 factors using 7 points, deviation before 1.90 after NaN
New endstop corrections: X:
Y:
Z:
New diagonal rod length:
240.00
New delta radius:
New homed height:
New tower position angle corrections: X:
Y:
Z:
0.00
Commands:
M665 RNaN L240.00
M666 XNaN YNaN ZNaN
; Set homed height NaNmm in config.h
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 03, 2016 06:32PM
anyone else having issues with arduino IDE 1.6.7 in windows 10 ? its not compiling the kossle bpe FW... i get this error msg...

Arduino: 1.6.7 (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

In file included from sketch\ultralcd.cpp:32:0:

sketch\dogm_lcd_implementation.h:1:17: fatal error: U8g.h: No such file or directory

#include

^

compilation terminated.

exit status 1
Error compiling.

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.


i have the u8glib downloaded and in the libraries folder for arduino... the IDE even updated it automatically.. everything is communicating as normal. but i cant upload any FW changes now...


UPDATE: NEVERMIND.. FIGURED IT OUT.. THE VERSION OF THE U8GLIB WASNT CORRECT... THE ARDUINO IDE IS AUTO UPDATING TO THE WRONG VERSION... AND MY CAPS LOCK BUTTON IS STUCK, IIM NOT YELLING I SWEAR!!!

Edited 2 time(s). Last edit at 01/03/2016 07:19PM by 09zx-6r.


Nophead Mendel90 Remixed in aluminum
Marlin v2.0
Matterhacker Control (latest)
Ramps 1.4
Sainsmart LCD
MK2B heatbed
E3dV6 hotend .4mm tip
1.75mm filaments
dedicated 12v33a psu
dedicated 12v5a laptop psu mod
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 03, 2016 06:37PM
Now I am thinking of starting over with Repetier FW as it seems it would more easily address my problems. Is there a guide or source to setting it up for the FT RevB? The page has a ton of questions. I did download Communication.h from paul_delta. Anything else I need or need to know? Thanks again.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 03, 2016 06:39PM
Here is the full archive you may start from your tuning: [forums.reprap.org]

Quote
guitarhammer
Now I am thinking of starting over with Repetier FW as it seems it would more easily address my problems. Is there a guide or source to setting it up for the FT RevB? The page has a ton of questions. I did download Communication.h from paul_delta. Anything else I need or need to know? Thanks again.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 03, 2016 06:53PM
Thank you. Downloaded and looking at it now.smiling smiley
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 03, 2016 09:28PM
OK, have the new firmware installed. Now is the a guide or anything on how and what files need setting up? Thank you for your time and patience, New to all this.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 03, 2016 09:37PM
Quote
guitarhammer
OK, have the new firmware installed. Now is the a guide or anything on how and what files need setting up? Thank you for your time and patience, New to all this.

[www.youtube.com]
you can skip Openscad part of video and start from here [youtu.be] with Repetier Host.
here is another article you must read: [www.repetier.com]

This thread covered almost all steps of calibration process, don't be lazy and read it...

Edited 2 time(s). Last edit at 01/03/2016 09:38PM by paul_delta.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 03, 2016 09:54PM
Sorry, not being lazy. There are 83 pages of information in no particular order. I have been reading for hours for 3 days to get to where I am. Thank you so much for your help. I do aircraft electronics for a living and have been a certified mechanic for over 30 years, a programmer I am not. Ah, the Z probe, I am cutting it off.

Edited 1 time(s). Last edit at 01/03/2016 09:56PM by guitarhammer.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 03, 2016 11:12PM
does anyone have a functioning configuration.h file that i can use ? the FW from folgertech isnt set up... Im getting very frustrated with the set up... i know ill need to change the Z height, but its a start...or does anyone have a how to set up guide for this printer... ??? one thats NOT for rocket scientists to understand

Edited 1 time(s). Last edit at 01/03/2016 11:13PM by 09zx-6r.


Nophead Mendel90 Remixed in aluminum
Marlin v2.0
Matterhacker Control (latest)
Ramps 1.4
Sainsmart LCD
MK2B heatbed
E3dV6 hotend .4mm tip
1.75mm filaments
dedicated 12v33a psu
dedicated 12v5a laptop psu mod
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 04, 2016 03:17AM
09zx-6r: Depends. Kossel2020 old version or RevB version? Firmware is Marlin from Folgertech?

Something else fyi: I tested the inductive z probe (the LJ12A3-4-Z-BX) and was astounded how *bad* it actually is. On different positions on the bed I get a deviation of up to 0.3 mm between the nozzle touching the bed and the probe triggering (possibly because of the PCB below the aluminium?). To make things worse, the LJ12A3-4-Z-BX is temperature dependent. I cant get any realiabe mesaurements and autoleveling done.

I will upgrade my Kossel2020 RevB with some stuff to make (auto) leveling a bit easier (JCRocholls touch probe, glass bed surface and spring loaded bed support) and post pictures & results.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 04, 2016 07:54AM
Quote
guitarhammer
Below is the last one I ran. Previously I entered the coordinates to stop in front of each upright and stop between each upright and then center, So no two spots were the same and it covered the whole bed. Same output of calculator.

The reason that the calculator is generating NaNs is that the combination of diagonal rod length, delta radius and probe points you have entered is physically impossible, because the arms would be too short to reach the first probe point. The calculator doesn't check for that. My guess is that the delta radius of your printer is much lower than the 186mm that you entered, more like 120mm. What value do you have set in the firmware? If you are running Marlin firmware, then it's the parameter called DELTA_RADIUS, and it is calculated (quite unnecessarily IMO) from some other values.

Edited 1 time(s). Last edit at 01/04/2016 07:54AM by dc42.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 04, 2016 08:07AM
Yes, here is my post about this problem and discussion: [forums.reprap.org]
It was the main reason why I designed this probe holder: [www.thingiverse.com]

It's much easier to level the bed when the probe has zero XY offset from the hot end. Also, to make it working with glass covered bed, I made a simple adapter that converts inductive probe to non-inductive smiling smiley [www.youtube.com]


Quote
docpayce
Something else fyi: I tested the inductive z probe (the LJ12A3-4-Z-BX) and was astounded how *bad* it actually is. On different positions on the bed I get a deviation of up to 0.3 mm between the nozzle touching the bed and the probe triggering (possibly because of the PCB below the aluminium?). To make things worse, the LJ12A3-4-Z-BX is temperature dependent. I cant get any realiabe mesaurements and autoleveling done.

I will upgrade my Kossel2020 RevB with some stuff to make (auto) leveling a bit easier (JCRocholls touch probe, glass bed surface and spring loaded bed support) and post pictures & results.

Edited 2 time(s). Last edit at 01/04/2016 08:21AM by paul_delta.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 04, 2016 09:18AM
Quote
docpayce
Something else fyi: I tested the inductive z probe (the LJ12A3-4-Z-BX) and was astounded how *bad* it actually is.

PS: actually, the probe is not bad - it has very good precision and returned values are pretty stable (during not very long z-probe session). During heavy tests I never had an error more than 0.01mm. And I suspect this error is just a backlash of mechanical parts and probe mount.

Edited 1 time(s). Last edit at 01/04/2016 09:18AM by paul_delta.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 04, 2016 05:05PM
Quote
docpayce
09zx-6r: Depends. Kossel2020 old version or RevB version? Firmware is Marlin from Folgertech?

Something else fyi: I tested the inductive z probe (the LJ12A3-4-Z-BX) and was astounded how *bad* it actually is. On different positions on the bed I get a deviation of up to 0.3 mm between the nozzle touching the bed and the probe triggering (possibly because of the PCB below the aluminium?). To make things worse, the LJ12A3-4-Z-BX is temperature dependent. I cant get any realiabe mesaurements and autoleveling done.

I will upgrade my Kossel2020 RevB with some stuff to make (auto) leveling a bit easier (JCRocholls touch probe, glass bed surface and spring loaded bed support) and post pictures & results.


i have the FT kossel2020 Rev B with the marlin FW from Folgertechs site...my inductive probe works fine... but i have yet to be able to get the flatness setup correct... theres a program called Matterhacker controller, i use it to autolevel my other 3d printers bed with NO probe needed... its the paper test at 3-12 points depending on how exact you want it... but iv never had an issue since... i may forgo the inductive probe and set a tall Z height and do it thru the software instead...

but either way, id like to try the correct way first... easiest isnt always the best way...


Nophead Mendel90 Remixed in aluminum
Marlin v2.0
Matterhacker Control (latest)
Ramps 1.4
Sainsmart LCD
MK2B heatbed
E3dV6 hotend .4mm tip
1.75mm filaments
dedicated 12v33a psu
dedicated 12v5a laptop psu mod
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 05, 2016 07:14PM
I do need serious help for my printer. When everything is reset, it prints well. But when the printer is continuously used, layer deposition is shifted to one side as shown in the picture. This problem goes away when the machine is reset. Is it possibly caused by the controller? Or some mechanical problems? The attached picture was taken in the morning when the printing was left unattended during the night with confidence, it was a total mess. It seemed OK till 2 layers were printed and prints before the pictured one were OK.

I also need a recommendation for a 32 bit controller upgrade?

Thanks in advance.

Quote
photo444
I have been enjoying reading posts of this forum and thanking all of contributors.

Recently I have finished building a rev B printer and having fun with it. After careful measurements and calibration a 20mm cube was printed for testing. As shown in the attached picture, the cube is not straight but tilt along Y axis. I have found that the radius value is slightly different between the three axes (within 2 mm), and suspecting as a possible cause of the tilt. I would appreciate for any suggestions and guides. The Y axis is along the left to the right.

Paul
Attachments:
open | download - Kossel02.jpg (58.5 KB)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 07, 2016 02:46PM
I had similar situation when nozzle touched warped side of model during travel. Check your extrusion rate, speed and temperature.
BTW did you check your drivers vRef voltage? Probably one of motors skipping steps.

Quote
photo444
I do need serious help for my printer. When everything is reset, it prints well. But when the printer is continuously used, layer deposition is shifted to one side as shown in the picture. This problem goes away when the machine is reset. Is it possibly caused by the controller? Or some mechanical problems? The attached picture was taken in the morning when the printing was left unattended during the night with confidence, it was a total mess. It seemed OK till 2 layers were printed and prints before the pictured one were OK.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 07, 2016 02:59PM
So, I'm trying to print this:




but I'm getting this:



Notice how two of the outside points are missing? It doesn't look like that in slicer nor in pronterface. Any ideas why this is happening?

I notice that the problem is in line with one of the towers (I have it arbitrarily labeled as "Z"). I have "circular build platform" checked and the Width/Depth are set to 172mm. X&Y Offsets are -86 and the print across the diameter (without the points) is coming in at 152mm so I should have 20 more mm of travel.

Edited 2 time(s). Last edit at 01/07/2016 03:08PM by Legrand.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 07, 2016 03:28PM
Try to move your hot end manually to the problem point. Are you able to do it without skipped steps?
Is it Repetier? If so, what is #define DELTA_FLOOR_SAFETY_MARGIN_MM ?

Quote
Legrand
So, I'm trying to print this:




but I'm getting this:



Notice how two of the outside points are missing? It doesn't look like that in slicer nor in pronterface. Any ideas why this is happening?

I notice that the problem is in line with one of the towers (I have it arbitrarily labeled as "Z"). I have "circular build platform" checked and the Width/Depth are set to 172mm. X&Y Offsets are -86 and the print across the diameter (without the points) is coming in at 152mm so I should have 20 more mm of travel.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 07, 2016 07:53PM
Paul_delta,

Thank you for the reply. I have checked the vRef and they are ~0.65V. Only Z-axis motor is bad (along the '-y direction' on the bed), and other axes are 'OK' compare to the Z-axis. The behavior is consistent with that the Z-motor is not strong enough to push the carriage back to where it has to be. When the motion is limited near the center the effect is minimal, but when the stroke is long enough the shift is significant. Since I have three stronger Nema 17 motors, decided to replace all three at once. I will see the result tomorrow. I remember seeing complains that those stock motors are not strong enough for the supposed function. I will report what will happen after the replacement.

One good thing I got through the trouble is deeper understanding of the printer.

Quote
paul_delta
I had similar situation when nozzle touched warped side of model during travel. Check your extrusion rate, speed and temperature.
BTW did you check your drivers vRef voltage? Probably one of motors skipping steps.

Quote
photo444
I do need serious help for my printer. When everything is reset, it prints well. But when the printer is continuously used, layer deposition is shifted to one side as shown in the picture. This problem goes away when the machine is reset. Is it possibly caused by the controller? Or some mechanical problems? The attached picture was taken in the morning when the printing was left unattended during the night with confidence, it was a total mess. It seemed OK till 2 layers were printed and prints before the pictured one were OK.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 07, 2016 08:13PM
Try to swap driver boards, like X-Z and see if the problem will move to another axis.
Check your top bearing for problem axis. I had to reassemble one of them because it was too tight.
BTW the vRef is 0.35v for stock motors. I have stock motors and they work up to 120mm/s without any problem.

Quote
photo444
Paul_delta,

Thank you for the reply. I have checked the vRef and they are ~0.65V. Only Z-axis motor is bad (along the '-y direction' on the bed), and other axes are 'OK' compare to the Z-axis. The behavior is consistent with that the Z-motor is not strong enough to push the carriage back to where it has to be. When the motion is limited near the center the effect is minimal, but when the stroke is long enough the shift is significant. Since I have three stronger Nema 17 motors, decided to replace all three at once. I will see the result tomorrow. I remember seeing complains that those stock motors are not strong enough for the supposed function. I will report what will happen after the replacement.

One good thing I got through the trouble is deeper understanding of the printer.

Quote
paul_delta
I had similar situation when nozzle touched warped side of model during travel. Check your extrusion rate, speed and temperature.
BTW did you check your drivers vRef voltage? Probably one of motors skipping steps.

Quote
photo444
I do need serious help for my printer. When everything is reset, it prints well. But when the printer is continuously used, layer deposition is shifted to one side as shown in the picture. This problem goes away when the machine is reset. Is it possibly caused by the controller? Or some mechanical problems? The attached picture was taken in the morning when the printing was left unattended during the night with confidence, it was a total mess. It seemed OK till 2 layers were printed and prints before the pictured one were OK.

Edited 1 time(s). Last edit at 01/07/2016 08:13PM by paul_delta.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 07, 2016 08:53PM
The motors were barely warm at 0.65V so didn't bother to lower them. It seems better practice keeping them as low as possible. I will try that. I also have 2020 i3 there I tried to lower them to be 0.35V and no troubles. I will certainly check the top bearing of the troubled axis. I think it also is a good idea to check the driver boards by swapping, too. I wish I had all the good suggestions before replacing the motors. If the top bearing was the problem I may have the same trouble with replaced motors. I appreciate for the suggestions.

Quote
paul_delta
Try to swap driver boards, like X-Z and see if the problem will move to another axis.
Check your top bearing for problem axis. I had to reassemble one of them because it was too tight.
BTW the vRef is 0.35v for stock motors. I have stock motors and they work up to 120mm/s without any problem.

Quote
photo444
Paul_delta,

Thank you for the reply. I have checked the vRef and they are ~0.65V. Only Z-axis motor is bad (along the '-y direction' on the bed), and other axes are 'OK' compare to the Z-axis. The behavior is consistent with that the Z-motor is not strong enough to push the carriage back to where it has to be. When the motion is limited near the center the effect is minimal, but when the stroke is long enough the shift is significant. Since I have three stronger Nema 17 motors, decided to replace all three at once. I will see the result tomorrow. I remember seeing complains that those stock motors are not strong enough for the supposed function. I will report what will happen after the replacement.

One good thing I got through the trouble is deeper understanding of the printer.

Quote
paul_delta
I had similar situation when nozzle touched warped side of model during travel. Check your extrusion rate, speed and temperature.
BTW did you check your drivers vRef voltage? Probably one of motors skipping steps.

Quote
photo444
I do need serious help for my printer. When everything is reset, it prints well. But when the printer is continuously used, layer deposition is shifted to one side as shown in the picture. This problem goes away when the machine is reset. Is it possibly caused by the controller? Or some mechanical problems? The attached picture was taken in the morning when the printing was left unattended during the night with confidence, it was a total mess. It seemed OK till 2 layers were printed and prints before the pictured one were OK.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 08, 2016 09:07AM
It's not Repetier, but since you guys seem to use it more, I just tried to install it and I got this when installing:



So, if anyone has any ideas why I can't install that software.... maybe it's a funky port? I don't know why it's trying to go online when installing since I didn't check the skinforge box, which, supposedly, is the only part it needs to go online for (there's a warning message there about needing an internet connection, which I obviously have).

I scaled down the print by 10% and am printing it successfully now.



Quote
paul_delta
Try to move your hot end manually to the problem point. Are you able to do it without skipped steps?
Is it Repetier? If so, what is #define DELTA_FLOOR_SAFETY_MARGIN_MM ?

Quote
Legrand
So, I'm trying to print this:




but I'm getting this:



Notice how two of the outside points are missing? It doesn't look like that in slicer nor in pronterface. Any ideas why this is happening?

I notice that the problem is in line with one of the towers (I have it arbitrarily labeled as "Z"). I have "circular build platform" checked and the Width/Depth are set to 172mm. X&Y Offsets are -86 and the print across the diameter (without the points) is coming in at 152mm so I should have 20 more mm of travel.

Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 08, 2016 03:17PM
I finished building my kossel. I got tired of waiting for folger to send me the missing screws, so I sourced them locally. It was a good thing I bought an assortment, because the manual is full of errors in the called for screw lengths. Anyways, I got it assembled with no issues at all. It's "square". After completing the wiring, I dialed in the stepper driver Vref, and moved on to the firmware.

Oy Vey! What a nightmare! Well I think I half figured it out, enough to home the printer successfully. I'm using repetier with the firmware provided by folgertech. I think I made most of the modifications necessary to get started calibrating it.

My issue is with the inductive sensor. It appears to function, as the LED lights when in proximity to the bed. The arduino doesn't seem to see a signal from it. Is there a setting in the configuration I have missed? I know I wired the resistors correctly, and I am sure it is connected as shown in the diagram in the manual. Knowing that though, I still don't actually understand how the thing works, so I'm not quite sure how to test the hardware. If I want to test it, what should I see at the arduino connector, when the sensor is "open", and "closed"? Is it as simple as that, an open or closed circuit? The weird resistor circuit makes me think it's not so simple.

I about threw the thing out the window last night, but slept on it instead. I'm ready to go back at it with a cool head, but I'd like a little guidance. I tried to look into doing the bed leveling manually, and it makes my head spin. If I can't get this sensor working I will have to let it sit until I can improvise another auto leveling solution.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 08, 2016 03:34PM
Try to load this Repetier firmware [forums.reprap.org]
It's pre-configured for FT Kossel.

Quote
faithblinded
I finished building my kossel. I got tired of waiting for folger to send me the missing screws, so I sourced them locally. It was a good thing I bought an assortment, because the manual is full of errors in the called for screw lengths. Anyways, I got it assembled with no issues at all. It's "square". After completing the wiring, I dialed in the stepper driver Vref, and moved on to the firmware.

Oy Vey! What a nightmare! Well I think I half figured it out, enough to home the printer successfully. I'm using repetier with the firmware provided by folgertech. I think I made most of the modifications necessary to get started calibrating it.

My issue is with the inductive sensor. It appears to function, as the LED lights when in proximity to the bed. The arduino doesn't seem to see a signal from it. Is there a setting in the configuration I have missed? I know I wired the resistors correctly, and I am sure it is connected as shown in the diagram in the manual. Knowing that though, I still don't actually understand how the thing works, so I'm not quite sure how to test the hardware. If I want to test it, what should I see at the arduino connector, when the sensor is "open", and "closed"? Is it as simple as that, an open or closed circuit? The weird resistor circuit makes me think it's not so simple.

I about threw the thing out the window last night, but slept on it instead. I'm ready to go back at it with a cool head, but I'd like a little guidance. I tried to look into doing the bed leveling manually, and it makes my head spin. If I can't get this sensor working I will have to let it sit until I can improvise another auto leveling solution.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 08, 2016 04:17PM
Quote
paul_delta
Try to load this Repetier firmware [forums.reprap.org]
It's pre-configured for FT Kossel.

I tried using that one yesterday, and again just now. It won't compile for me. Here is the error I get in arduino when I try to verify it:
"
sketch\libraries\twi.c:1:17: fatal error: twi.c: No such file or directory

#include

^

compilation terminated.

exit status 1
Error compiling.
"

Sorry if I'm missing something simple. It's been a while since I've been so humbled by a piece of equipment. It's maddening. grinning smiley

Edited 1 time(s). Last edit at 01/08/2016 04:18PM by faithblinded.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 08, 2016 04:23PM
It's arduino compiler.... Try older version, like 1.6.5
Repetier fixed this compilation issue for 1.6.7 in 0.92.7.

Quote
faithblinded
Quote
paul_delta
Try to load this Repetier firmware [forums.reprap.org]
It's pre-configured for FT Kossel.

I tried using that one yesterday, and again just now. It won't compile for me. Here is the error I get in arduino when I try to verify it:
"
sketch\libraries\twi.c:1:17: fatal error: twi.c: No such file or directory

#include

^

compilation terminated.

exit status 1
Error compiling.
"

Sorry if I'm missing something simple. It's been a while since I've been so humbled by a piece of equipment. It's maddening. grinning smiley


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 08, 2016 04:59PM
Ok thanks Paul, I used an older one and it compiled. Seems like the same thing though. I run M119 and the z probe reports the same thing whether it's triggered or not. Looks like I may have a bum probe, or I wired it wrong. I guess I have to learn to calibrate it manually. Shoot me now.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 08, 2016 05:08PM
Check your wiring. BTW you have to learn how to calibrate anyway. Z-probe is a useful tool, not a panacea.
Also you can try to use dc42 calculator - fill your values, measured using paper test for 7-10 points and enter results in your firmware (using Repetier Host Eeprom menu)

Quote
faithblinded
Ok thanks Paul, I used an older one and it compiled. Seems like the same thing though. I run M119 and the z probe reports the same thing whether it's triggered or not. Looks like I may have a bum probe, or I wired it wrong. I guess I have to learn to calibrate it manually. Shoot me now.

Edited 1 time(s). Last edit at 01/08/2016 05:10PM by paul_delta.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 08, 2016 05:13PM
PS: may be you swapped ground and signal pins from z-probe to RAMPS? BTW you can check z-probe with multimeter connected to ground and signal pin. Disconnect from RAMPS and measure voltage, switching z-probe on and off with piece of metal.

Edited 1 time(s). Last edit at 01/08/2016 05:15PM by paul_delta.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Sorry, only registered users may post in this forum.

Click here to login