Welcome! Log In Create A New Profile

Advanced

Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level

Posted by Kasahabo 
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 08, 2016 05:47PM
Thanks Paul. I realized it had to be my wiring, or the probe itself. I went over it and saw I mixed up blue and black on the probe. Probably cause I was so worried about getting the resistors correct. Dummy. It reads correctly, now that I rewired it. Now I have to see if it will auto level, and maybe do a test print.

I know I need to learn to level the bed manually, I was simply hoping to ease myself into it a little more slowly. It's alot to learn. Thanks for your patience, helping myself and others.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 08, 2016 09:23PM
My printer is a new creature all together with the motor upgrade!
Before the upgrade, when I hit 'home', the three carriages were barely hanging at the home position after hitting the limit switches, but now they are firmly locked at the home position. Prints are clean and nice with straight walls, and it seems doing what it supposed to do. I highly recommend upgrading motors with higher capacity.

Quote
photo444
The motors were barely warm at 0.65V so didn't bother to lower them. It seems better practice keeping them as low as possible. I will try that. I also have 2020 i3 there I tried to lower them to be 0.35V and no troubles. I will certainly check the top bearing of the troubled axis. I think it also is a good idea to check the driver boards by swapping, too. I wish I had all the good suggestions before replacing the motors. If the top bearing was the problem I may have the same trouble with replaced motors. I appreciate for the suggestions.

Quote
paul_delta
Try to swap driver boards, like X-Z and see if the problem will move to another axis.
Check your top bearing for problem axis. I had to reassemble one of them because it was too tight.
BTW the vRef is 0.35v for stock motors. I have stock motors and they work up to 120mm/s without any problem.

Quote
photo444
Paul_delta,

Thank you for the reply. I have checked the vRef and they are ~0.65V. Only Z-axis motor is bad (along the '-y direction' on the bed), and other axes are 'OK' compare to the Z-axis. The behavior is consistent with that the Z-motor is not strong enough to push the carriage back to where it has to be. When the motion is limited near the center the effect is minimal, but when the stroke is long enough the shift is significant. Since I have three stronger Nema 17 motors, decided to replace all three at once. I will see the result tomorrow. I remember seeing complains that those stock motors are not strong enough for the supposed function. I will report what will happen after the replacement.

One good thing I got through the trouble is deeper understanding of the printer.

Quote
paul_delta
I had similar situation when nozzle touched warped side of model during travel. Check your extrusion rate, speed and temperature.
BTW did you check your drivers vRef voltage? Probably one of motors skipping steps.

Quote
photo444
I do need serious help for my printer. When everything is reset, it prints well. But when the printer is continuously used, layer deposition is shifted to one side as shown in the picture. This problem goes away when the machine is reset. Is it possibly caused by the controller? Or some mechanical problems? The attached picture was taken in the morning when the printing was left unattended during the night with confidence, it was a total mess. It seemed OK till 2 layers were printed and prints before the pictured one were OK.

Edited 1 time(s). Last edit at 01/08/2016 09:24PM by photo444.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 09, 2016 12:27PM
My previous problem was solved, a broken thermistor wire, but now I'm having trouble with the probe. The LED light won't come on. I looked through the photos on the google drive and noticed I'm missing the thin red and black wires going into the power supply on photo DSC00175. Can anyone tell me what these wires are for? They aren't on the wiring diagram and I'm hoping it will solve my probe problem.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 09, 2016 12:35PM
Two wires are for power, another two - for the signal to RAMPS.


Quote
MarkM92
My previous problem was solved, a broken thermistor wire, but now I'm having trouble with the probe. The LED light won't come on. I looked through the photos on the google drive and noticed I'm missing the thin red and black wires going into the power supply on photo DSC00175. Can anyone tell me what these wires are for? They aren't on the wiring diagram and I'm hoping it will solve my probe problem.

Edited 1 time(s). Last edit at 01/09/2016 12:37PM by paul_delta.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 09, 2016 12:43PM
PS: looks like FT still working on rev.B manual, making it totally unusable. Before there was a diagram how to wire z-probe with resistors. Now - there is nothing about resistors. What a clowns.

Edited 2 time(s). Last edit at 01/09/2016 12:45PM by paul_delta.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 09, 2016 01:11PM
Quote
paul_delta
PS: looks like FT still working on rev.B manual, making it totally unusable. Before there was a diagram how to wire z-probe with resistors. Now - there is nothing about resistors. What a clowns.

Resistors arent needed.
The sensor can run on 5v, The spec for the sensor is 6v to 36v, but it will run on 5v.

I used them before in other 3d printers. If you simple hook it up to the endstop as 5v power, gnd and signal . It will work just fine.
I check the difference between 5v and 12v and i couldnt find any height difference.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 09, 2016 01:15PM
I have the blue and brown going to the power supply and the red and black going to the board with the resistors hooked up. But in that image i referenced I do not have the thin red and black wires anywhere. Anyways I have a much bigger problem now.. I had the printer plugged into my laptop and all of a sudden my laptop shut off and the LCD screen on the printer got bright. Now when i plug the printer into the laptop the screen comes on and reads temps and everything, but when I plug the power into the printer the screen gets bright and unreadable. When the power gets switched off it dims and for a second you can read the normal screen and it's throwing a mintemp error before shutting of completely. I tried re-uploading the firmware but it gets stuck on uploading. When I try to connect to repetier hst it either says access to port denied or puts out lines and lines of symbols. I'm guessing something shorted?

Edited 1 time(s). Last edit at 01/09/2016 01:19PM by MarkM92.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 09, 2016 02:18PM
If the LCD goes brighter than normal, it sounds to me that either there is a short between +12V and +5V, or the 5V regulator on the Arduino has overheated (which is common when it is asked to power a graphical LCD) and failed by shorting its input to its output (which is unusual, they typically fail by providing no output).



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 09, 2016 03:03PM
I took everything out and have just the arduino by itself plugged in. The LEDs come on and my computer finds it but when I try and upload the firmware it gets stuck on uploading and times out, even after hitting the reset button. So I'm guessing the arduino is bad?
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 10, 2016 02:09PM
So I recently finished building and setting everything up with my Rev B from Folgertech. Since I had everything working well with marlin FW I decided to give Repetier a shot. I was able to get everything working and calibrated. Autobed leveling seemed to work just fine and I did several prints in PLA and ABS. Now today when trying some prints the nozzle would start dragging on the 3rd layer very badly. After checking a few things I realized I was able to recreate the issue anytime I had the Z axis at 0.5mm. Any movement command of 0.1mm up or down via Repeiter Host or LCD would result in a movement in the opposite direction but the Z axis would read as if the movement was correct. I was able to do this at any physical level in z height by changing my Z height to something smaller like 150mm and have the same issue. This would led me to believe it is some kind of software issue versus hrdware. I did flash back to Marlin FW without the issue. Flashing back to Repetier FW issue would come back.

Was hoping someone familer with Repetier might have some idea what is causing this strange issue. I have come to prefer Repetier over Marlin but this issue makes printing impossible with Repetier FW.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 10, 2016 02:19PM
Attach your Configuration.h, looks like configuration issues.

Quote
capacitor
So I recently finished building and setting everything up with my Rev B from Folgertech. Since I had everything working well with marlin FW I decided to give Repetier a shot. I was able to get everything working and calibrated. Autobed leveling seemed to work just fine and I did several prints in PLA and ABS. Now today when trying some prints the nozzle would start dragging on the 3rd layer very badly. After checking a few things I realized I was able to recreate the issue anytime I had the Z axis at 0.5mm. Any movement command of 0.1mm up or down via Repeiter Host or LCD would result in a movement in the opposite direction but the Z axis would read as if the movement was correct. I was able to do this at any physical level in z height by changing my Z height to something smaller like 150mm and have the same issue. This would led me to believe it is some kind of software issue versus hrdware. I did flash back to Marlin FW without the issue. Flashing back to Repetier FW issue would come back.

Was hoping someone familer with Repetier might have some idea what is causing this strange issue. I have come to prefer Repetier over Marlin but this issue makes printing impossible with Repetier FW.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 10, 2016 02:21PM
PS: did you load your default eeprom values after changing firmware to Repetier? If not - old eeprom values from marlin may interfere with Repetier.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 10, 2016 02:43PM
Quote
paul_delta
Attach your Configuration.h, looks like configuration issues.

#define NUM_EXTRUDER 1
#define MOTHERBOARD 33
#include "pins.h"

// ################## EDIT THESE SETTINGS MANUALLY ################
// ################ END MANUAL SETTINGS ##########################


#define FAN_PIN -1
#define FAN_BOARD_PIN -1
#define FAN_THERMO_PIN -1
#define FAN_THERMO_MIN_PWM 128
#define FAN_THERMO_MAX_PWM 255
#define FAN_THERMO_MIN_TEMP 45
#define FAN_THERMO_MAX_TEMP 60
#define FAN_THERMO_THERMISTOR_PIN -1
#define FAN_THERMO_THERMISTOR_TYPE 1
#undef X_MIN_PIN
#define X_MIN_PIN -1
#undef Y_MIN_PIN
#define Y_MIN_PIN -1
#undef Z_MIN_PIN
#define Z_MIN_PIN -1

//#define EXTERNALSERIAL use Arduino serial library instead of build in. Requires more ram, has only 63 byte input buffer.
// Uncomment the following line if you are using arduino compatible firmware made for Arduino version earlier then 1.0
// If it is incompatible you will get compiler errors about write functions not beeing compatible!
//#define COMPAT_PRE1
#define BLUETOOTH_SERIAL -1
#define BLUETOOTH_BAUD 115200
#define MIXING_EXTRUDER 0

#define DRIVE_SYSTEM 3
#define XAXIS_STEPS_PER_MM 80
#define YAXIS_STEPS_PER_MM 80
#define ZAXIS_STEPS_PER_MM 80
#define EXTRUDER_FAN_COOL_TEMP 50
#define PDM_FOR_EXTRUDER 0
#define PDM_FOR_COOLER 0
#define DECOUPLING_TEST_MAX_HOLD_VARIANCE 20
#define DECOUPLING_TEST_MIN_TEMP_RISE 1
#define KILL_IF_SENSOR_DEFECT 0
#define RETRACT_ON_PAUSE 2
#define PAUSE_START_COMMANDS ""
#define PAUSE_END_COMMANDS ""
#define EXT0_X_OFFSET 0
#define EXT0_Y_OFFSET 0
#define EXT0_Z_OFFSET 0
#define EXT0_STEPS_PER_MM 100
#define EXT0_TEMPSENSOR_TYPE 1
#define EXT0_TEMPSENSOR_PIN TEMP_0_PIN
#define EXT0_HEATER_PIN HEATER_0_PIN
#define EXT0_STEP_PIN ORIG_E0_STEP_PIN
#define EXT0_DIR_PIN ORIG_E0_DIR_PIN
#define EXT0_INVERSE 1
#define EXT0_ENABLE_PIN ORIG_E0_ENABLE_PIN
#define EXT0_ENABLE_ON 0
#define EXT0_MAX_FEEDRATE 50
#define EXT0_MAX_START_FEEDRATE 20
#define EXT0_MAX_ACCELERATION 5000
#define EXT0_HEAT_MANAGER 3
#define EXT0_WATCHPERIOD 1
#define EXT0_PID_INTEGRAL_DRIVE_MAX 230
#define EXT0_PID_INTEGRAL_DRIVE_MIN 40
#define EXT0_PID_PGAIN_OR_DEAD_TIME 7
#define EXT0_PID_I 2
#define EXT0_PID_D 40
#define EXT0_PID_MAX 255
#define EXT0_ADVANCE_K 0
#define EXT0_ADVANCE_L 0
#define EXT0_ADVANCE_BACKLASH_STEPS 0
#define EXT0_WAIT_RETRACT_TEMP 150
#define EXT0_WAIT_RETRACT_UNITS 0
#define EXT0_SELECT_COMMANDS ""
#define EXT0_DESELECT_COMMANDS ""
#define EXT0_EXTRUDER_COOLER_PIN HEATER_2_PIN
#define EXT0_EXTRUDER_COOLER_SPEED 255
#define EXT0_DECOUPLE_TEST_PERIOD 50000
#define EXT0_JAM_PIN -1
#define EXT0_JAM_PULLUP 0

#define FEATURE_RETRACTION 1
#define AUTORETRACT_ENABLED 0
#define RETRACTION_LENGTH 4
#define RETRACTION_LONG_LENGTH 13
#define RETRACTION_SPEED 40
#define RETRACTION_Z_LIFT 0
#define RETRACTION_UNDO_EXTRA_LENGTH 0
#define RETRACTION_UNDO_EXTRA_LONG_LENGTH 0
#define RETRACTION_UNDO_SPEED 20
#define FILAMENTCHANGE_X_POS 0
#define FILAMENTCHANGE_Y_POS 0
#define FILAMENTCHANGE_Z_ADD 2
#define FILAMENTCHANGE_REHOME 0
#define FILAMENTCHANGE_SHORTRETRACT 5
#define FILAMENTCHANGE_LONGRETRACT 50
#define JAM_STEPS 220
#define JAM_SLOWDOWN_STEPS 320
#define JAM_SLOWDOWN_TO 70
#define JAM_ERROR_STEPS 500
#define JAM_MIN_STEPS 10
#define JAM_ACTION 1

#define RETRACT_DURING_HEATUP true
#define PID_CONTROL_RANGE 20
#define SKIP_M109_IF_WITHIN 2
#define SCALE_PID_TO_MAX 0
#define TEMP_HYSTERESIS 0
#define EXTRUDE_MAXLENGTH 160
#define NUM_TEMPS_USERTHERMISTOR0 0
#define USER_THERMISTORTABLE0 {}
#define NUM_TEMPS_USERTHERMISTOR1 0
#define USER_THERMISTORTABLE1 {}
#define NUM_TEMPS_USERTHERMISTOR2 0
#define USER_THERMISTORTABLE2 {}
#define GENERIC_THERM_VREF 5
#define GENERIC_THERM_NUM_ENTRIES 33
#define HEATER_PWM_SPEED 0

// ############# Heated bed configuration ########################

#define HAVE_HEATED_BED 1
#define HEATED_BED_MAX_TEMP 120
#define SKIP_M190_IF_WITHIN 3
#define HEATED_BED_SENSOR_TYPE 1
#define HEATED_BED_SENSOR_PIN TEMP_1_PIN
#define HEATED_BED_HEATER_PIN HEATER_1_PIN
#define HEATED_BED_SET_INTERVAL 5000
#define HEATED_BED_HEAT_MANAGER 0
#define HEATED_BED_PID_INTEGRAL_DRIVE_MAX 255
#define HEATED_BED_PID_INTEGRAL_DRIVE_MIN 80
#define HEATED_BED_PID_PGAIN_OR_DEAD_TIME 196
#define HEATED_BED_PID_IGAIN 33
#define HEATED_BED_PID_DGAIN 290
#define HEATED_BED_PID_MAX 255
#define HEATED_BED_DECOUPLE_TEST_PERIOD 300000
#define MIN_EXTRUDER_TEMP 150
#define MAXTEMP 275
#define MIN_DEFECT_TEMPERATURE -10
#define MAX_DEFECT_TEMPERATURE 290


// ################ Endstop configuration #####################

#define ENDSTOP_PULLUP_X_MIN true
#define ENDSTOP_X_MIN_INVERTING false
#define MIN_HARDWARE_ENDSTOP_X false
#define ENDSTOP_PULLUP_Y_MIN true
#define ENDSTOP_Y_MIN_INVERTING false
#define MIN_HARDWARE_ENDSTOP_Y false
#define ENDSTOP_PULLUP_Z_MIN true
#define ENDSTOP_Z_MIN_INVERTING false
#define MIN_HARDWARE_ENDSTOP_Z false
#define ENDSTOP_PULLUP_X_MAX true
#define ENDSTOP_X_MAX_INVERTING true
#define MAX_HARDWARE_ENDSTOP_X true
#define ENDSTOP_PULLUP_Y_MAX true
#define ENDSTOP_Y_MAX_INVERTING true
#define MAX_HARDWARE_ENDSTOP_Y true
#define ENDSTOP_PULLUP_Z_MAX true
#define ENDSTOP_Z_MAX_INVERTING true
#define MAX_HARDWARE_ENDSTOP_Z true
#define max_software_endstop_r true

#define min_software_endstop_x true
#define min_software_endstop_y true
#define min_software_endstop_z true
#define max_software_endstop_x false
#define max_software_endstop_y false
#define max_software_endstop_z false
#define ENDSTOP_X_BACK_MOVE 5
#define ENDSTOP_Y_BACK_MOVE 5
#define ENDSTOP_Z_BACK_MOVE 5
#define ENDSTOP_X_RETEST_REDUCTION_FACTOR 3
#define ENDSTOP_Y_RETEST_REDUCTION_FACTOR 3
#define ENDSTOP_Z_RETEST_REDUCTION_FACTOR 3
#define ENDSTOP_X_BACK_ON_HOME 5
#define ENDSTOP_Y_BACK_ON_HOME 5
#define ENDSTOP_Z_BACK_ON_HOME 5
#define ALWAYS_CHECK_ENDSTOPS 0

// ################# XYZ movements ###################

#define X_ENABLE_ON 0
#define Y_ENABLE_ON 0
#define Z_ENABLE_ON 0
#define DISABLE_X 0
#define DISABLE_Y 0
#define DISABLE_Z 0
#define DISABLE_E 0
#define INVERT_X_DIR 0
#define INVERT_Y_DIR 0
#define INVERT_Z_DIR 0
#define X_HOME_DIR -1
#define Y_HOME_DIR -1
#define Z_HOME_DIR 1
#define X_MAX_LENGTH 85
#define Y_MAX_LENGTH 85
#define Z_MAX_LENGTH 277
#define X_MIN_POS -85
#define Y_MIN_POS -85
#define Z_MIN_POS 0
#define DISTORTION_CORRECTION 1
#define DISTORTION_CORRECTION_POINTS 4
#define DISTORTION_CORRECTION_R 70
#define DISTORTION_PERMANENT 1
#define DISTORTION_UPDATE_FREQUENCY 15
#define DISTORTION_START_DEGRADE 0.5
#define DISTORTION_END_HEIGHT 1
#define DISTORTION_EXTRAPOLATE_CORNERS 1
#define DISTORTION_XMIN 10
#define DISTORTION_YMIN 10
#define DISTORTION_XMAX 190
#define DISTORTION_YMAX 190

// ##########################################################################################
// ## Movement settings ##
// ##########################################################################################

#define FEATURE_BABYSTEPPING 1
#define BABYSTEP_MULTIPLICATOR 1

#define DELTA_SEGMENTS_PER_SECOND_PRINT 180 // Move accurate setting for print moves
#define DELTA_SEGMENTS_PER_SECOND_MOVE 70 // Less accurate setting for other moves
#define EXACT_DELTA_MOVES 1

// Delta settings
#define DELTA_DIAGONAL_ROD 244 // mm
#define DELTA_ALPHA_A 210
#define DELTA_ALPHA_B 330
#define DELTA_ALPHA_C 90
#define DELTA_RADIUS_CORRECTION_A 0
#define DELTA_RADIUS_CORRECTION_B 0
#define DELTA_RADIUS_CORRECTION_C 0
#define DELTA_DIAGONAL_CORRECTION_A 0
#define DELTA_DIAGONAL_CORRECTION_B 0
#define DELTA_DIAGONAL_CORRECTION_C 0
#define END_EFFECTOR_HORIZONTAL_OFFSET 0
#define CARRIAGE_HORIZONTAL_OFFSET 0
#define DELTA_MAX_RADIUS 90
#define ROD_RADIUS 147.4
#define PRINTER_RADIUS 85
#define DELTA_HOME_ON_POWER 0
#define STEP_COUNTER
#define DELTA_X_ENDSTOP_OFFSET_STEPS 0
#define DELTA_Y_ENDSTOP_OFFSET_STEPS 0
#define DELTA_Z_ENDSTOP_OFFSET_STEPS 0
#define DELTA_FLOOR_SAFETY_MARGIN_MM 5
//#define SOFTWARE_LEVELING

#define DELTASEGMENTS_PER_PRINTLINE 24
#define STEPPER_INACTIVE_TIME 360L
#define MAX_INACTIVE_TIME 0L
#define MAX_FEEDRATE_X 200
#define MAX_FEEDRATE_Y 200
#define MAX_FEEDRATE_Z 10
#define HOMING_FEEDRATE_X 50
#define HOMING_FEEDRATE_Y 50
#define HOMING_FEEDRATE_Z 10
#define HOMING_ORDER HOME_ORDER_ZXY
#define ZHOME_MIN_TEMPERATURE 0
#define ZHOME_HEAT_ALL 1
#define ZHOME_HEAT_HEIGHT 20
#define ZHOME_X_POS 999999
#define ZHOME_Y_POS 999999
#define ENABLE_BACKLASH_COMPENSATION 0
#define X_BACKLASH 0
#define Y_BACKLASH 0
#define Z_BACKLASH 0
#define RAMP_ACCELERATION 1
#define STEPPER_HIGH_DELAY 0
#define DIRECTION_DELAY 0
#define STEP_DOUBLER_FREQUENCY 12000
#define ALLOW_QUADSTEPPING 1
#define DOUBLE_STEP_DELAY 0 // time in microseconds
#define MAX_ACCELERATION_UNITS_PER_SQ_SECOND_X 1000
#define MAX_ACCELERATION_UNITS_PER_SQ_SECOND_Y 1000
#define MAX_ACCELERATION_UNITS_PER_SQ_SECOND_Z 100
#define MAX_TRAVEL_ACCELERATION_UNITS_PER_SQ_SECOND_X 100
#define MAX_TRAVEL_ACCELERATION_UNITS_PER_SQ_SECOND_Y 100
#define MAX_TRAVEL_ACCELERATION_UNITS_PER_SQ_SECOND_Z 100
#define INTERPOLATE_ACCELERATION_WITH_Z 0
#define ACCELERATION_FACTOR_TOP 60
#define MAX_JERK 20
#define MAX_ZJERK 0.3
#define PRINTLINE_CACHE_SIZE 16
#define MOVE_CACHE_LOW 10
#define LOW_TICKS_PER_MOVE 250000
#define FEATURE_TWO_XSTEPPER 0
#define X2_STEP_PIN ORIG_E1_STEP_PIN
#define X2_DIR_PIN ORIG_E1_DIR_PIN
#define X2_ENABLE_PIN ORIG_E1_ENABLE_PIN
#define FEATURE_TWO_YSTEPPER 0
#define Y2_STEP_PIN ORIG_E1_STEP_PIN
#define Y2_DIR_PIN ORIG_E1_DIR_PIN
#define Y2_ENABLE_PIN ORIG_E1_ENABLE_PIN
#define FEATURE_TWO_ZSTEPPER 0
#define Z2_STEP_PIN ORIG_E1_STEP_PIN
#define Z2_DIR_PIN ORIG_E1_DIR_PIN
#define Z2_ENABLE_PIN ORIG_E1_ENABLE_PIN
#define FEATURE_THREE_ZSTEPPER 0
#define Z3_STEP_PIN ORIG_E2_STEP_PIN
#define Z3_DIR_PIN ORIG_E2_DIR_PIN
#define Z3_ENABLE_PIN ORIG_E2_ENABLE_PIN
#define FEATURE_DITTO_PRINTING 0
#define USE_ADVANCE 0
#define ENABLE_QUADRATIC_ADVANCE 0


// ################# Misc. settings ##################

#define BAUDRATE 250000
#define ENABLE_POWER_ON_STARTUP 1
#define POWER_INVERTING 0
#define KILL_METHOD 1
#define ACK_WITH_LINENUMBER 1
#define WAITING_IDENTIFIER "wait"
#define ECHO_ON_EXECUTE 1
#define EEPROM_MODE 1
#undef PS_ON_PIN
#define PS_ON_PIN ORIG_PS_ON_PIN
#define JSON_OUTPUT 0

/* ======== Servos =======
Control the servos with
M340 P S / ServoID = 0..3 pulseInUs = 500..2500
Servos are controlled by a pulse width normally between 500 and 2500 with 1500ms in center position. 0 turns servo off.
WARNING: Servos can draw a considerable amount of current. Make sure your system can handle this or you may risk your hardware!
*/
#define FEATURE_SERVO 0
#define SERVO0_PIN 11
#define SERVO1_PIN -1
#define SERVO2_PIN -1
#define SERVO3_PIN -1
#define SERVO0_NEUTRAL_POS -1
#define SERVO1_NEUTRAL_POS -1
#define SERVO2_NEUTRAL_POS -1
#define SERVO3_NEUTRAL_POS -1
#define UI_SERVO_CONTROL 0
#define FAN_KICKSTART_TIME 200

#define FEATURE_WATCHDOG 1

// #################### Z-Probing #####################

#define Z_PROBE_Z_OFFSET 0
#define Z_PROBE_Z_OFFSET_MODE 0
#define UI_BED_COATING 1
#define FEATURE_Z_PROBE 1
#define Z_PROBE_BED_DISTANCE 10
#define Z_PROBE_PIN ORIG_Z_MIN_PIN
#define Z_PROBE_PULLUP 0
#define Z_PROBE_ON_HIGH 0
#define Z_PROBE_X_OFFSET 0
#define Z_PROBE_Y_OFFSET 20
#define Z_PROBE_WAIT_BEFORE_TEST 0
#define Z_PROBE_SPEED 10
#define Z_PROBE_XY_SPEED 125
#define Z_PROBE_SWITCHING_DISTANCE 1
#define Z_PROBE_REPETITIONS 2
#define Z_PROBE_HEIGHT 0.9
#define Z_PROBE_START_SCRIPT ""
#define Z_PROBE_FINISHED_SCRIPT ""
#define FEATURE_AUTOLEVEL 1
#define Z_PROBE_X1 -70
#define Z_PROBE_Y1 -40
#define Z_PROBE_X2 67
#define Z_PROBE_Y2 -4
#define Z_PROBE_X3 0
#define Z_PROBE_Y3 60
#define BED_LEVELING_METHOD 1
#define BED_CORRECTION_METHOD 0
#define BED_LEVELING_GRID_SIZE 4
#define BED_LEVELING_REPETITIONS 5
#define BED_MOTOR_1_X 0
#define BED_MOTOR_1_Y 0
#define BED_MOTOR_2_X 200
#define BED_MOTOR_2_Y 0
#define BED_MOTOR_3_X 100
#define BED_MOTOR_3_Y 200
#define BENDING_CORRECTION_A 0
#define BENDING_CORRECTION_B 0
#define BENDING_CORRECTION_C 0
#define FEATURE_AXISCOMP 1
#define AXISCOMP_TANXY 0
#define AXISCOMP_TANYZ 0
#define AXISCOMP_TANXZ 0

#ifndef SDSUPPORT // Some boards have sd support on board. These define the values already in pins.h
#define SDSUPPORT 0
#undef SDCARDDETECT
#define SDCARDDETECT -1
#define SDCARDDETECTINVERTED 0
#endif
#define SD_EXTENDED_DIR 1 /** Show extended directory including file length. Don't use this with Pronterface! */
#define SD_RUN_ON_STOP ""
#define SD_STOP_HEATER_AND_MOTORS_ON_STOP 1
#define ARC_SUPPORT 1
#define FEATURE_MEMORY_POSITION 1
#define FEATURE_CHECKSUM_FORCED 0
#define FEATURE_FAN_CONTROL 1
#define FEATURE_FAN2_CONTROL 0
#define FEATURE_CONTROLLER 2
#define LANGUAGE_EN_ACTIVE 1
#define LANGUAGE_DE_ACTIVE 0
#define LANGUAGE_NL_ACTIVE 0
#define LANGUAGE_PT_ACTIVE 0
#define LANGUAGE_IT_ACTIVE 0
#define LANGUAGE_ES_ACTIVE 0
#define LANGUAGE_SE_ACTIVE 0
#define LANGUAGE_FR_ACTIVE 0
#define LANGUAGE_CZ_ACTIVE 0
#define LANGUAGE_PL_ACTIVE 0
#define LANGUAGE_TR_ACTIVE 0
#define UI_PRINTER_NAME "Kossel"
#define UI_PRINTER_COMPANY "IO Don"
#define UI_PAGES_DURATION 4000
#define UI_ANIMATION 0
#define UI_SPEEDDEPENDENT_POSITIONING 0
#define UI_DISABLE_AUTO_PAGESWITCH 1
#define UI_AUTORETURN_TO_MENU_AFTER 30000
#define FEATURE_UI_KEYS 0
#define UI_ENCODER_SPEED 1
#define UI_REVERSE_ENCODER 1
#define UI_KEY_BOUNCETIME 10
#define UI_KEY_FIRST_REPEAT 500
#define UI_KEY_REDUCE_REPEAT 50
#define UI_KEY_MIN_REPEAT 50
#define FEATURE_BEEPER 0
#define CASE_LIGHTS_PIN -1
#define CASE_LIGHT_DEFAULT_ON 1
#define UI_START_SCREEN_DELAY 1000
#define UI_DYNAMIC_ENCODER_SPEED 1
/**
Beeper sound definitions for short beeps during key actions
and longer beeps for important actions.
Parameter is delay in microseconds and the secons is the number of repetitions.
Values must be in range 1..255
*/
#define BEEPER_SHORT_SEQUENCE 2,2
#define BEEPER_LONG_SEQUENCE 8,8
#define UI_SET_PRESET_HEATED_BED_TEMP_PLA 60
#define UI_SET_PRESET_EXTRUDER_TEMP_PLA 190
#define UI_SET_PRESET_HEATED_BED_TEMP_ABS 110
#define UI_SET_PRESET_EXTRUDER_TEMP_ABS 240
#define UI_SET_MIN_HEATED_BED_TEMP 30
#define UI_SET_MAX_HEATED_BED_TEMP 120
#define UI_SET_MIN_EXTRUDER_TEMP 170
#define UI_SET_MAX_EXTRUDER_TEMP 260
#define UI_SET_EXTRUDER_FEEDRATE 2
#define UI_SET_EXTRUDER_RETRACT_DISTANCE 3


#define NUM_MOTOR_DRIVERS 0



#endif
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 10, 2016 02:56PM
Too many differences with my configuration. Try to load my version [forums.reprap.org]

PS: next time use "Attach a file", don't paste in message body.

Quote
capacitor
#define NUM_EXTRUDER 1
#define MOTHERBOARD 33
#include "pins.h"

Edited 3 time(s). Last edit at 01/10/2016 02:58PM by paul_delta.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 10, 2016 03:16PM
I see there is a new 0.92.8 version on Repetier web site. It looks like there are a lot of improvements in bed leveling procedure since 092.6 version.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 10, 2016 03:46PM
Btw Z-probe calibration page on the Repetier web site was updated for new version: [www.repetier.com]


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 10, 2016 03:59PM
Quote
paul_delta
I see there is a new 0.92.8 version on Repetier web site. It looks like there are a lot of improvements in bed leveling procedure since 092.6 version.

I had been using 0.92.8 for a few days without issue. I did give yours a try and didn't have any issues on 0.92.6. I will try and dig through looking for what difference there is between the 2 version that might cause this problem.

Thanks
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 10, 2016 08:01PM
Thank you paul_delta for the help. I got mine up and running and calibrated for nice and flat X Y travel. I upgraded a couple things while I was at it. So my next question is any one running a E3D V6 hot end? And if so what changes in feed rate did you find works best?. Seems it needs to be upped a bit. Thanks all.

Edited 1 time(s). Last edit at 01/10/2016 08:03PM by guitarhammer.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 10, 2016 09:41PM
The Z feed rate and homing rate are too low in my configuration - for safety during calibration.

MAX_FEEDRATE_Z
HOMING_FEEDRATE_Z

My current homing feedrate set to 50.
You can set it in Eeprom.

Quote
guitarhammer
Thank you paul_delta for the help. I got mine up and running and calibrated for nice and flat X Y travel. I upgraded a couple things while I was at it. So my next question is any one running a E3D V6 hot end? And if so what changes in feed rate did you find works best?. Seems it needs to be upped a bit. Thanks all.

Edited 1 time(s). Last edit at 01/10/2016 09:42PM by paul_delta.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 12, 2016 11:06AM
dont know if this will help but i found you cant be running pronterface and arduino ide at same time it interferes with upload
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 12, 2016 02:18PM
Hey There. Joined the forum to ask a question...

I bought a kit back in November, I have it up and running reasonably well printing off my computer. Happy with my kit so far, I stumbled my way through a few pitfalls while building it, my only major modifcations from stock being an e3d-lite6 print head (it's awesome), and I removed the bed sensor and it's bracket (because as everyone here says, it's mostly useless).

I got a reprapdiscount lcd controller with my kit, but I haven't hooked it up because I thought I saw something in the forum about there not being enough oomph from the PSU to run it. Is that the case? I can find the occasional reference to this, but usually it's involving the servo for the old bed sensor, which I don't have to worry about.

I've been a lurker around here for a couple months, it's all been very helpful. Thanks!
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 12, 2016 02:26PM
LCD (the simple one, not graphical) works very good with rev.B. The main problem in previous revisions was the servo connected directly to RAMPS. It draws enough to make a problem for Arduino, so there was a recommendation to connect only signal wire to RAMPS and have additional +5v source to power servo.

Quote
Dav3xor
I got a reprapdiscount lcd controller with my kit, but I haven't hooked it up because I thought I saw something in the forum about there not being enough oomph from the PSU to run it. Is that the case? I can find the occasional reference to this, but usually it's involving the servo for the old bed sensor, which I don't have to worry about.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 12, 2016 02:36PM
Aha, perfect, thank you. That was the impression I got from reading the few things I could find, but it was hard to be sure.
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 12, 2016 02:54PM
But it's better to use Repetier firmware, if you have LCD. Marlin performance is not good enough to handle high speed printing and LCD - you will get strange short pauses that will cause blobs.

Quote
Dav3xor
Aha, perfect, thank you. That was the impression I got from reading the few things I could find, but it was hard to be sure.

Edited 1 time(s). Last edit at 01/12/2016 02:59PM by paul_delta.


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 13, 2016 03:42AM
Connecting a graphical LCD to Arduino/RAMPS is likely to overheat the voltage regulator on the Arduino. Put your finger on it to see if it is too hot, but take care not to burn yourself. One solution is to disconnect the backlight anode from the 5V supply and run it from 12V through a series resistor instead.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 13, 2016 03:53AM
uhhh ok, well iv been using the full graphics display reprap discount version on my ramps 1.4 and arduino mega 2560 with no issues since i built it... weird... ill have to watch for anything odd...

QUESTION:

the firmware is marlin, but how the hell do i get rid of the #2 and #3 extruder symbols that are taking up space on my LCD? i tried the dogm_implimentation file but it doesnt go away... thoughts?



Nophead Mendel90 Remixed in aluminum
Marlin v2.0
Matterhacker Control (latest)
Ramps 1.4
Sainsmart LCD
MK2B heatbed
E3dV6 hotend .4mm tip
1.75mm filaments
dedicated 12v33a psu
dedicated 12v5a laptop psu mod
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 13, 2016 02:07PM
Quote
davidf01
Ok I may have something not right. When I home the printer with the G28 command my endstops report triggered. Should the Z_min not be triggered here?

Reporting endstop status
x_max: TRIGGERED
y_max: TRIGGERED
z_min: TRIGGERED
z_max: TRIGGERED

When I bring it down to Z0 it reports
Reporting endstop status
x_max: open
y_max: open
z_min: TRIGGERED
z_max: open

How can my Z_min be triggered both times?

Hey Davidf01, I know this is an old post of yours, but I am having this very problem you describe (amongst several others, but I am trying to tackle them one by one). Can you tell me how you fixed this?

Thanks,

Eric
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 13, 2016 02:32PM
Hi everyone,

I have been following this thread for quite a while as I slowly have been putting together my FT Kossel RevB. I finally got it all together and powered up, but as my last post above shows, I have some issues... One is the Z_MIN always being TRIGGERED regardless of whether or not the light comes on, but I am going to try re-wiring it (it currently has the blue wire connected to ground, whereas I see that most people have it connected to V-). If that doesn't fix it, I will try removing the resistors and just connecting to 5V as a previous poster mentioned it works for him that way..

My main issue though, is that using Repetier-Host (and the FT Marlin firmware compiled using Arduino and flashed with no errors), no matter what I do with the manual controls, they all just result in all the carriages moving up until they hit the end stops... and they don't stop when hitting the end stops either. If I try to do a 0.1mm move on Z, it just goes up and keeps going up. Same if I try to do a move on X or Y or even extruder (!).. It was not like this at first, so I thought perhaps I had messed up the firmware, so I re-compiled the FT firmware (with no changes) and reuploaded to the printer... same problem still persists though...

Any clues as to why all the movement commands just end up causing the entire print head to move straight up? Did I fry something?

Thanks for all of the help you folks have already given... I'm still learning and all this shared info is great...

Eric
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 13, 2016 03:40PM
triggered z-min is the source of problem. disable your probe completely and try again.

Quote
chaster
Hi everyone,

I have been following this thread for quite a while as I slowly have been putting together my FT Kossel RevB. I finally got it all together and powered up, but as my last post above shows, I have some issues... One is the Z_MIN always being TRIGGERED regardless of whether or not the light comes on, but I am going to try re-wiring it (it currently has the blue wire connected to ground, whereas I see that most people have it connected to V-). If that doesn't fix it, I will try removing the resistors and just connecting to 5V as a previous poster mentioned it works for him that way..

My main issue though, is that using Repetier-Host (and the FT Marlin firmware compiled using Arduino and flashed with no errors), no matter what I do with the manual controls, they all just result in all the carriages moving up until they hit the end stops... and they don't stop when hitting the end stops either. If I try to do a 0.1mm move on Z, it just goes up and keeps going up. Same if I try to do a move on X or Y or even extruder (!).. It was not like this at first, so I thought perhaps I had messed up the firmware, so I re-compiled the FT firmware (with no changes) and reuploaded to the printer... same problem still persists though...

Any clues as to why all the movement commands just end up causing the entire print head to move straight up? Did I fry something?

Thanks for all of the help you folks have already given... I'm still learning and all this shared info is great...

Eric


My [www.thingiverse.com] stuff, my configuration of Repetier 0.92.6: [forums.reprap.org] (use Arduino 1.6.5 to compile)
Re: Folger Tech Kossel Delta 2020 Full 3D Printer Kit w/Auto-Level
January 13, 2016 04:54PM
Thanks paul_delta, will do. EDIT: Um, this is a stupid question - but what is the proper way to disable my z-probe? I tried to disable it by uncommenting the following line in my Configuration.h file:

Quote

//#define DISABLE_MIN_ENDSTOPS

But that didn't seem to make any difference.... I apologize for the newb questions. I appreciate your help a LOT.

Eric

Quote
paul_delta
triggered z-min is the source of problem. disable your probe completely and try again.

Quote
chaster
Hi everyone,

I have been following this thread for quite a while as I slowly have been putting together my FT Kossel RevB. I finally got it all together and powered up, but as my last post above shows, I have some issues... One is the Z_MIN always being TRIGGERED regardless of whether or not the light comes on, but I am going to try re-wiring it (it currently has the blue wire connected to ground, whereas I see that most people have it connected to V-). If that doesn't fix it, I will try removing the resistors and just connecting to 5V as a previous poster mentioned it works for him that way..

My main issue though, is that using Repetier-Host (and the FT Marlin firmware compiled using Arduino and flashed with no errors), no matter what I do with the manual controls, they all just result in all the carriages moving up until they hit the end stops... and they don't stop when hitting the end stops either. If I try to do a 0.1mm move on Z, it just goes up and keeps going up. Same if I try to do a move on X or Y or even extruder (!).. It was not like this at first, so I thought perhaps I had messed up the firmware, so I re-compiled the FT firmware (with no changes) and reuploaded to the printer... same problem still persists though...

Any clues as to why all the movement commands just end up causing the entire print head to move straight up? Did I fry something?

Thanks for all of the help you folks have already given... I'm still learning and all this shared info is great...

Eric

Edited 1 time(s). Last edit at 01/13/2016 05:16PM by chaster.
Sorry, only registered users may post in this forum.

Click here to login