Welcome! Log In Create A New Profile


Getting my Rostock moving correctly

Posted by knaskurt 
Getting my Rostock moving correctly
January 18, 2016 03:17PM

Over the last few weeks i have been building a Rostock style 3d-printer during my free time.
I have finally been able to make and assemble all the parts, but I'm having some issues with it.

When trying to move it in the z-direction the axles move at different paces, with the x-axle moving quicker than the other two.

Also, when i try to 'Auto Home' the axis only jump up roughly 1-2cm, with the x-axis moving further than the other two.
And it doesn't stop when it hits the end-stops when auto-homing, you can still tell it to auto home again making it move into the end-stops.

I have attached a picture of the wiring of my ramps board (with the wires for each sensor marked), as well as my config.h for the marlin firmware I'm using.

Any help would be greatly appreciated.
I'm suspecting i got my end-stops wired/configured wrong (they are wired to be normaly closed), but i have no idea why the axis are moving at different paces. (I got the same size pulleys (20 teeth GT2) on all axis)
All the movements are done on the LCD-interface.

Best regards, billy.

Edited 1 time(s). Last edit at 01/18/2016 03:21PM by knaskurt.
open | download - wiring.JPG (280.2 KB)
open | download - Configuration.h (36.2 KB)
Re: Getting my Rostock moving correctly
January 18, 2016 04:00PM
Frist your endstops are wired wrong.
Delta type printers should use MAX

From your pix you have it as min.
Also dont kow how your endstops are setup but might be ser wrong.

Swap them to the MAX spot.
Then in pronterface connect to the printer viabusb and type M119
Into the consle window.

This code will check the endstops.
It should report
Open when the switch isnt touch.
Triggered when touched.

If its backwards then in your config where it talks about inverting endstops false. Change it to true for X,Y,Z MAX
Re: Getting my Rostock moving correctly
January 18, 2016 06:02PM
Thank you! your advice helped me get all my endstops set up properly, and working.

The only problem I have remaining is the X-axis moving further than the other axis.
Using Pronterface i tried lowering the extruder 10mm; the Z & Y axis moved 10mm, but the X-axis moved roughly 40mm instead.
Any idea what could be causing this?

I'm adding the movement part of my configuration.h in case that helps.

#define NUM_AXIS 4 // The axis order in all axis related arrays is X, Y, Z, E
#define HOMING_FEEDRATE {200*60, 200*60, 200*60, 0}  // set the homing speeds (mm/min)

// default settings

#define XYZ_BELT_PITCH 2

#define DEFAULT_MAX_FEEDRATE          {200, 200, 200, 200}    // (mm/sec)
#define DEFAULT_MAX_ACCELERATION      {9000,9000,9000,9000}    // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for skeinforge 40+, for older versions raise them a lot.

#define DEFAULT_ACCELERATION          3000    // X, Y, Z and E max acceleration in mm/s^2 for printing moves
#define DEFAULT_RETRACT_ACCELERATION  3000   // X, Y, Z and E max acceleration in mm/s^2 for retracts

Best regards.
Re: Getting my Rostock moving correctly
January 18, 2016 06:48PM
Sounds like that x stepper has a different tooth pulley on it.
Recount it and see.

You can also swap the x motor and endstop wiring with the Y.
If the problems moves to the Y then its hardware.
If the problem stays at the X then its software.
Re: Getting my Rostock moving correctly
January 19, 2016 04:07AM
I swapped my X & Y axis around, and the problem followed me to the new x-axis tower.
Also tried swapping the stepper motor drivers between X & Y (and checking that the microstepping jumpers was on correctly), but to no avail.

And suddenly the difference has in moved distance has increased (even when moving the wiring/drivers around again).
Where the X-axis moves 160mm when told to move 10mm. I'm suspecting it has something to do with microstepping, since its roughly 16 times to much.

Could there be something physical wrong with my ramps boards? Something related to the x-axis driver/motor port.
I already had some problems with the lcd getting an intermittent connection, and having to wiggle the connection to the board a little to get a connection.
None of the soldering really looks "good" on this board, but there is no obvious errors.

Should I maybe order a new ramps + atmega 2560?
Sorry, only registered users may post in this forum.

Click here to login