Welcome! Log In Create A New Profile

Advanced

Kossel mini endstops problem

Posted by a.abushaqra 
Kossel mini endstops problem
February 18, 2016 07:51AM
Hello everybody, I have a problem setting up my kossel mini. the problem happens when I hit g28 in pronterface and the roller carriages hit the endstops but the motors don't stop and keep pushing towards them. I made a short video showing my problem. any help would be much appreciated

[www.youtube.com]

Albara
Re: Kossel mini endstops problem
February 18, 2016 12:08PM
You'll need to tell us more, such as which electronics and firmware you are using.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Kossel mini endstops problem
February 19, 2016 07:46AM
I am using a ramps 1.4 board for electronics and run a marlin firmware. keeping it simple as it is my first experience with 3d printers
Re: Kossel mini endstops problem
February 19, 2016 07:57AM
Quote
a.abushaqra
I am using a ramps 1.4 board for electronics and run a marlin firmware. keeping it simple as it is my first experience with 3d printers

Marlin + RAMPS is cheap, not simple.

Sorry I can't watch your video as I only have a low-bandwidth Internet connection right now. I suggest you use the M119 command form Pronterface/Repetier or whatever USB host program you are using to check that the endstop switches show as triggered when you press them and not otherwise. If they don't, check that you have them connected correctly (to the SIG and - pins of each MAX endstop input) and that you have Marlin configured for max endstops with pullup resistors enabled.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Kossel mini endstops problem
February 19, 2016 09:09AM
I would slow your printer down significantly until you have the problem fixed. It is hard to tell what is happening because it happens very quickly. Can you make another video with the speed turned down? What are the values of your end stops when they are pressed manually m119 I think the code is. Are you sure you have the proper endstop wired to the corresponding motor?
Re: Kossel mini endstops problem
February 20, 2016 06:26PM
dc42 and Billhc83 thank you so much for your replies. you were right as it was improper connection of the endstops to the board, I have switched some of the wires and now it works perfectly. thank you
Sorry, only registered users may post in this forum.

Click here to login