Welcome! Log In Create A New Profile

Advanced

dc42 auto-calibration doesn't go all the way to the bed

Posted by gmh39 
dc42 auto-calibration doesn't go all the way to the bed
March 11, 2016 08:35PM
So I've got my Duet all set up for my Mini Kossel, but when I run the auto-calibration (G32) the effector only goes to about 30mm above the bed. When I put my hand under the sensor (IR Probe), it senses it so I know the sensor is working.

Has anyone had this problem?


greghoge.com

HUGE 3D PRINTER PARTS SALE!!!
Re: dc42 auto-calibration doesn't go all the way to the bed
March 11, 2016 09:17PM
I dont own a z probe but in the config you have to set the height and threshold "G31 " I think

Post a least your Z probe related config.g, so DC can take a look if there an error there or its somewhere else
Re: dc42 auto-calibration doesn't go all the way to the bed
March 11, 2016 09:46PM
look at height defined in config.g
Re: dc42 auto-calibration doesn't go all the way to the bed
March 11, 2016 11:08PM
Here's my Config file:

Quote

; Configuration file for Mini Kossel kit from Think3DPrint3D

; Communication and general
M111 S0 ; Debug off
M550 MiniKossel ; Machine name and Netbios name (can be anything you like)
M551 MiniKossel ; Machine password (used for FTP)
M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED ; MAC Address
;*** Adjust the IP address and gateway in the following 2 lines to suit your network
M552 P192.168.0.120 ; IP address (0 = use DHCP)
M554 P192.168.0.1 ; Gateway
M553 P255.255.255.0 ; Netmask
M555 P2 ; Set output to look like Marlin
M575 P1 B57600 S1 ; Comms parameters for PanelDue

G21 ; Work in millimetres
G90 ; Send absolute coordinates...
M83 ; ...but relative extruder moves

; Axis and motor configuration
M569 P0 S0 ; Drive 0 goes forwards
M569 P1 S0 ; Drive 1 goes forwards
M569 P2 S0 ; Drive 2 goes forwards
M569 P3 S0 ; Drive 3 goes forwards
M569 P4 S0 ; Drive 4 goes forwards
M574 X2 Y2 Z2 S1 ; set endstop configuration (all endstops at high end, active high)
;*** The homed height is deliberately set too high in the following - you will adjust it during calibration
M665 R109 L218.0 B85 H180 ; set delta radius, diagonal rod length, printable radius and homed height
M666 X0 Y0 Z0 ; put your endstop adjustments here, or let auto calibration find them
M92 X100 Y100 Z100 ; Set axis steps/mm
M906 X300 Y300 Z300 E500 I60 ; Set motor currents (mA) and increase idle current to 60%
M201 X1000 Y1000 Z1000 E1000 ; Accelerations (mm/s^2)
M203 X20000 Y20000 Z20000 E3600 ; Maximum speeds (mm/min)
M566 X1200 Y1200 Z1200 E1200 ; Maximum instant speed changes mm/minute

; Thermistors
;*** If you have a Duet board stickered "4.7K", change R1000 to R4700 to the following M305 commands
M305 P0 T100000 B3950 R1000 H30 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
M305 P1 T100000 B3974 R1000 H30 L0 ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction
M305 P2 T100000 B3974 R1000 H30 L0 ; Put your own H and/or L values here to set the second nozzle thermistor ADC correction
M570 S180 ; Hot end may be a little slow to heat up so allow it 180 seconds

; Tool definitions
M563 P0 D0 H1 ; Define tool 0
G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
;*** If you have a dual-nozzle build, un-comment the next 2 lines
;M563 P1 D1 H2 ; Define tool 1
;G10 P1 S0 R0 ; Set tool 1 operating and standby temperatures
M92 E663:663 ; Set extruder steps per mm

; Z probe and compensation definition
;*** If you have an IR zprobe instead of a switch, change P4 to P1 in the following M558 command
M558 P1 X0 Y0 Z0 ; Z probe is a switch and is not used for homing any axes
G31 X0 Y0 Z4.8 P500 ; Set the zprobe height and threshold (put your own values here)

;*** If you are using axis compensation, put the figures in the following command
M556 S78 X0 Y0 Z0 ; Axis compensation here

M208 S1 Z-0.2 ; set minimum Z
;
T0 ; select first hot end

and here is bed.g :

Quote

; Auto calibration routine for delta printers
; Before running this, you should have set up your zprobe Z offset to suit your build, in the G31 command in config.g.

M561 ; clear any bed transform, otherwise homing may be at the wrong height
G31 X0 Y0 ; don't want any probe offset for this
G28 ; home the printer

;*** Remove the following line if your Z probe does not need to be deployed
;M98 Pdeployprobe.g ; deploy the mechanical Z probe

; The first time the mechanical probe is used after deployment, it gives slightly different results.
; So do an extra dummy probe here. The value stored gets overwritten later. You can remove this if you use an IR probe.
;G30 P0 X0 Y0 Z-99999

; Probe the bed and do 6- or 7-factor auto calibration
G30 P0 X-73.6 Y-42.5 Z-99999 ; X tower
G30 P1 X0 Y-85 Z-99999 ; between X and Y towers
G30 P2 X73.6 Y-42.5 Z-99999 ; Y tower
G30 P3 X73.6 Y20 Z-99999 ; between Y and Z towers
G30 P4 X0 Y67 Z-99999 ; Z tower
G30 P5 X-73.6 Y20 Z-99999 ; between Z and X towers
G30 P6 X-36.8 Y-21.25 Z-99999 ; half way to X tower
G30 P7 X36.8 Y-21.25 Z-99999 ; half way to Y tower
G30 P8 X0 Y42.5 Z-99999 ; half way to Z tower
G30 P9 X0 Y0 Z-99999 S6 ; centre, and auto-calibrate 6 factors

;*** Remove the following line if your Z probe does not need to be retracted
;M98 Pretractprobe.g ; retract the mechanical Z probe

G1 X0 Y0 Z150 F15000 ; get the head out of the way of the bed


greghoge.com

HUGE 3D PRINTER PARTS SALE!!!
Re: dc42 auto-calibration doesn't go all the way to the bed
March 12, 2016 01:31AM
G31 X0 Y0 Z4.8 P500 ; Set the zprobe height and threshold (put your own values here)

Your using the stock value there... maybe that where your problem at

Check the instruction on david website, the section called "Testing and commissioning the board"

Mini height sensor
Re: dc42 auto-calibration doesn't go all the way to the bed
March 12, 2016 02:11AM
Things you need to do:

1. Calibrate the G31 trigger height of the Z probe as already discussed.

2. In the M665 command set the H parameter to the approximate nozzle height when the carriages are right at the top and triggering the homing switches. It sounds as though you have it set 30mm too low at present. Also check that the D parameter is correct for your build.

3. Temporarily increase the dive height until you have done the initial caibration, by adding an H parameter to the M558 command, e.g. H30 to increase the dive height to 30mm.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Sorry, only registered users may post in this forum.

Click here to login