Welcome! Log In Create A New Profile

Advanced

Kossel Stepper Troubles

Posted by ormerod88 
Kossel Stepper Troubles
March 29, 2016 02:14PM
Hello, I'm new here and perhaps way out of my depth, but I need some help please. I bought an AliExpress FLSUN Kossel and things aren't exactly running smoothly.

After finally getting the whole thing assembled, which took 6 weeks thanks to missing parts, I'm finally at the calibration stage. I've uploaded the firmware and opened Pronterface to start homing.

The Y and Z steppers home fine, the X however doesn't work at all. I've checked the voltages at the drivers, both Y and Z show around 500mV but the X only shows 30mV, Ive tried turning up the potentiometer but it reaches 30mV and then goes back down to 10mV after continuing to turn clockwise.

Does this sound like a blown driver? That would be a nightmare because they are integrated on the MKS Mini Board.

I have tried changing the cables over and running the other steppers through the X driver and none work, the X stepper works through the other drivers.

Any assistance would be greatly appreciated.
Re: Kossel Stepper Troubles
March 30, 2016 10:52PM
Does that kit use a RAMBO or RAMPS setup? If the drivers are removable - swap out the X-axis for another one.
Re: Kossel Stepper Troubles
March 31, 2016 02:55AM
A blown driver would not normally cause the voltage on the pot to remain low, although it's not impossible. More likely, one of the components attached to the pot is faulty or not properly soldered. However, the MKS Mini board is closed source, so I can't suggest what components to look at.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Kossel Stepper Troubles
March 31, 2016 04:34AM
Thanks for your thoughts, this is the board [reprap.org] so unfortunately i cant swap the drivers.

I thought it was strange that the pot was still giving a reading, and it does change when turned but only to 30mv max before dropping back to 10mv. I'll have a look at the board and check to see if i can see any bad connections. The only thing i can think of is returning the board for a replacement, hopefully the good people of aliexpress will agree, their support has been great so far.

Is there any way this could be a firmware issue?
Re: Kossel Stepper Troubles
March 31, 2016 06:40AM
FIXED! Thanks for your help it was bad soldering on the board. I removed the heat sync from the driver and took a photo for a closer inspection, and after clearing away an obvious spot of dirt i managed to get the pot to 150mv (further turning took it back to zero)

So i continued to poke around with the tip of my multimeter, cleaning up between the connections and pushing on the pins slightly. Constantly plugging in and un-plugging to change and check the voltage at the pot and things went bad, max 10mv. I was ready to throw it out of the window when I had a final poke, pressing on the pins. Plugged it in to find 250mv! I was able to turn up the pot to 490mv and I'm happy. I believe this is a reasonable number to run the steppers at after watching this video [www.youtube.com]

I know very little about electronics, and believe I got lucky poking around, but it seems to have solved the problem for now. Ill still be looking into upgrading the board for one with removable drivers but for now hopefully I can start extruding some plastic!

Looking at the photo, I believe the second and third pins down on the top right of the driver were the problem, it may have been the resistor at CM3, but it could easily have been any of the other pins I wiggled.

Thanks again.
Attachments:
open | download - IMG_3956 - MKS Mini V1.2 Broken Connections - 01.jpg (428.1 KB)
Re: Kossel Stepper Troubles
March 31, 2016 04:32PM
I don't advise removable drivers. The problem withthem is that there is far too little PCB area to cool the chip properly, so they are very prone to overheating and can carry far less current than a driver chip soldered to as good size board. The stick-on heatsinks don't work because the chips are designed to be cooled through the PCB. The exception is the RAPS128 driver board, which uses a chip designed to be cooled through the top.

Edited 1 time(s). Last edit at 03/31/2016 04:32PM by dc42.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Sorry, only registered users may post in this forum.

Click here to login