Welcome! Log In Create A New Profile


Need of advice regarding Kossel Stepper motor problem

Posted by Zeuthen 
Need of advice regarding Kossel Stepper motor problem
December 24, 2016 04:16AM
I just put together a Kossel XL but can not get it to work due to a problem with the Stepper Motors; When I press home the motors make a lot of sounds but there is no movement.

I first thought that I might have damaged the polulo stepper boards, so I bought new ones, with the same results.

I have also tried to replace the Arduino board and the RAMPS1.4, with same results.

The voltage from the power supply is 12V and 5 Amp, and I have measured that it is correct.

Then I have tried to adjust the Vref on the Polulo steppers by turning the potentiometer 1/6 steps in either direction. Lowering the voltage seem to cause the motors to move a little 1/4 turn, but that is it.

I have tried to connect the excruder stepper instead of one of the three steppers on X,Y,Z with same result.

I have tried to change the parameters for the stepper motors in the Marlin software, no change.

Any suggestions?
Re: Need of advice regarding Kossel Stepper motor problem
December 27, 2016 06:43PM
The first thing that springs to mind is to check your motor wiring. The four wires make up two pairs. Identify pairs using a multimeter set to measure resistance, and find the two sets of wires that have some resistance between. Ensure that one pair are connected to one side (i.e. pins 1 and 2) of the motor connector on your controller board and that the other pair are attached to the other side i.e. pins 3 and 4. If the motor goes the wrong way reverse the connector. It sounds like you have the pairs mixed up and so the motor is just going back and forth by a tiny amount. You cannot trust the colours of the wires or the connectors supplied by the motor manufacturer. Of course it could be something else but this is worth ruling out before testing other things. Unless the current is really low, the motor should turn. Test the motors with no load, i.e. no belts or axes attached initially.

Simon Khoury

Co-founder of [www.precisionpiezo.co.uk] Accurate, repeatable, versatile Z-Probes
Re: Need of advice regarding Kossel Stepper motor problem
December 27, 2016 08:11PM
+1 on DJDemon's advice.

The next thing to check is that your steps per mm is in the ballpark -- try 80 steps per mm and ensure that you're on 1/16 microstepping using the jumpers.

Also check your VRef with a multimeter, the actual value depends on your driver and motors, but if you don't know what it should be, try 0.4 volts.
Sorry, only registered users may post in this forum.

Click here to login