Welcome! Log In Create A New Profile


FLSun Marlin Issues

Posted by Maestro 
FLSun Marlin Issues
July 31, 2017 01:53AM
Hey guys, I'm new to 3d printing and decided to get a FLSun Kossel Delta printer as my first printer, cause I like to tinker. I managed to nail everything on the hardware side, but I'd assume like most, the software side of things is driving me nuts. That brings me here, in hopes that maybe those well versed in Delta printers may pass some knowledge down.

The printer looks to come with a pre-configured copy of marlin. Wanting to have the latest firmware, I opted to use the most recent version of Marlin (1.1.4). As I was milling about the files and learning how to operate marlin, I found the example configuration folder and sure enough, there happened to be a pre-made configuration for the FLSun Delta. So I
copied pasted it and dove into the "configuration h" to plug in some numbers that were relevant to my printer. The manufacture even sent a sd card with many files in regards to setup, software, and so forth, but also included there own version of marlin. Assuming that this older version was configured for this specific printer, I copied many of the numbers assuming that they were relevant to this printer. After compiling and uploading, I tried some of the functions that this newer firmware provided, such as "Auto Calibration" and "Auto Bed Leveling", (and yes, I do have a Z-Probe to utilize this function.) Even so, they're time in both functions where the nozzle would momentarily scrape into the bed, which I'd assume is abnormal. Assume that the numbers gave from "Auto Calibration" were inaccurate, I reset them and just set the Z height to the best of my ability and tried to print. After messing about with different heights and temps i was finally able to get the first layer to stick, however it looked like that the height of the following layers was inaccurate, where the nozzle wasn't raising high enough and just trying to print into the lower layers.

At this point, I assume I'm having major issues with the base configuration and I'm looking to start from scratch. I've scoured the interwebs for many references and trying on my own to correct the issues. That said, between to 2 firmware's (Manufactures / Updated Marlin w/ FLSun delta profile) there seem to be setting missing in the new config that was defined in the older firmware, such as smooth rod offset, carriage offset. I'd assumed that there were fancy tricks in the new firmware that could calculate the missing definitions through auto calibration, but seems I was mistaken. Even when I tried to specify a specific amount of of filament to be extruded, in this case 10mm, it instead fed only 6.5ish mm. So I think my setting are way off.

Looking for guidance in regards to my software woes, I'll provide the 2 sets of configuration files of the 2 firmware's in hope that someone can see what I'm doing wrong.

The larger first 2 files are the updated Marlin files, as well as my current settings, while the next 2 smaller files are the configuration from the manufacture.
open | download - Configuration.h (65 KB)
open | download - Configuration_adv.h (56.7 KB)
open | download - Configuration.h (25.1 KB)
open | download - Configuration_adv.h (17.3 KB)
Re: FLSun Marlin Issues
July 31, 2017 07:33AM
Have a look at [github.com]
Re: FLSun Marlin Issues
August 01, 2017 07:52AM
After running through the majority of the guide, I seem to be stuck in the auto calibration (g33). It will run, but there are parts during the calibration where the nozzle based probe scrapes pretty bad into the bed, as well as possibly the belt skippping, which i think is abnormal. I've followed all the direction up to the g33 command very thoroughly and recheck a lot of my numbers. I went a step ahead and change some of the numbers in the marlin config.h such as: printable radius/diagonal rod. It feels like i'm exatly back where I started before.

For what its worth, here's the repetier log output of my last g33 run that I ran (Again, there was scraping and belt skipping):

04:28:30.673 : G33 Auto Calibrate
04:28:38.228 : Checking... AC
04:28:38.231 : .Height:295.00 Ex:+0.00 Ey:+0.00 Ez:+0.00 Radius:101.00
04:28:38.233 : .Tower angle : Tx:+0.00 Ty:+0.00 Tz:+0.00
04:29:14.812 : Iteration : 01 std dev:17.139
04:29:14.814 : .Height:285.06 Ex:-5.88 Ey:+0.00 Ez:-29.63 Radius:76.79
04:29:14.816 : .Tower angle : Tx:+2.88 Ty:+6.31 Tz:+0.00
04:29:37.442 : Iteration : 02 std dev:1.532
04:29:37.445 : .Height:288.47 Ex:-3.50 Ey:+0.00 Ez:-28.61 Radius:83.24
04:29:37.448 : .Tower angle : Tx:+3.16 Ty:+5.66 Tz:+0.00
04:30:01.949 : Iteration : 03 std dev:2.010
04:30:01.952 : .Height:289.15 Ex:+0.00 Ey:-0.94 Ez:-29.28 Radius:82.11
04:30:01.955 : .Tower angle : Tx:+2.80 Ty:+5.03 Tz:+0.00
04:30:25.452 : Calibration OK rolling back.
04:30:25.455 : .Height:285.06 Ex:-5.88 Ey:+0.00 Ez:-29.63 Radius:76.79
04:30:25.458 : .Tower angle : Tx:+2.88 Ty:+6.31 Tz:+0.00
04:30:25.460 : Save with M500 and/or copy to Configuration.h

Re: FLSun Marlin Issues
August 02, 2017 04:38AM
Check that your probe triggers fine and isn't stuck (not only in the centre but also close to the towers and opposite points).
Re: FLSun Marlin Issues
August 07, 2017 04:44AM
Ok since last time I messed with the printer, I wired the z min (Z probe) differently, negative to nozzle, positive to aluminum heat bed. so now as soon as nozzle touches the bed, it registers. As accurate and precise as the new setup is, i'm still having the same issues as before, where the nozzle will scrape on the bed during auto calibration, a bit less then before now with new endstop trigger. This is current output from running a g33:

01:33:29.430 : G33 Auto Calibrate
01:33:31.196 : Checking... AC
01:33:31.199 : .Height:285.00 Ex:+0.00 Ey:+0.00 Ez:+0.00 Radius:101.00
01:33:31.201 : .Tower angle : Tx:+0.00 Ty:+0.00 Tz:+0.00
01:34:07.235 : Iteration : 01 std dev:16.592
01:34:07.238 : .Height:278.25 Ex:-4.79 Ey:+0.00 Ez:-28.19 Radius:77.45
01:34:07.240 : .Tower angle : Tx:+2.51 Ty:+5.74 Tz:+0.00
01:34:29.846 : Iteration : 02 std dev:1.503
01:34:29.848 : .Height:281.74 Ex:-2.23 Ey:+0.00 Ez:-26.99 Radius:83.50
01:34:29.851 : .Tower angle : Tx:+2.67 Ty:+5.02 Tz:+0.00
01:34:54.879 : Iteration : 03 std dev:2.902
01:34:54.882 : .Height:280.73 Ex:+0.00 Ey:-4.20 Ez:-27.99 Radius:80.43
01:34:54.885 : .Tower angle : Tx:+2.71 Ty:+4.53 Tz:+0.00
01:35:15.548 : Iteration : 04 std dev:1.409
01:35:15.551 : .Height:280.52 Ex:+0.00 Ey:-4.24 Ez:-28.68 Radius:83.31
01:35:15.554 : .Tower angle : Tx:+2.57 Ty:+4.23 Tz:+0.00
01:35:36.410 : Iteration : 05 std dev:1.507
01:35:36.413 : .Height:280.78 Ex:+0.00 Ey:-3.61 Ez:-28.83 Radius:86.42
01:35:36.416 : .Tower angle : Tx:+2.92 Ty:+4.38 Tz:+0.00
01:35:57.006 : Calibration OK rolling back.
01:35:57.009 : .Height:280.73 Ex:+0.00 Ey:-4.20 Ez:-27.99 Radius:80.43
01:35:57.012 : .Tower angle : Tx:+2.71 Ty:+4.53 Tz:+0.00
01:35:57.014 : Save with M500 and/or copy to Configuration.h

So not to terribly different, but still inaccurate. And now i know for certain that the probe is triggering fine, and not getting stuck, since it triggers as soon as it touches the bed.

I guess I haven't mentioned it yet, but this is the larger variant of the FLSun Delta, with max print area of 285 by Φ240mm. Not sure if that has an issue with current version of marlin, but its what I'm working with. I also remeasured the effector arms and they're within .2mm of one another, so not sure if that's an issue...


Edited 1 time(s). Last edit at 08/07/2017 04:53AM by Maestro.
Re: FLSun Marlin Issues
August 08, 2017 03:00AM
Seems to be something very wrong with your z-axis; furthermore an initial delta radius of 100mm on a 240mm diameter printer just is impossible.

Edited 3 time(s). Last edit at 08/08/2017 03:04AM by LVD.
Re: FLSun Marlin Issues
August 08, 2017 05:02AM
I came up with the initial delta radius via the comment made in regards to its definition. "Set the radius for the calibration probe points - max DELTA_PRINTABLE_RADIUS*0.869 for non-eccentric probes" So i took the diameter/2 for radius, minus distance from edge for clearance, times this 0.869 and got to 95.59. As far as whats wrong with Z Axis I have no clue. If i had to guess it seems that during probing, at some points during the probe, the effector wont rise high enough to clear the nozzle to the next point, as if the movement command is issued but the probing command is delayed by the movement command, thus giving false readings when its being depressed into bed. Or maybe the Auto Calibration Algorithm was not written with the dimensions of bigger deltas taken into account, causing error. I have absolutely no idea what it can be, given I'm new to the space. Just throwing in my 2 cents based on what I've observed.

I'm kinda at a standstill now, and given this is my first printer, it's kinda disheartening given that I've done everything in my power (hardware and software wise) to have a properly working device, yet it's not functioning as intended. Help would be greatly appreciated...
Re: FLSun Marlin Issues
August 08, 2017 04:42PM
The definition in Configuration.h of DELTA_RADIUS is " // Horizontal distance bridged by diagonal push rods when effector is centered.". What you refer to is the definition of DELTA_CALIBRATION_RADIUS.
Re: FLSun Marlin Issues
August 08, 2017 09:29PM
I never messed with the DELTA_RADIUS because it appeared to be a number derived from the auto calibration, however since auto calibration doesn't seem to be working for my printer, I tried different values to see how it would affect calibration. Regardless of value, the nozzle still seems to scrape. Any other idea's?
Re: FLSun Marlin Issues
August 09, 2017 05:06AM
DELTA_RADIUS is one of the parameters that defines how big your printer is. Auto calibration is not ment to determine the size and type of printer you have but to fine-tune it.

Any other idea's?

Set up your printer properly first and use the correct values your manufacturer provided.
Re: FLSun Marlin Issues
August 24, 2017 03:03PM
After shelving the project for a bit to cool my head, I returned to it with the idea of copying a lot of the Delta Settings from the manufactures config file. There were quite a bit more parameters being defined that weren't present in the newer firmware. So after I copied/pasted these setting, ran a m502 and m500 it now seems to be tracking properly and Auto Calibration now seems to be working properly.

One of my concerns now however is that right now, I have the negative lead for the Z Probe connected to the top of the hot end, and the positive lead connected to the bed, so as soon as the nozzle touches the bed it registers. While this is working beautifully, my concern is that when I apply power to the heating element, the positive lead of the heating element may supply power to the negative lead of the Z Probe, thus possibly overloading circuit controlling the probe. I'm not as concerned for the positive lead for the Z Probe connected to the bed because the heating element appears to be completely insulated. From what I understand about electricity, it follows the path of least resistance, and the heating element for the hot end generates its heat from lots of resistance, so if I have the negative lead of the Z probe affixed to the hot end, wouldn't it be less resistant to pass through the probe lead even if the connection is further? I'm also unsure of how electrically self contained the heating element cartridge.

So question is how safe/unsafe is having the negative lead from Z Probe affixed to the hot end while applying power to the hot end heating element...
Re: FLSun Marlin Issues
November 04, 2017 01:35AM
The heating element should be electrically isolated from your bed. If it weren't, you would have a serious shock hazard when the heating element is energized. You can check that with a meter. Do a continuity check from the positive heater bed lead (disconnected from the board) to the endstop lead (also disconnected from the board).

Now, over time, the insulation may breakdown with the heating processes. Then it may fry your board. Although I like the concept, I don't think I would do it that way because of that risk. With this configuration, you would have to change the Z endstop true or false statements. On my FLSun, the switch is closed until the head lifts when it hits the bed. With your connection, it would be open until the head touches the bed. It makes me wonder if this is your autocalibrate problem. Your printer is looking for a change from high to low and it is getting a low to high.
Sorry, only registered users may post in this forum.

Click here to login