Welcome! Log In Create A New Profile


Endstop Error: Z-Tower incorrectly moves after home.

Posted by StalkerFox 
Endstop Error: Z-Tower incorrectly moves after home.
September 27, 2017 04:41AM
Hi All.

A few months ago my D-Force delta burnt its board. I am not sure what caused it but the DC input terminal melted and left a holed in the circuit board. I initially wanted to replace it with another MKS board but figured I might as well go for something else as part of learning experience. After a long wait I received my MicroMake Makerboard Mini (Ramps 1.4) controller board and spent the weekend rebuilding the printer with new linears and magnetic effector joints. Loaded the firmware (Repetier) but for the love of me I couldn't get the machine to run anywhere near level. After a full day of re-checking everything I noticed the Z-tower endstop behaving as follow:

When I home all the axis the Z-tower carriage touches the limit switch, triggers it and then fails to match the movement pattern of the other towers. Instead of touching, moving down 5mm, touching and then finally moving down 3mm it barely resets the limit switch. The effect is that the Z-tower is 4mm higher than the others.

I figured it might be the limits switch. It tested fine, normally closed with snappy and predictable motion, but I figured I could just as well replace it. I replaced it twice, with the same results.

Perhaps all my spare switches are faulty then? So I decided to switch my Z-tower wiring with my Y-tower. The result is that the Z-tower (running on the Y-tower driver) runs fine while the Y-tower (now connected with the Z-motor drive and endstop terminal) repeats the same error. I repeated the exercise, swapping the Z-tower and the X-tower which gave similar results.

My conclusion is that my wiring is working but the that error lies with the output from my Z-tower motor driver or the Z-tower End-stop terminal.

I have checked the Configuration.h file and I cannot find anything wrong with either the End-stop or XYZ movements sections (It match the code I loaded on the original MKS board).

Does anyone have any experience with a simular issue or have an idea where to start looking for a fix?
Re: Endstop Error: Z-Tower incorrectly moves after home.
September 28, 2017 05:17PM
I would have to say it is in the firmware.
Re: Endstop Error: Z-Tower incorrectly moves after home.
October 09, 2017 07:25AM
I don't know if you already solved your problem, but i experiencd the same thing with my Custom build delta when i first had it moving this saturday.

I don't know if it is the proper way to fix the issue, but i think i know somewhat what happens. I had the Z_MIN switch enabled in the config.h. Disabling this switch solved the issue and the printer homes as normal as you see here [www.youtube.com]

I guess it happens because the printer moves and when homing the z-tower the printer thinks the Z_MIN stop is triggered and thus refuse to lower the z tower. If you don't use a z-probe disabling the Z_MIN switch will solve your issue. I guess installing a Z-probe will also solve the issue as the Z_MIN switch won't be triggered when homing the towers.
Sorry, only registered users may post in this forum.

Click here to login