Welcome! Log In Create A New Profile


Anycubic Pulley Autolevelling

Posted by ccheatum 
Anycubic Pulley Autolevelling
December 30, 2017 05:26PM
Disclaimer: First post by a 3D printing newbie who is really grateful to have such a strong community of support. I have looked around a bit and not really found anyone with exactly this problem. If I have overlooked it, then I apologize. Please just point me in the right direction.

I have an Anycubic Kossel the pulley version with a heated bed and auto bed leveling. In general, it has been great. It was easy to set up and the quality of the first prints is very high. It has been a great value for the money. Nevertheless, I just ran into an odd problem. Almost everything that I have printed so far has been small enough that the extruder only samples the central portion of the bed. Yesterday, however, I tried to print something that went near the edge in the X direction. When the extruder got near the +X limit, say >60 mm, the extruder lifted up in the Z direction by nearly 4 mm. So, I started looking around and considered many of the possible problems sugested for what sounded like similar problems.

1. Mechanical - I checked for loose parts, pully carriages, rods, etc. Mechanically everything seems robust.

2. Bed level - I have run the bed leveling program several times. It seems to consistently return similar results and does not solve the problem.

3. Circular calibration print - I ran a circular calibration at 100 mm diameter, 120 mm diameter, and 150 mm diameter. At 100 and 120 mm the prints come out perfect all the way around. At 150 mm diameter, the extruder lifts about 4 mm for a region about 255 mm long along the circumference. As a result of this lift, the first layer will not adhere to the surface. Although I am unable to complete the print, that is the only part of the print that has a problem. Everywhere else around the circle lays down exactly as expected.

4. Manually checking the Z height - I have checked the Z height all over the bed manually, and the results are strange but consistent with the circle calibration prints. Everywhere on the bed except near the edge in +X, the extruder just makes contact with the bed at Z=0. Up to X = +61 mm, the Z height is exactly on 0. With the extruder at Z = 1 mm, a command to move from X = +61 mm to X = +62 mm also moves in the Z direction by almost exactly 4 mm, i.e. at X = 62 mm, I have to move the Z position to -4 mm to get contact with the bed. This offset of 4 mm persists in the X direction from 62 mm out to the edge of the bed at X = 180 mm. This offset holds for position in this X range for Y values of about 12 mm either side of Y = 0.

Although I was initially concerned that it is mechanical, the fact that this behavior only occurs in such a small region of the print space and the offset comes in abruptly rather than gradually suggests to me that this effect is probably not mechanical. I am suspicious that this problem may result from the fact that I am still using the stock 8-bit board that came with the printer, which uses Marlin firmware. From what I have read, it is pushing the board pretty hard to run a delta with auto bed leveling with this firmware on an 8-bit board. I guess my question is, am I missing anything? Is the board really the most likely source of the problem? Is there anything else I should look at?

The upshot is that I can continue to run good prints so long as I do not have to use X values larger than 60 mm in the +X direction. The rest of the platform is entirely usable. So, this problem does not limit me much. If anyone has any advice for me though, I would be grateful for your input.
Re: Anycubic Pulley Autolevelling
December 31, 2017 03:27AM
It's probably the math behind the kinematics, which crosses a red line.
Deltas can go berzerk, when you try to move the head out off the limits.
The shape of the printable area is not a circle but a triangle with rounded corners.
If you have to print wider things, the only way is to use longer rods and loose some z-height.
Re: Anycubic Pulley Autolevelling
December 31, 2017 10:16AM
I think you stepped into that typical Anycubic Kossel trap. They are nearly all delivered with the same bug.

Balljoints degree of freedom ist limited by screw heads. Have look at you balljoints!

Lars - Blog, Thingiverse, Git

After successfully ignoring Google, FAQ's, the board search and leaving a undecipherable post in the wrong sub-forum don't expect an intelligent reply.
Sorry, only registered users may post in this forum.

Click here to login