Welcome! Log In Create A New Profile


Delta printer stopping after print start

Posted by CrisCG 
Delta printer stopping after print start
March 14, 2019 04:44PM

I have a 3d printer that i made with parts from ebay, 310mm bed, arduino mega and RAMPS 1.4 with DRV8825 stepper drivers, 12V 360W power supply. I run repetier firmware with repetier-host.

It's been printing fine for about 2 years. I solved everything that came up, to the point that i could just leave it printing and go and do my other things.

Recently, it started randomly to have a problem, when i was starting a print, after about 15-20 seconds, it would just stop printing without any error. The extruder and bed would get set to 0 degrees and the steppers would stop, almost seemed like somebody pressed the reset button.

Now it's doing it more often. Occasionally it will finish even a 2h print, if it gets past the first 30 seconds without stopping. I don't know what i would need to change. Please give me an idea.

I'm printing in PLA extruder 210 and bed 60.

PS: I thought it would be something set wrong in repetier-host (no error appears in log file). So i fired up Simplify 3D, and looking at the communication windows, when the problem occurs, it would say RECEIVED: wait. And this message would appear once every second until i exit the program.

Maybe something is fried on the RAMPS board? I have the bed wired through the board, maybe i should go with a relay instead in the future.

Thank you,
Re: Delta printer stopping after print start
March 15, 2019 11:45AM
May be the printer is entering a save mode when it detects failure in a temperature sensor?

Try to follow temperature while moving/bending cables leading the temperature probes. If this leads to spikes in the measured temperature then you need to fix the cables.
Re: Delta printer stopping after print start
March 16, 2019 12:55PM
Hi hercek,

Thank you for the reply. Unfortunately, doesn't look like one of those kind of fails. I've had some of those at some point, but this is a bit different. The temps stay steady when the problem occurs.

I always print the first layer crazy slow. And i mess around a bit with the Z babystep. I noticed that when it is going to stop the print, before it does so, the display freezes for a few seconds, then works for just a blink and freezes again, and it does this 3-4 times, then it just stops the steppers, sets the temps to 0 and that's it. I will try to make a video of it doing this. Maybe it helps clear up things a bit.

Thank you again.
Re: Delta printer stopping after print start
March 17, 2019 07:45AM
If you did not change firmware and it is not a simple safe mode then it is likely you have some kind of hardware error.

The only way how I can imagine a firmware problem is the overflow in the accumulated statistics (e.g. the filament printed). You can reset it to zeroes whether it helps. But I doubt it.

Most likely there is a problem with power source. The rest of the electronics is possible too but less likely. It is easy to check a different power source since you use 12V. You probably can borrow some PC power source and check with it.

You can try a dry run mode to see whether the the problem happens. This will result in lower power consumption (since heaters are not running). It does not rule out power source as a reason for problems. You could do it only with an oscilloscope in trigger mode. If you have one then this is easy to check.

You can verify whether the firmware goes through a reset with some calibration data which are not stored in EEPROM. You would check whether the calibration data are still there after the printer misbehaves.
Or you can use the set pin gcode to test for a reset. You could set some unused external pin with it to the non-default value, start a print and if the pin is still set after the failure then MCU did not reset.
But I'm not sure how much knowing whether reset happend would help. Based on your description the MCU either resets or firmware goes awry. And it probably goes awry because of a hardware problem since it worked fine before.
Re: Delta printer stopping after print start
March 18, 2019 02:59AM
Yes, a dry run eliminates the problem. I guess the simplest thing i can do is to test with another power supply. I do have another printer but it would be a pain to swap the psu, i will just buy another one and see what is what.
Re: Delta printer stopping after print start
March 19, 2019 11:47AM
Coming in late here:
To me, this sounds like a firmware error. If you run a print several times, does it stop at the same place every time? If so, then it could be an processor overload issue. Try reducing DELTA_SEGMENTS_PER_SECOND and see if that changes anything.

Replicator 1 dual, Leadscrew based delta printer
learn more
Re: Delta printer stopping after print start
March 19, 2019 05:55PM
I haven't had time to play around with it yet, just the dry run test.

Yes, it does stop in the same place every time. The strange thing is that i haven't done anything to the settings in over a year now. So seems kinda strange that would happen by it's self. But i can also try that, for sure.

Edited 1 time(s). Last edit at 03/19/2019 06:59PM by CrisCG.
Re: Delta printer stopping after print start
April 14, 2019 10:55AM
I just installed a new PSU and it does the same thing. So much for that, i guess it's the either the arduino or the RAMPS. What do you think?
Re: Delta printer stopping after print start
April 14, 2019 02:47PM
I had the same problem once (Repetier. etc.).
I never was able to diagnose it; but printing from SD card worked.
Re: Delta printer stopping after print start
April 14, 2019 03:33PM
Hmmm, it does stop at the same place every time? That would indicate more of a SW problem.
What about the old Gcode files? Do you have some which worked before? If yes, does it still work?

If it still works then it indicates that maybe it is a software bug you never hit before. If so you can try to upgrade/change firmware. If it is a software problem then this should fix it.

If you cannot borrow a different RAMPS or Arduino then I would just buy new electronics and go for a 32 bit one.
Well, you can try to replace electrolytic capacitors. Those are most likely to fail from aging. Probably not worth a try.
Re: Delta printer stopping after print start
April 17, 2019 01:34PM
YES, i have old files on SD card and they still work. I'm not sorry i changed the PSU, the fan was making a loud noise. It was good enough for a cheap 10$ PSU.

And yes, same place every time.

I will go for a firmware update and report back.

I do have a RAMPS somewhere around here, i just have to search for it.

I want to fix it and then sell it. I have to deltas with 310mm bed. So i will sel both and i want to go for a Creality CR-10 next. So i won't be investing in much better electronics in this case.

Thank you for the replies. All are very good ideas.
Re: Delta printer stopping after print start
May 02, 2019 03:48PM
I replaced the PSU, then RAMPS 1.4 and now the arduino mega... and it's the same.
Re: Delta printer stopping after print start
May 02, 2019 04:07PM
Looks like it started working after i reduced the printing segment/s from 180 to 100. I printed for almost 3 years with 180 and didn't had any problems. I don't understand why it would be a problem now. But it work with the new 100 segments/s setting.
Re: Delta printer stopping after print start
May 02, 2019 04:14PM
Wat about different slicer or updated firmware?
Because if it stops always at the same place and the old files work than it indicates a SW problem. Maybe slicer sends some crap to the firmware or firmware cannot handle some special sequence of (otherwise valid) G-codes.

Here is the point. If an error is deterministic and at a location where no new hardware is en ganged the first time then it is likely a software problem.
If the error in not deterministic and the system worked before with variety of input then it is likely hardware provided that no new SW features are used (which were not used before).
Otherwise there is no easy way to guess where an error is.
Re: Delta printer stopping after print start
May 02, 2019 04:17PM
Big segments per seconds can lead to line buffer under-runs depending on the specific g-code. Normally buffer under-runs do not cause any problem except shuttering. No idea how it could lead to a stopped print in your case.

Anyway 100 segments per second is perfectly big enough value. You can even go to about 80 segments per second to save some MCU time.
Sorry, only registered users may post in this forum.

Click here to login