Welcome! Log In Create A New Profile

Advanced

Delta x and y are crawling..

Posted by pilot error 
Delta x and y are crawling..
January 30, 2020 09:49AM
Hi this looks like a great place to ask for help spinning smiley sticking its tongue out

So... my lil flsun kossel mini has been awesome, until the thermister wires managed to loosen their shielding and the bare wires touched inside the hotend, thus releasing the blue smoke contained in a part on the main board, an MKS Mini-B V1, rip!

Enter a brand new BTT SKR 1.3 32 bit board with new A4988 stepper drivers, was planning to upgrade them once I got the gist of the new board.
I tried a few different firmware's trying to get my head around using VSCode, wow what a trip it is for an idiot to try understand lol but I managed to get only one firmware compiled without errors
and it did print ok, just had a few issues, like homing was painfully slow etc, so I tried some more most of them failed to compile with a multitude of errors, or all of the errors lol so the current one seems to be the one, it compiled with just a few tweaks and uploaded to the SKR board, all is working well, even the heated bed, which I have never used untill now..

The only problem I have now is the X and Y movements are slow, like agonizingly slow, think 90 year old lady walking across an empty football field!
The other movements are fine, super in fact, homes just the way I want it, FAST!

I have a video that I will link and also copies of my Configuration.h and Configuration-adv.h files I put on google drive,
Hopefully it is a simple thing that my idiot brain is missing, all speed settings are the same feedrate, steps per mil etc, I think anyway,

I would be so grateful if a delta expert could take a look at my stuff and point me in the right direction smileys with beer


Delta movement video..

Config.h

Config-adv.h


FLSUN Kossel mini on SKR 1.3 Still on the learning curve smiling smiley
Re: Delta x and y are crawling..
January 30, 2020 05:08PM
First problem that I see is that you have your steps/unit wrong.
The A4988 can do up to 16 microsteps, you have yours set to 64 microsteps, so that will be a problem with speed and scaling.
Your slicer will typically control how fast you move the head around, so check your speeds set up in your slicer.

DLC


Kits: Folgertech Kossel 2020 upgraded E3Dv6, Anet A8 upgraded E3Dv6, Tevo Tarantula enhanced parts and dual-head, TronXY X5SA Pro(E3Dv6).
Scratch: Large bed Cartesian, exchangeable heads, Linear slide Delta, Maker-Beam XL Micro Delta, 220x220CoreXY.
Re: Delta x and y are crawling..
January 30, 2020 05:18PM
HI dlc60,

thanks for the help, wow had no idea steps were out by that much!! have since managed to install another firmware, the Anycubic kossel from the newest examples folder on github, and it seems to be working perfectly after a few tweaks.
I will go back and check the old firmware and learn how to identify the error in steps, again, thanks for the reply,

Test cube time lol
Sorry, only registered users may post in this forum.

Click here to login