Welcome! Log In Create A New Profile

Advanced

FLSUN QQS irregular first layer - Out of ideas

Posted by Mils24 
FLSUN QQS irregular first layer - Out of ideas
May 13, 2020 03:28PM
Hello All,

Long story short..

I am trying to help my friend with his FLSUN QQS first layer problems. I have been printing for a long time and have tried everything I can possibly think of but still it is not working.

The problem is the first layer bed adhesion is very sporadic. Initially the printer was working fine and now its not.

After two to three weeks of 'troubleshooting' this is the best we can get now:



As you can see there are dramatic changes in nozzle to bed distance over very small areas of the bed. This of course leads to jams and scored beds.

Things we have tried and have made no difference:

1. Auto levelling with stock FLsun firmware
2. Updating FLSUN Firmware
3. Full mechanical check for cracked, broken, loose parts
4. Trying to use some of the Auto Calibration commands on the FLSUN stock firmware which is a branch of Smoothieware - This didn't work as FLSUN seem to somehow locked some of these features from working. This led on to us trying Marlin as it would not be 'locked'
5. Flashing latest Marlin 2.0.5 to try auto calibration and levelling through it - didn't make any difference
6. Flashing a branch of Marlin Bugfix 2.0.x from an FLSUN Facebook group - no difference
7. Flashing stock Marlin Bugfix 2.0.x - no difference

For each of the different firmware flashes the auto levelling feature simply doesn't work. The script runs and an M503 command in pronterface returns all the point data. However during a print it does not look like the bilinear mesh data is being used. (M420 S1 is in the start script after the G28 to turn bed levelling on)

Finally with stock Bugfix 2.0.x currently in the machine we manually levelled the bed last night which has resulted in the picture above. This is the best the printer has been in about a month. To get this we had to adjust the delta radius down by approx 2-3mm.

So my questions:
1. has anyone seen such drastic changes over a bed in such small intervals?
2. does anyone know why the bed levelling mesh doesn't seem to be being applied during printing?
3. does anyone know why we would have to of changed the delta radius value to much when it was printing fine with stock radius values a month ago?

Any and all help greatly appreciated. Im at the end of my weather with this one.
Re: FLSUN QQS irregular first layer - Out of ideas
May 19, 2020 09:57PM
I have a similar printer and used many versions of Marlin. For me ABL seems to make things worse than better and I just keep it off. I have no proof but I suspect:

1) ABL has been broken for Delta machines(or more?) since 1.1.9.
There are other tickets open for ABL but this is one I am following [github.com]

2) Autocalibrate isn't very good.
I've messed with this a lot and I came to the conclusion that it gets kind of close then I print this thing [www.thingiverse.com] about 5 or 6 times adjusting the endstops. The result is not great but functional. I've manually calibrated the machine using [escher3d.com] and it seemed to be more accurate but more of a pain (warning: the Marlin setting is missing values and requires additional fiddling).

3) Deltas are a second class citizen.
Last I read none of the developers use a Delta so it seems more likely regressions will slip in unnoticed.

Have you tried using vanilla Smoothieware?
Re: FLSUN QQS irregular first layer - Out of ideas
May 20, 2020 01:03PM
Thanks for the reply the hankinator, I did look at going back to 1.1.9 as I had seen a few people saying that it worked but unfortunately I don't think it works with the MKS boards.

Ive also been following a few threads about ABL not working. You may see a familiar username in them as my own delta is also suffering from no ABL along with my friends in this post above. I was prioritising getting his sorted as I can use some of my bed at least.

I will have a go at the escher3D calculator and try the manual approach again. What setting are missing in Marlin that you mentioned? Could you give me a little more detail on that?

Finally yes I was thinking about trying vanilla Smoothie however I have read that MKS is not too well liked at smoothie and therefore I thought it could end up being another waste of time trying to get it working.
Re: FLSUN QQS irregular first layer - Out of ideas
May 20, 2020 02:40PM
You can also run RepRapFirmware on MKS 32-bit boards.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: FLSUN QQS irregular first layer - Out of ideas
May 20, 2020 05:08PM
Quote
Mils24
I will have a go at the escher3D calculator and try the manual approach again. What setting are missing in Marlin that you mentioned? Could you give me a little more detail on that?

I selected the "standard" Marlin firmware type. Definitely use the preset button for positions in Pronterface or Octoprint. Be conservative with the Z value on these points, I have damaged nozzles and scratched my bed due to the following discrepancies:

1) Marlin(since like 2.0?) changed the way it uses DELTA_HEIGHT. It used to be the distance from the nozzle to the center of the bed but now it's the distance from the probe to the bed. So when you enter a value for "Initial homed height" you need to add the distance between the nozzle and probe to the current delta height (from the Delta Settings menu).
2) Don't use G30 to get the "Nozzle height error", manually lower the nozzle with endstops disabled (be careful!) to the bed. No matter what I put into the endstop setting it never changed the reading so I'm guessing it disregards them.
3) I found using the LCD to lower Z I needed to invert the value before entering it in the "Nozzle height error" field for each point
4) After you click the "calculate" button, the M665 command is incomplete. You will need to fill in the rest of the arguments (https://marlinfw.org/docs/gcode/M665.html) or Marlin will reset them to default. Also due to issue #1 you will need to then subtract the probe offset from the calculated new height. Be very careful here, verify the settings after you set them (this is where I damaged my printer).

RepRapFirmware might be superior than Marlin for a delta, it's on my todo list on my RE-ARM board. The configuration is an entirely different beast compared to Smoothie and Marlin (not in a bad way, just different).
Re: FLSUN QQS irregular first layer - Out of ideas
May 20, 2020 05:35PM
Thanks thehankinator that was super information and very helpful!! I have had a go at the escher3D calibration tool on my own delta as I no longer have access to the FLSUN machine in the image original post image.

From my stock firmware values to two iterations of escher3D I went from a SD of 0.3 to <0.04.

I then ran my test print (a series of 20mm circles around the bed) and this time the skirt stuck around the whole perimeter of the test print - first time! However my series of circles were not so successful. There was still a visible difference in the circles directly below the X tower and opposite X. Y and Z seem to be not too bad but X has a problem. I know it cannot be the rods as I made them all off a single jig, one at a time. Therefore I am going to look at the bed to frame relationship again to see if it has any deviation.

It's clear to see now that the G33 auto calibrate command in Marlin Bugfix 2.0.x does not work as well as the ABL feature. I may take dc42's advice above and look into RRF. Naively my only other delta has always ran Repetier (never had a ABL sensor on it) and when I built mine I went with Marlin thinking it was the 'daddy' firmware for printers. More research needed I think!

I am also going to get my friend to run the escher3D tool on the flush machine above. I am confident this will help and if not then there must be a mechanical issue.

Thanks again!
Re: FLSUN QQS irregular first layer - Out of ideas
May 20, 2020 10:37PM
The first time I made rods I also used a single jig that was bolted to the frame of the 2020 frame. I used the typical rod ends like these. They came out perfect, looked identical as far as I could tell. Unfortunately I kept having issues with the print head hitting the bed, calibration was always a dumpster fire no matter what approach I took. After a month or two of troubleshooting I noticed that when the print head was near the outer edge of the print area (like during autocalibration) some of the rod ends would "bind" up. Like I could no longer rotate them side to side with my fingers, the rod just felt super tight. After dinking around with tightening this or that I gave up and made new rods without those tie rod ends. Instantly improved my calibration. Might be worth a check on your printer.
Re: FLSUN QQS irregular first layer - Out of ideas
May 21, 2020 06:01PM
Yet again thanks thehankinator, Im fairly confident that my rods are pretty good. On my original delta (Kickstarter kit) I had endless problems with my rods so Im quite familiar with bad rods. On this build I have used Traxxas rod end bearings. To ensure minimal slop I bought 2 packets a used the best 12 of them all. So far they are pretty good.

However saying that I do have a set of magnets and smooth balls to install at some point as I always liked the idea of a magnetic end effector. Plus I do plan to have a quick change head system. Basically a break away loom for all my electronics and then a magnetic E3D v6 End Effector and a magnetic E3D volcano end effector than can be plugged in and used depending on the size of the print job.

You mentioned that you 'gave up' and made new rods? what did you go with the second time? Still rod end bearings, all be it a different type or did you opt for something else?
Re: FLSUN QQS irregular first layer - Out of ideas
May 21, 2020 06:58PM
In addition to the binding, they also had play in the rod end causing backlash. After doing some research I decided to try the magnetic rods like this design. It was a total disaster. The magnets are no where near strong enough to hold the rods in place. Simply homing the effector caused the whole thing to fall apart. Only after this point did I stumbled upon a forum post talking about how this approach is flawed. I don't know why there are so many designs for this approach on thingiverse when it is so ineffective. Anyway, I was determined to avoid spending yet another $50-$70 in parts that may or may not solve my problems. After a few days of searching I found the Cherry Pi III printer by AndyCart that uses the same ball end rods but with a spring/line to keep them in place rather than a magnet. I designed my own effector and carriages that allowed me to reuse the rods from my failed magnetic attempt. I been running this setup for a month or two now. I'm really happy with it, it's got excellent range of motion and as far as I can tell there is no backlash. No idea how it compares with a "proper" magnetic setup though.

Here's what it looks like right now
[i.imgur.com]
Re: FLSUN QQS irregular first layer - Out of ideas
May 22, 2020 03:01AM
oh that's a very interesting idea. I will certainly keep that in mind if my magnetic set up does not work. You now have me concerned that it is going to be a total disaster!! sad smiley
Re: FLSUN QQS irregular first layer - Out of ideas
May 22, 2020 10:47AM
If you were planning on the same approach as me (ball on the arm with magnet in the effector/carriage), I wouldn't go down that path... If I were to attempt it again, I would do the reverse (magnet in the arm with ball on the effector/carriage). Like this [www.magballarms.com] . I think the top left picture might be dc42's printer so I think there is more credibility to this approach than some rando on Thingiverse. That site sells parts to accomplish this also (I've never bought from it FYI).
Re: FLSUN QQS irregular first layer - Out of ideas
May 24, 2020 06:51PM
Interesting that you have said that. Why would you go this ways as opposed to having the ball on the end of the rod?

I have seen those Hayden Huntley arms a few times when searching about magnetic delta arms but I must say my initial thought was always to have the balls on the rods and the magnets on the end effector.

I have ordered a few other bits today however to increase the magnetic force and also reverse this to take your advice.

Thanks.
Re: FLSUN QQS irregular first layer - Out of ideas
May 24, 2020 07:30PM
The explanation I read said that if the magnets are on the effector, the strongest part of the magnetic field will be at a fixed angle. So as the effector moves the the build area the magnet field will likely not be aligned with the rod. When the magnet is in the rod, the magnet is always aligned to the rod giving it's full strength to hold the rod to the ball at any angle. It seems like the magnet must be of some strength of course but I couldn't figure out how to tell if a magnet is strong enough or not (I used N52). I really hope you have better luck than I did.
Re: FLSUN QQS irregular first layer - Out of ideas
May 25, 2020 12:52PM
Suppose that makes a lot of sense.

New part have been ordered and I will get on to designing my new effector and sliding carriage parts.

Ill come back and update in a few weeks once I get everything done.
Sorry, only registered users may post in this forum.

Click here to login