Welcome! Log In Create A New Profile


Morgan/Scara X and Y Movement

Posted by Ed_DoubleD 
Morgan/Scara X and Y Movement
January 03, 2017 03:49AM

I tried posting this on the Repreppers part of this forum but haven't had much luck thereconfused smiley...

I have just built my own Morgan but have run into some problems with my config. I can get the Z axis to operate and Home and when the extruder is at temperature I can move the extruder stepper.

The only way I can get the X and Y axis to move in Marlin is when I hit the home all axis button in Pronterface or if I run G28 (they only move a short distance, once either one of the axis hit an endstop, after multiple hits of the g28 command, they stop moving totally even when you hit g28 again).

I checked all my end stops and they are working when I run m119 they all say triggered or open when triggered or not

My x and y run on drv8825 which only has a jumper in MS3 for 1/16th and my z and e are running on a4988 which has jumpers in all 3 for 1/16th

I don’t believe there is a problem with the hardware as all motors move when I run the RAMPS1.4 TestCode.pde.

My Configuration.h file is attached Configuration.h

Please help, not sure where to start looking…
Re: Morgan/Scara X and Y Movement
March 01, 2017 09:23PM
Marlin Release What do you use? On my printer working RC1-RC6. RC7, RC8 on parallel Scara not work.
Sorry, only registered users may post in this forum.

Click here to login