Welcome! Log In Create A New Profile


Slic3r on mint 17 Qiana

Posted by v1talogy 
Slic3r on mint 17 Qiana
May 12, 2017 08:19AM
Hi fellow reprappers,

Has anyone been able to run slic3r on Linux Mint 17?

When I follow the instructions as on the slic3r website (https://github.com/alexrj/Slic3r/wiki/Running-Slic3r-from-git-on-GNU-Linux) I get stuck on the actual build of the application:

perl Build.PL

The instructions says do not build as root, but if I run it as is the compiler says it does not have permissions (creating directories) and thus fails. So I run

sudo perl Build.PL instead. It ends up saying:

! Installing ./xs failed. See /home/UserName/.cpanm/work/1494587822.18562/build.log for details. Retry with --force to force install it.
The XS/C++ code failed to compile, aborting

And the log file states:

Building and testing Slic3r-XS-0.01
-> FAIL Installing ./xs failed.

I have tried different versions of perl using perlbrew and citrus perl. I have also read most of the comments on github but can not get past that error:

The XS/C++ code failed to compile, aborting

Does anyone know what I must do to get this to compile correctly? I have also tried two of the precompiled versions from here: [dl.slic3r.org]

but the error on both tries states that it can't find: .../Slic3r/local-lib/lib/perl5/x86_64-linux-thread-multi/auto/Slic3r/XS/XS.so

ANy help or direction would be appreciated.
Re: Slic3r on mint 17 Qiana
May 26, 2017 12:05PM
Right, I seems I owe every reader of this post an apology. Firstly for posting this question in the wrong section, and secondly for using the wrong install package.

From what I can gather I have always attempted to run development packages which gave me problems as mentioned above. For reasons completely irrelevant to this problem I reinstalled the mint OS and gave this whole process another go.
After untarring the stable version and installing freeglut3 my slic3r is up and running!

I do not know if reinstalling mint made any difference but once again do apologise for this unnecessary post.
Sorry, only registered users may post in this forum.

Click here to login