Welcome! Log In Create A New Profile


pumping out to much goo

Posted by jackmanuk 
pumping out to much goo
May 22, 2013 03:22PM
after hours and hours of building my huxley , its finally up and running .... sort of .... besides the heat bed not heating and saying -40 its not he worst of my issues atm

... my huxley is pumping out to much material and making a 8-10mm wide strip, iv turned the movement upto 70 in slicer and turned the feed down to 330 but its still not a fine line,

do i need to turn the feed down more or is there something else thats causing the issues?
Re: pumping out to much goo
June 02, 2013 02:59PM
Going through the commissioning steps myself at the moment, having spent the weekend building mine.

Regarding the heated bed, the instructions on the wiring page are not terribly clear. I had crimped the wrong cable initially :/

Pin 1 - B temp +ve
Pin 2 - B temp Gnd
Pin 3 - Should be crimped and go to the second pin of the expansion port.
Pin 4 - Reserved / not used.

... now to fix a blocked nozzle....

Did your aluminium heat bed screw holes all align with the PCB/laser cut wood? or was it just mine which were a 2-3mm out?
Re: pumping out to much goo
June 02, 2013 03:41PM
yes mine did line up but one of the holes wasnt threaded in the alu plate
Re: pumping out to much goo
June 02, 2013 05:25PM
Okay, I am having the same trouble as yourself. If I raise the Z axis and tell it to extrude in pronterface and tell it to extrude I get a lovely steam of filament. But if I load up gcode made with slic3r the print head goes way to slowly and feeding out too much creating a huge blob similar to yourself.

... at the moment no idea how to fix it. - tried reducing the extrusion multiplier but no luck so far.
Re: pumping out to much goo
June 02, 2013 07:58PM
It looks like the extruder feed rate (steps per mm) in the firmware was set incorrectly.

Using pronterface, asking for it to extrude 5mm at 300mm/min, it takes ages and I end up with around 65cm or so of filament coming through - not actually connected to the hot end.

So I am going to do a firmware update.. another day, which is a shame.



line 312:
// default settings
// X, Y, Z, E steps per mm
#define DEFAULT_AXIS_STEPS_PER_UNIT {92.635, 92.635, 4000, 660}

It should be the 660 value (either as is or requires a little tweaking) - unless anyone else tries it will report back in a couple of days.


Firmware update instructions:



Setting it to 643 seemed to be about right for my machine, at least from pronterface. - I don't know what value it shipped with, but the default 660 was a lot closer to being right! Having just tried a print, I still have a blob-o-matic, so need to find something else to fix. All seems to be working!

Edited 4 time(s). Last edit at 06/03/2013 04:34AM by squeeks.
Re: pumping out to much goo
June 04, 2013 04:07PM
Ive got the same issue.
My first print was a 10mm wide strip, which should have been a single 0.5mm strip.
reprap Pro huxley.
Ive tried M92 setting down to 20, but the extrude 5mm still extrudes too much.
Is there a list of the g and m codes anywhere?
Its complicated by the fact my printer PC refuses to connect to the internet, and my mac book refuses to talk to the printer...
Squeeks, did you have to re load the firmware to get the 660 working correctly?

Re: pumping out to much goo
June 04, 2013 04:30PM
iv managed to get mine sorted ..... dont know how all of a sudden it went from the 1 cm strip to the normal strip ... now i think the system is moving to fast for the extruder yet the e steps seem right

but it dusnt matter anyway as my board seems fried
Re: pumping out to much goo
June 04, 2013 04:55PM
Hi Dave S,

Regarding a list of G and M commands, here's a list I use all the time.. [reprap.org]

I'll have a look at my seetings and see if I can come back with anything useful for you.

I've got a Reprappro Huxley (July 2012), but I tend not to use slic3r much, I prefer skeinforge myself, but that's just me.
Re: pumping out to much goo
June 04, 2013 08:10PM

I did update the firmware, but in hind sight I perhaps should have used the M codes. But up to date firmware is never a bad thing...

So I should have:

Disconnected the bowden tube and run the filament though the extruder until it is flush with the block with the motor/hobbled bolt attached.

Used M503 to list all the current settings taking note of the M92 Exxx value.

M302 - Allow cold extrusion

Tell pronterface to run Xmm through and measured where it stopped. Or G1 E100 F500 - extrude 100mm at 500mm/minute

Then work out the number of steps actually taken (distance times the number of steps per mm) and divide it by the actual distance measured to get your new steps per mm.

M92 Exxx - set the xxx steps per mm you need

M500 - Store the settings in the eeprom so it remembers it when you restart.

lifted from:

Higher numbers will give you more filament, lower numbers less.
Re: pumping out to much goo
June 05, 2013 02:43PM
Emailed RepRapPro just before heading to bed last night and they suggested a fix before this morning. smiling smiley
Im not sure of the actual cause, but issuing an M502 (load factory defaults), followed by an M500 (store them in the e2)
has fixed it.

Picture of first real print: [s306.photobucket.com]

Re: pumping out to much goo
June 05, 2013 03:23PM
better than my first print ..... and frankly after weeks of trying im still trying to get a first print .....
Re: pumping out to much goo
June 05, 2013 03:49PM
I found the build really straight forward, but then I am glad I ordered a full kit, it has all come together really well.

I do have a fully equipped tool room in the garage alread yhowever....

Re: pumping out to much goo
June 05, 2013 03:59PM
i thought some of the instructions were abit veigh and some part should of been added before the instructions say so , but i did get it together but to no end of problems with feed rate and not sticking to the bed , but i cant do anything till i get a reply from reprap for my damaged board , and if they say its not covered then well frankly they can have the hole lot back
Re: pumping out to much goo
June 13, 2013 08:00PM
Thanks Dave, I had the same problem, issuing an M502 (load factory defaults), followed by an M500 (store them in the e2)
has fixed the never stopping extruder problem I had.

My kit went together really well, however, I seem to have a lot of extra parts - screws, washers, connectors etc. left over!

Will continue on comissioning it tomorrow!
Re: pumping out to much goo
July 14, 2013 03:07PM
I had a similar issue.
When testing everytning after building my reprappro using pronterface I found that when asking for 1mm extrusion I got 126mm. Very repeatable. Problem did not disappear after reset or power down.
I tested the suggested M502 M500 but without success. Then I tried M92 E60 expecting to get about a 1/10 as much as before but I actually got a longer extrusion, about 190mm but much slower. Strange, why slower? Then I tested the increasing number of steps per unit M92 E6600. The effect was that the stepper motor was trying to step faster than possible just making a oscillating sound. I turned of the power (due to the bad sound) and after power on I did M92 E660 to set it normal again.
Now it works. Good for me but strange. I seem to be cured even after power of or reset.
(I had to tweak the value to E636 to get 100mm when asking for 100mm)
Re: pumping out to much goo
July 16, 2013 07:48AM

The order to fix this problem is M502, M500, then press reset on the Melzi. You turned off the power, which did pretty much the same thing!

RepRapPro tech support
Sorry, only registered users may post in this forum.

Click here to login