Welcome! Log In Create A New Profile


Problems after firmware upload - Marlin for Sanguinololu

Posted by kebv 
Problems after firmware upload - Marlin for Sanguinololu
June 03, 2013 04:55PM
Hi all,

I'm new to the forum (1st post), but have had a Reprappro Huxley since July 2012.
I've been using it without any major issues since Oct last year and have had many hours of good service from it (using the factory-installed firmware) but I recently decided (reluctantly I might add!) to update the firmware in order to add control of a PWM fan. Since then the printer has been not been working properly. I've tried a number of things but am not getting anywhere towards resolving the issues. If anyone can point me in the right direction or help me diagnose the issue that would be great! I must be doing something wrong, but I'm sure I've followed the instructions to the letter, several times!

Here's a bit more info:
The main issue is that all 3 axes are behaving very strangely. X seems to be reversed, Y and Z seem to travel in the correct direction when I use G1 commands. The home commands causes each axis to go in the wrong direction for about 10mm and then stop and reset the new position to home.
I've tried reversing the logic of the endstops (stock mechanical ones), but his doesn't help. If I trigger the endstops by hand and press home the axis moves in the correct direction (towards home) until I release the microswitch.
There were some other issues but I manged to figure these out.
Extruder is fine. Temps are fine too (in fact even more accurate than before).

Reprappro Huxley
Sanguinololu 1.3a with ATmega 1284p 16MHz
Current Firmaware: Marlin 1_0_4 (the latest Reprappro version on Github) [github.com]
Arduino 1.0.4 (I tried 0023 as suggested in the Sanguinololu wiki but it cant open the "project" or the sketch files) I've selected the correct board too.
I've uncommented the correct parts of the config.h tab to reflect my board and printer and did the step/mm as per the instructions.
Firmware compiles and uploads with no issues or complaint.
Pronterface connects to the printer fine.

If anyone knows what needs to be changed in the firmware I'm comfortable to do this (and learn at the same time!)

Apologies for the long post, I though I'd get as much info in there rather than just a "PLEEZZE HELP!" type job! ;-)

I'll also post in the Emaker forum under the same topic if that's ok as there doesn't seem to be anyone else having this problem (according to many hours "debating" with google!)


Re: Problems after firmware upload - Marlin for Sanguinololu
June 03, 2013 05:50PM
Did you use the reprap pro Marlin fork on git hub? - -> [github.com] <- There are a few versions around, this one has some settings specifically for various reprap pro models.

Actually reading your post before replying helps...

Arduino 1.0.4 does work and you should be able to open the Marlin.ino with the application, once you've copied the sanguine hardware description into the right location... it isn't a project as I would expect in other IDE's, but just a lot of tab open in the arduino interface. But you are building and able to upload so moving on.

The home buttons will run the axis towards the switch until the switch is open (I believe). If I press the end stop so the switch opens and then press home, the axis will jump 10mm-ish away from the end stop.

Logically it would seem that changing these values in the config.h to true would be useful, which you've already tried
const bool X_ENDSTOPS_INVERTING = false; // set to true to invert the logic of the endstops.
const bool Y_ENDSTOPS_INVERTING = false; // set to true to invert the logic of the endstops.
const bool Z_ENDSTOPS_INVERTING = false; // set to true to invert the logic of the endstops.

Check first physically whats happening with a multimeter. Secondly make sure you are doing clean between builds to ensure you are uploading the changes you think you've made. You can verify your uploaded file using the STRING_VERSION_CONFIG_H and STRING_CONFIG_AUTHOR values which are echoed back to you when the printer starts:

Printer is now online.
echo:Marlin 1.0.1 RRP
echo: Edited 4 time(s). Last edit at 06/04/2013 03:00AM by squeeks.
Re: Problems after firmware upload - Marlin for Sanguinololu
June 03, 2013 05:59PM
Hi Squeeks,

Yeah, that's the one I've been using, the reprappro fork of Marlin. I think your link is the same as mine. :-)

Re: Problems after firmware upload - Marlin for Sanguinololu
June 03, 2013 06:26PM
Sorry I didn't read the post fully before replying and you got to it before I finished re-editing my comment. Sorry about that.

It looks like you are doing the logical things as far as I can tell, without delving into the limit switch logic and staying in the config files. So I would make sure they steps you are running through are actually doing the things you think you are telling them to and there are no artefacts lying around that are getting caught in the build and deploy steps. If you are using the arduino ide you only really have verify and upload, so it should be fairly clean.
Re: Problems after firmware upload - Marlin for Sanguinololu
June 03, 2013 07:16PM
No worries, looking back it's actually quite a lot of reading in that first post! :-)

Thanks for the pointers. In the beginning I did make a couple of changes at a time to different firmware variables which probably wasn't helping. As you suggested I've made one change at a time and renamed each new version so I don't get out of step....

So, I've got the axes going in the correct directions now, changed in the config.h file. I was reluctant to do this originally as the F/W version is for a Huxley and the mchine was working fine last week, but perhaps the latest new Huxley kits have some axes reversed compared to mine due to improvements and the newest firmware reflects this??? just a guess. (I know there was a revision to the Y-axis when I was building my kit, the instructions were out of date at the time.)

I was going to check the endstops with a multimeter next, but again I was pretty sure all 3 were still OK as nothing had physically been changed. I have set the end-stop logic back to "false" on all 3 and the endstops themselves are now working as expected. (I had read here [reprap.org] that they needed to be inverted.)

However the homing issue still remains, it behaves very cautiously. When I command all or an individual axis to home it will (as expected) jump away ~10mm and slowly travel towards the endstop about 20mm, but regardless of whether the endstop itself has been triggered the axis stops and sets that as the new home position. I have to keep pressing home to to get it to reach the actual endstop. After that all is well until I press home or G28 again....
Could it be something to do with the M208 values or something?

I might think it over in my sleep.... thanks for your help so far.

Edited 1 time(s). Last edit at 06/03/2013 07:19PM by kebv.
Re: Problems after firmware upload - Marlin for Sanguinololu
June 04, 2013 06:31PM
All sorted now. It was the issue with the max travel values (M208) being set to 0, so the printer thought the axes can only travel 0mm.

Thanks for all your help and to jmgiacalone too over on the Emaker forum who diagnosed & explained the above.

Re: Problems after firmware upload - Marlin for Sanguinololu
June 04, 2013 08:14PM
Glad it is all working - just starting to discover G-code. Interesting that your max travel managed to get set to 0 during the update.
Sorry, only registered users may post in this forum.

Click here to login