Welcome! Log In Create A New Profile


Upgrading firmware to later/latest Marlin

Posted by epatel 
Upgrading firmware to later/latest Marlin
February 15, 2014 10:12AM
I have an older RepRapPro Huxley. Delivered early 2012 (I think). I built it a few weeks back, actually got it to print pretty good I think. One of the first things I did was to update the firmware to the current at [github.com]

But I am also looking into upgrading it with LCD etc. Have been looking into the latest Marlin at [github.com] which seem to have a number of enhancements. Specially interesting did a pull request seem to be, manual bed leveling [github.com]

I am now trying to configure this for my Huxley, here is my first stab [github.com] Most of the updates I found by diffing against the reprappro repo.

Any comments? Anything I have missed? Am I risking anything to try this? Major difference seem to be the thermistor tables/function, anyway to test first to see I get right values?

Will appreciate any comments,
Re: Upgrading firmware to later/latest Marlin
February 19, 2014 07:56PM
This is great! I got both the new firmware running, just one little issue with the temp reading of bed, and got this manual bed leveling.

But this bed leveling was just great. I first tried to print 9 small discs w/o fw update and leveling. It was very obvious the bed wasn't leveled enough. It was ok in the middle, where I have until now only printed a couple small pieces, but in one corner it was to low and in the opposite to high. I updated the fw + double checked as much as possible (minor changes, will update github shortly) made the bed leveling procedure as above (took a few tries before I got it), and then printed, and it worked!

Very happy! Video proof [www.youtube.com]

The bed temp is reporting appr. 10-15 deg to low. Any suggestions? Think I have selected the right thermistor. Should maybe integrate the RepRapPro table-less solution.

Configurations here: [github.com]
Re: Upgrading firmware to later/latest Marlin
February 20, 2014 03:48AM
I have also had success but had similar bed temperature problems.

I tried implementing algebraic temperature calculations which is used in the Reprappro firmware but got errors when compiling. Unfortunately I have have very limited programming knowledge, perhaps someone can assist? I found this :


As a interim solution, I measured the bed temperature with an IR thermometer and found thermistor 1 to be only a few degrees out and increasing the bed temperature for PLA to 61°C seems to compensate for the different resulting in a surface temperature of 57°C.

Thanks for sharing the link and your merge.


Edited 1 time(s). Last edit at 02/20/2014 03:49AM by paulnd.
Re: Upgrading firmware to later/latest Marlin
February 20, 2014 04:51AM
Yes, am thinking of doing that too. But I also looked a little at the table values for type "8". It looks both short and a little off. I tried to generate a new table with the help of the values from the RepRapPro version (i.e. BETA=4100) and will maybe try that first.

Note: Thanks for the blog link. Have missed that, but recognise the code which is maybe a little updated in the RepRapPro/Marlin repo.

Edited 2 time(s). Last edit at 02/20/2014 01:45PM by epatel.
Re: Upgrading firmware to later/latest Marlin
February 21, 2014 12:37PM
Yes, the problem with the temp reading was the temp table for type "8". Generated a new one with 100K, beta 4100 and R1=4.7K and this worked perfectly. Will commit changes soonish...

Edited 1 time(s). Last edit at 02/21/2014 12:37PM by epatel.
Re: Upgrading firmware to later/latest Marlin
February 22, 2014 03:48AM
Thank you for the temp table
Re: Upgrading firmware to later/latest Marlin
February 22, 2014 05:26AM
Please note that if you are looking at my commit with the temp table I happened to commit the E step value I measured on my Huxley (910, default is 875).

Line 405 in Configuration.h [github.com]
Re: Upgrading firmware to later/latest Marlin
June 11, 2014 11:33AM
I have updated my Huxley to the latest Marlin firmware. It is now working with bed autoleveling.
I have successfully printed a number of items using it. The autolevelling is not 100% reliable yet, but that could be my hardware. You just need to watch it and if it is wrong restart.

The files I changed are attached. Also included the Openscad parts for mounting an SG90 servo and micro switch.


Sorry, only registered users may post in this forum.

Click here to login