Welcome! Log In Create A New Profile


gcode epic fail

Posted by 4ndy 
gcode epic fail
April 13, 2011 01:24AM
I've just got started with my newly built mendel on Gen6, and repsnapper is confusing the hell out of me.

For starters, it won't accept half of the STL files that I try to feed it, exported from solidworks.

Now when I try to make gcode for one that works (a small triangle key I made), I get this:

; GCode generated by RepSnapper by Kulitorum
G21 ;metric is good!
G90 ;absolute positioning
T0 ;select new extruder
G28 ;go home
G92 E0 ;set extruder home
M104 S200.0 ;set temperature to 200.0
G1 X20 Y20 F500 ;Move away from 0.0, so we use the same reset (in the layer code) for each layer
G1 F70
G1 Z0.2 E0 F70
G1 F70
G1 Z0.6 F70
G1 F70
G1 Z1 F70
G1 F70
G1 Z1.4 F70
G1 F70
G1 Z1.8 F70


G1 F70
G1 Z21.4 F70
G1 F70
G1 Z21.8 F70
G1 F70
G1 Z22.2 F70
G1 X0 Y0 F2000.0 ;feed for start of next move
M104 S0.0 ;Heater off

As you can probably guess, all it does is get hot and go up in a straight line.
Why might it be basically missing out all the actual printing?
Re: gcode epic fail
April 13, 2011 08:03AM
I read some time ago that SolidWorks exports .stl files of, um, questionable quality. I haven't had trouble slicing a test cube or any of the other simple shapes I've done yet. I've also switched over to using Skeinforge, which is probably more robust. When you save as .stl from SolidWorks, you have an options button in the lower right of the save dialog box. Poke around in there and make sure all your settings are sane.

I don't know why RS doesn't generate any X or Y moves for you.
Re: gcode epic fail
April 13, 2011 09:24AM
Yeah I can't explain it, because I tried it on other working STLs from thingiverse and it did the same thing, only Z moves.
Any newb's guide to skeinforge round here?

Edited 1 time(s). Last edit at 04/13/2011 09:50AM by 4ndy.
Re: gcode epic fail
April 13, 2011 11:09AM
Oh, you're using Skeinforge. Did you accidentally set it to no fill and no perimiter?
Re: gcode epic fail
April 13, 2011 02:47PM
I wasn't using skeinforge before, but IRC elves fixed the problem smiling smiley thanks anyway.
Just using skeinforge instead, and set up dimensions tab so that it comes out appropriately.
Now just hunting round the flat for some acetone while the shops are shut...damn slippery kapton...

Edit: Funnily enough, skeinforge is accepting the STL files that repsnapper was rejecting, and making good print instructions for them.

Edited 1 time(s). Last edit at 04/13/2011 02:49PM by 4ndy.
Re: gcode epic fail
April 13, 2011 04:18PM
Skeinforge has some mesh healing abilities, but I don't know how extensive. I'm not surprised that it's more tolerance than Repsnapper.
Re: gcode epic fail
April 20, 2011 02:01AM
Like 4ndy, I am facing exactly the same gcode problem as you using the RepSnapper software. None of the STL files I tried generated any meaningful gcode. The RepSnapper Beta dated 24-Feb-2011 had its CONF setup with "Shell Count=0" under Printer settings. I disabled "Shell Only - no infill" and changed the Shell count=1.

With that RepSnapper generated gcodes correctly. However I am still not able to get it to generate the correct extruder on/off commands. The gcode merely moves the reprap around. Will anyone who has successfully generated gcode and printed with the RepSnapper software please enlighten newbies like us?

Edited 1 time(s). Last edit at 04/20/2011 03:09AM by Ziggy.
Re: gcode epic fail
April 20, 2011 02:33AM
I'm simply working around it by exporting gcode from SkeinForge, and then opening that in repsnapper. That doesn't seem to be working perfectly with my firmware yet, but it's a lot better. I've just given up on having repsnapper interpret my STL files.
It seems I need to add a line telling it what temperature I want after exporting with SF though, so I use "M109 S205" before it starts printing PLA, so that it's plenty hot in time.

My very limited success so far is shown in my last blog post.

GCode Guide - RepRap Wiki

Edited 1 time(s). Last edit at 04/20/2011 02:37AM by 4ndy.
Re: gcode epic fail
April 22, 2011 12:38PM
Get a copy of the free NETFABB Basic edition, and use the Repair STL functions there. I've had some good results with it.
Sorry, only registered users may post in this forum.

Click here to login