Welcome! Log In Create A New Profile


RepSnapper + Ramps and ShaperCube

Posted by stefkuhb 
RepSnapper + Ramps and ShaperCube
June 21, 2011 09:46AM

Im new in the 3d printing but i have a Shapercube with the arduino 2560 and the ramps board on it, im controlling it with the RepSnapper software
The only problem now is that when i start printing it doesn't extrude anything, while the 3 axis are moving. What could be the problem ?

btw, heres a small bit of my gcode:

; GCode generated by RepSnapper by Kulitorum
G21 ;metric is good!
G90 ;absolute positioning
T0 ;select new extruder
G28 ;go home
M104 S273.0 ;set temperature
G1 X20 Y20 F500 ;Move away from 0.0, so we use the same reset (in the layer code) for each layer

G1 F70
G1 Z0.2 E0 F70

G1 F1000
G1 X33.0555 Y18.4796 F1000
G1 X53.3355 E7.50362 F1000
G1 X53.3413 Y15.4796 E8.61363 F1000
G1 X56.5385 E9.79661 F1000
Re: RepSnapper + Ramps and ShaperCube
June 25, 2011 05:48AM
HI, I don't know if this helps but... I'm running Ramps V1.2 on a Mendal design, slicing in Skeinforge 41 but running on RepSnapper. So the difference is I'm not slicing in RepSnapper. My firmware sets the extruder speed to 620 when running SF41 gcode. Attached is my 20mm test cube placed @(40,40) on the bed. Also, I don't know anything about your machine but your temperature seems high. I'm running PLA much cooler.
open | download - 20mmbox_export.gcode (65.9 KB)
Re: RepSnapper + Ramps and ShaperCube
August 17, 2011 02:55PM
I don't want to hijack the thread but i think I'm having a similar issue.

@dean448 - That gcode worked for me, but when I try to make my own in skeinforge, it runs extremely slowly and the image over hangs the origin so my carriage keeps running into the bump stops. Also my extruder doesn't extrude. How did you make your gcode? As in, what did you alter from the stock configuration in Skeinforge?
Re: RepSnapper + Ramps and ShaperCube
August 18, 2011 01:35AM
Do u use the shapercube 2.0 with ramps ? if so try to use skeinforge with THESE settings.. that worked for me!

all other questions about the shapercube go to the IRC channel of shapercube,, real time support winking smiley

Re: RepSnapper + Ramps and ShaperCube
August 18, 2011 04:55AM
M104 sets the temperature and hands back control straight away to repsnapper, so it assumes that it has hit the target temperature already. I always manually pre-heat the hot end using repsnapper's manual controls.
See here: [reprap.org]
dean448's gcode has M109 after M104; I guess this causes the gcode to wait for the hot end to warm up.
Re: RepSnapper + Ramps and ShaperCube
August 18, 2011 08:17AM
Also, just noticed your temperature is very high!
M104 S273.0 ;set temperature
That's 273ºC! You may not even be able to get the temperature that high. ABS should be around 230-240ºC, PLA around 190-210º, though depends on your setup.
dean448's gcode has
M104 S170
So sets the temperature much lower. If you understand what your gcode means, you'll be able to troubleshoot problems much more easily.
Sorry, only registered users may post in this forum.

Click here to login