Welcome! Log In Create A New Profile


Help connecting arduino mega 1280 to ramps & computer

Posted by T-Carbs 
Help connecting arduino mega 1280 to ramps & computer
November 22, 2011 10:35PM
Okay I'm having some strange problems with running my electronics.
I'm running the Ultimachine.com ramps 1.4 and it doesn't seem to be connecting properly.
I've managed to upload sprinter onto my arduino (i think) however i come across this strange issue when I connect my Ramps to my arduino (by stacking them on top of eachother), my computer no longer recognizes it.
So when it is just the arduino, my computer works fine with it, however when my board looks like this:
It no longer works

I've tried connecting 12V power to RAMPS, however no leds come on, no other activity seems to occur either
and when I have my arduino stacked under it, there is a worrying sign that the arduino gets VERY hot between the usb port & the power plug

I'm a complete newbie at electronics, so I have basically very little to no idea what to do
Any help would be greatly appreciated
Re: Help connecting arduino mega 1280 to ramps & computer
November 23, 2011 11:44AM
Power down RAMPS and the mega board and disconnect the usb lead.
Firstly disconnect everything from the RAMPS board (stepper drivers, stepper motors, thermistors and heater connections).
Power RAMPS back up and connect the usb lead.
Now upload the RAMPS test script (link).

Now all the LED's should flash in order.
If they don't then the RAMPS board itself has an issue. If you brought a pre-assembled kit now would be the time to contact Ultimachine.

Presuming the LED's flash.
Power down RAMPS, disconnect the usb then attach a single stepper driver and motor.
Power RAMPS back up and connect the usb.
If the LED's still flash and the stepper motor rotates then power down, disconnect then add another.
If the LED's don't flash then the stepper driver is dead.

After the stepper drivers and motors test the heating connections and thermistors.

Fingers crossed it will be something small like a fried stepper driver or heating element.

PS when doing anything more then uploading firmware you want to 12v of power connected to RAMPS.

PPS. I'm only just getting started with RepRap, but the above helped me locate a dead stepper motor which caused the same issue. If any of the above is wrong can someone with a little more experience then me please correct me, as its the best way to learn.

My Reprap blog

Re: Help connecting arduino mega 1280 to ramps & computer
November 25, 2011 07:25PM
I took everything off, tried the code and put the stepper motors back on one by one, the all appear to be working
so i haven't fried anything (i hope)
Now just to upload the firmware and get things working again

Sorry, only registered users may post in this forum.

Click here to login