Welcome! Log In Create A New Profile


prints reseting

Posted by Gulf 
prints reseting
December 05, 2011 08:15AM
I have RAMPS 1.4 on my prusa, using printrundist, I've tried slicing with skeinforge and slic3r.
Problem is, the controller resets about 350 to 400 lines of g-code in and tries to start over.
I have tried different USB cords, changed power supplies, and several different files to print. I read that some folks have had luck using ferrite noise suppressors, however, the current USB cord I'm using has them on both ends and didn't help.

Any ideas?
Re: prints reseting
December 05, 2011 01:06PM
What operating system are you using?

It can be helpful if you can get any type of system log information.

Can you try with another computer? Maybe a laptop?

Re: prints reseting
December 05, 2011 02:30PM
I'm using windows xp, tried on 2 different laptops with the same result.

This is what is displayed in printrundist
ok T:176
Printer is now online
rs 0 Serial Error: Linenumber (353) is not last + 1 (0), line received: N353 G92 E0*66
ok T:158

In the log file:
Exception in thread Thread-1:
Traceback (most recent call last):
File "threading.pyc", line 532, in __bootstrap_inner
File "threading.pyc", line 484, in run
File "printcore.pyc", line 79, in _listen
File "io.pyc", line 520, in readline
File "serial\serialwin32.pyc", line 218, in read
SerialException: call to ClearCommError failed
Re: prints reseting
December 05, 2011 03:43PM
It looks like your Mega gets disconnected. I was having the same problem. I used a ferrite toroid and I gave it a couple of turns with my USB cable. It was a RAMPS 1.4 too.

Fluorescent tubes nearby made it worse.

Re: prints reseting
December 07, 2011 06:24PM
I have to order/find a ferrite toroid and I will give that a try.
Attempted to isolate the problem by unplugging everything in the room including the LED's and fluorescent lights, however had the same result with the Mega disconnecting.

misan what firmware are you running, thanks for the help
Re: prints reseting
December 08, 2011 04:14AM
I am using Sprinter firmware, however, I tried Marlin with the same results so I got back to Sprinter, which I am happily using now.

Good luck,

Re: prints reseting
December 09, 2011 07:24PM
Restart problem solved. It turns out that it was the gcode that was generated by skeinforge. When I use the reprap to slice the stl 's into gcodes it prints fine. I do not know what it is in the skeinforge code but I will try and post it up.
Re: prints reseting
December 09, 2011 07:56PM
Maybe Skeinforge is stressing more your hardware than Reprap host? I'd say g-code should not be able to freeze/reset your Mega. But I'll be interested on learning about your findings in this matter.

Re: prints reseting
December 10, 2011 09:25AM
Do you have a replace.csv file in your alterations folder? I'm guessing that you haven't removed G codes that are incompatible with the firmware and it's making the fw freeze.
Re: prints reseting
December 11, 2011 06:18PM
brnrd I do have a replace.csv file in my alterations folder. However I do not know what it does, can someone share some insight?

I attempted to modify the G codes and replaced:
and it seemed to work. thanks I will try and test it some more
Re: prints reseting
December 30, 2011 09:36PM
FiveD firmware had a bug when the speeds in the Z-axis were heigher than it could handle it would reset the controller.

Changed firmware to sprinter. I configured the latest build about a week ago and have had awesome results.
Thank you everyone for the suggestions.
Re: prints reseting
December 31, 2011 07:31AM
I have just moved to Marlin and I have liked it a lot. My prusa now shakes a lot less than with Sprinter. Now that you are changing firmware you might want to give it a try.

Sorry, only registered users may post in this forum.

Click here to login