Welcome! Log In Create A New Profile


[Resolved] Ramps 1.4 Not driving steppers

Posted by nubspera 
[Resolved] Ramps 1.4 Not driving steppers
January 01, 2012 05:58PM
I recently purchases a ramps 1.4 board from Ultimachine but I'm having some troubles getting the stepper motors to turn(or really react to being attached to the board at all)

I have loaded the testing script for ramps(http://reprap.org/mediawiki/images/0/0f/RAMPS1.4_TestCode.pde) and i find that all 4 LED's flash like(i think) they should. I also checked the voltage on the x axis pololu, which read as follows:

Vdd = 4.89
Vmot = 5.22
EN = 0.012
MS1, MS2, MS3 = 4.89
SLP = 4.45
DIR = 4.89

1A, 1B, 2A, 2B read around 0.012

The motor doesn't have any hold when both the USB is plugged in and the 12v/5v connectors are plugged in(i.e. when the arduino is running the test program) however if i connect just the 12v/5v and the arduino is not running the program(doesn't seem to run when the usb isn't plugged in) the motors have a bit of hold to them.

Any idea's what might be the problem? Also if there is any information that would help resolve the issue i can post it. I know very little about electronic components and the way electricity acts so I just don't know what info is helpful and what is clutter.

Also my power supply is a 250W ATX, but i have tried a 350W as well with the same problem.

Edited 1 time(s). Last edit at 01/01/2012 09:24PM by nubspera.
Re: Ramps 1.4 Not driving steppers
January 01, 2012 07:11PM
VMOT should be 12V, 5V is too low and the chips have under voltage lockout so will do nothing. Looks like your PSU is not wired correctly.

Re: Ramps 1.4 Not driving steppers
January 01, 2012 08:20PM
Interesting. That makes sense, but the problem i run into is finding the source of the problem.

The metrics from the power source read 5.22 volts and 12.43 volts.

I'm wondering if that means that somewhere between the power input and the Vmot there is an issue, or if the issue might be that i dont have a hefty enough wire going from my power supply to the ramps board.

Do you have any ideas where the fault might lay?

Thank you for your time, I've been to my wits end on this thing.
Re: Ramps 1.4 Not driving steppers
January 01, 2012 09:11PM
It sounds like you have supplied 5V to the 5A connector?
Re: Ramps 1.4 Not driving steppers
January 01, 2012 09:23PM
Wow, I feel like such a dunce. That was the issue, i read it as 5v+ and 11v+ instead of 5a+ and 11a+. I dont care to admit how many hours have been wasted on such a simple issue.

Thank you both so much for your help. I can finaly get my printer up and running!
Sorry, only registered users may post in this forum.

Click here to login